Yes!!! I can’t use 3.6.9 (Mac) until this has been fixed, AND, a Mac version is published somewhere.

Read More...