james_lan replied to the topic 'Driver OnStep (LX200 like) for INDI' in the forum. 1 year ago

Since I haven't updated in a bit. I fixed a bug yesterday not allowing to set the slew rate, should be in the next release.

Port 9998 has worked for quite a while.

As far as the focuser, I haven't implmented it yet. I did get into the habit of using 1 micron = 1 step in Config.h. I'd like to not break it for anyone potentially using it, but I need to refresh myself on the focuser. I'll probably let it toggle.

Couple of things on my todo list (numbered for convenience, not priority):

1. Changing the MaxRate replacement (degrees per sec)
Question on this: Would people prefer a settable 50-200%, as Degrees per sec, or the 50,75, 100, 150, 200%?
2. Intervolometer support
(Might be a priority, simply because I have some D5100s, and if I could trigger them as well as the main one in Ekos, that'd be handy until the Ekos/Kstars Imaging train gets done.)
3. Focuser Changes
4. Dew heater
5. Weather support. (Read BME280/etc)
6. Tangent arm support (Plate solve then adjust?)
7. Check backlash values (Changed to allowed to 3600)
8. DC Focuser support (Not sure if that works already or not?) Might need someone who has one to help with this.
9. TMC_SPI reporting support. (I got one for testing, and finally went to put it in on this cloudy night. I unfortunately missed the: You have to have both axis be SPI if one is, so this will be working at some point, but when is a big question. Oops.)
10. Equivalent of MoveAxis support to allow for following satellites. (Kstars issue more likely than OnStep directly, as the custom rates are added in, but Kstars doesn't have a way to send the rates/information, AFAIK)

Anything anyone else wants?

Read More...