I´ve the same compiling-error and fixed it for me, setting the include: indilib.org/forum/development/12145-erro...piling-indicore.html

Read More...

Edgar Scholz created a new topic ' Error compiling indicore' in the forum. 2 months ago

This is the error-message:

/home/edgar/astrostuff/indi/libs/indibase/indiccd.cpp:68:20: Fehler: »ostream_iterator« ist kein Element von »std«
   68 |               std::ostream_iterator<std::string>(ss, delim.c_str()));

Including <iterator> in indiccd fix this error:
#include <dirent.h>
#include <cerrno>
#include <cstdlib>
#include <zlib.h>
#include <iterator>
#include <sys/stat.h>

Edgar

Read More...

Sorry for the first instance, it was a type mismatch. I corrected it.
Yes, I went back to larger picture sizes an the driver crashed
Edgar

Read More...

This may be interesting too:

Compiled from git two days ago (sdk 1.17) Opensuse Tumbleweed, ASI1600mm-pro

Picture size:   4656 x 3522       driver-crash
Picture size:   3880 x 3520       driver-crash
Picture size:   3879 x 3520       no crash!

So, reduzing the picture size a bit let the crash dissapeare

Edgar

Read More...

Jasem, which cameras did you use?

The little ASI120mm gives no crash for me. All is fine.
The big ASI1600mm-pro crash the cam driver and finally kstars.

That´s hat happen on my Linux-PC
Edgar

Read More...

I compiled from git just an hour before. The problem is not solved: ASI1600mm-pro crash the asi-cam-driver and kstars as well.

I played a bit with this stuff
 
The crash comes in with the new ASI-Cam-SDK 1.17.  "libASICamera2.so.1.17" is a shared library and dynamically loaded. I told my system to load the old SDK instead ( "libASICamera2.so.1.16.3" ). Result: No more crash. All is working well. So going back to SDK 1.16.3 should fix the problem

Edgarp, li { white-space: pre-wrap; }p, li { white-space: pre-wrap; }

Read More...

No crash with current build and ASI120mc-s. So I changed to ASI1600mm-pro: crash.
I went back in the git history. The first time, the crash comes in, is this commit:

edgar@Edgar-Desktop:~/astrostuff/indi-3rdparty> git bisect bad d7f06e419006c9b174ee6caf2778ec3d69dc2f12 is the first bad commit commit d7f06e419006c9b174ee6caf2778ec3d69dc2f12 Author: Jarno Paananen Date: Wed Mar 31 21:41:47 2021 +0300 ASI Camera SDK 1.17 release (#371) V1.17 Fix some bugs. debian/libasi/changelog | 8 ++++++++ debian/libasi/rules | 2 +- libasi/CMakeLists.txt | 4 ++-- libasi/armv6/libASICamera2.bin | Bin 1985074 -> 2275083 bytes libasi/armv7/libASICamera2.bin | Bin 1637430 -> 1898635 bytes libasi/armv8/libASICamera2.bin | Bin 2243289 -> 2607103 bytes libasi/mac/libASICamera2.bin | Bin 3659808 -> 4208832 bytes libasi/x64/libASICamera2.bin | Bin 2286548 -> 2672576 bytes libasi/x86/libASICamera2.bin | Bin 2276422 -> 2642407 bytes 9 files changed, 11 insertions(+), 3 deletions(-)

Maybe someone of you can have a closer look into this.
Edgar

Read More...

xsnrg post=69454 wrote: <code>ACTION=="add", SUBSYSTEM=="usb", RUN+="/bin/sh -c 'test -f /sys/module/usbcore/parameters/usbfs_memory_mb && test $(cat /sys/module/usbcore/parameters/usbfs_memory_mb) -lt 256 && echo 256 > /sys/module/usbcore/parameters/usbfs_memory_mb'"</code>

I just put a PR up for the change.

Jim


 

Works, ThankYou!

Edgar

Read More...

@knro

Jasem, the rule  you´ve added does not work on my system (Tumbleweed):

edgar@Edgar-Desktop:~> cat /sys/module/usbcore/parameters/usbfs_memory_mb 16

Looks like cat /sys/module/usbcore/parameters/usbfs_memory_mb has to be set into "back apostrophes" (don´t know theright word in english :)

This is working for me:
ACTION=="add", SUBSYSTEM=="usb", RUN+="/bin/sh -c 'test -f /sys/module/usbcore/parameters/usbfs_memory_mb && test `cat /sys/module/usbcore/parameters/usbfs_memory_mb` -lt 256 && echo 256 > /sys/module/usbcore/parameters/usbfs_memory_mb'"


Read More...

"Leave usbfs_memory_mb up to system to decide instead of tampering with it"
That was the comment of the commit, Jasem did about usbfs_memory_mb.

That means, the system has to manage the size of usbfs_memory_mb itself. The problem is, Linux Kernel set the default usbfs_memory_mb to 16MB, which is too low for the bigger astro-cameras.

Before this commit, usbfs_memory_mb was set to 256MB using an udev-rule. Comparing, firecapture stable sets the memory to 200MB using an udev-rule as well.

Now the udev-rule is no longer used in indi, what means: default 16MB. Comparing, I didn´t find an udev-rule on firecapture 2.7beta, which means: usbfs_memory_mb default 16MB?

I managed this problem with setting usbfs_memory_mb to 1000MB globally, passing it as a kernel parameter on booting with grub2. Since I´m on openSUSE, I´m using Yast for this:

Yast / Bootloader / Kernel-Parameters: Add "usbcore.usbfs_memory_mb=1000" at the end of the string.

Just for info: The maximum possible usbfs_memory_mb is 2047MB. usbcore.usbfs_memory_mb=0 sets this maximum.

Edgar

Read More...

Hi Roland

This can happen, when your USB3-hub is broken (the USB3-part of it). It will fall back to USB2 an dcan see the guiding-cam and the EFW, because they are connected via USB2-cable. The ASI1600mm is connected via USB3-cable and isn´t recognized anymore.

Edgar

Read More...

Edgar Scholz replied to the topic 'Build issue - target not found' in the forum. 2 years ago

Same problem here on Tumbleweed
Edgar

Read More...

Connection tab in indi-eqmod driver: Try baudrate: 115200
Edgar

Read More...