I have always been a bit confused about the two ways I have found of entering data about the telescopes I use with KStars/Ekos/Indi. There is the 'Profile Editor - KStars'

which leads to the 'Configure Equipment - KStars' and there is the Indi mount 'Options' tab.
In a fresh installation of an Astroberry image, my usual habit is to personalise the data by entering the telescope and camera combinations I use in the 'Profile Editor - KStars'. For a recent application where I have mounted my DSLR on a SW AZGTi I setup three lenses as the telescopes on the Configure Equipment box. At some moment (not sure when) the FOV frame appropriate to one of these lenses in combination with the camera sensor, appeared on the KStars screen. I tried to change the 'Scope Properties' values in the mount Options tab but it would not accept changes and the green light turned to red. I tried changing the scope configurations with similar red light. The orange frame stayed whatever I did subsequently. I'm sure this is a bug but I don't really know what behaviour would be correct.

Read More...

I guess there hasn’t yet been a survey carried out on this. Just to say that my preferred way is to run everything on the Pi. I control and adjust things from either a Windows laptop PC via VNC Viewer and occasionally add an iPad into the mix, possibly running SkySafari Pro. I have the Pi image folder downloaded to the laptop, these days by VNC file transfer although I did have Syncthing running on both, a few weeks ago before I crashed my system after some unwelcome Pi Kernel updates. The regular downloading to the laptop PC lets me run SharpCap Pro for ‘live stacking’ on it so combining a bit of EAA with normal image capture.

Read More...

So I tried putting an old microSD card last used in March into the RPi in place of the 'mostly working' SSD. lsusb didn't recognise the FTDI device from the Pegasus PPB either and there were the usual hystrionics where neither the Sky-Watcher EQMOD mount nor the PPB were present in Ekos/Indi. So I replaced the SSD and was preparing for just working with the PPB disconnected from the USB hub since I only use this to monitor the temperature and humidity during a capture run - dew heater control is preset to be automatic in any case. However on switch on I ran lsusb and there was the FTDI device along with all the others. A subsequernt check and all devices were connected and working in Ekos/Indi. So in the meantime the only thing I had done was to remove the USB cable from the PPB to the hub and ultimately plugged it back in and all was working again. Here is the lsusb device list:
astroberry@astroberry:~ $ lsusb
Bus 002 Device 003: ID 0781:558c SanDisk Corp.
Bus 002 Device 005: ID 03c3:533f
Bus 002 Device 004: ID 0bda:0411 Realtek Semiconductor Corp.
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0403:6015 Future Technology Devices International, Ltd Bridge(I2C/SPI/UART/FIFO)
Bus 001 Device 008: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 009: ID 03c3:120e
Bus 001 Device 007: ID 04b4:6572 Cypress Semiconductor Corp.
Bus 001 Device 006: ID 04d8:fac2 Microchip Technology, Inc.
Bus 001 Device 004: ID 0bda:5411 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 0bda:5411 Realtek Semiconductor Corp.
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Read More...

Kaczorek wrote: Did you run any updates/upgrades on your system? None has been released for Astroberry in the meatime.

Not since the one which seemed to ‘fix’ the issue that I referred to in the post. After that the RPi was never connected to the internet and was always used in HotSpot mode.

Read More...

Avocette wrote:

Kaczorek wrote:
PS. if you encounter missing devices on any USB port see this post indilib.org/forum/stellarmate/7374-no-as...ct-port-mapping.html

I hope I’m not making a premature judgement, but it’s possible that the very latest RPi kernel updates installed yesterday but dated 2020-07-11 may have sorted the FTDI USB device issue. At least I have booted my equipment three times without warning messages about the Pegasus Astro PPB disconnecting. The PPB features an FTDI USB to serial chip.

Well - I've had a happy and trouble free eleven days with all my equipment working well including especially the Pegasus Astro PPB with its FDTI chip. Unfortunately, last night it was back to the old problems again i.e. if I even plug the USB cable from the PPB to the USB3.0 hub, then all the USB 2.0 devices disappear both from lsusb and in Ekos there are error messages about failures to connect to other devices. What to do now??

Read More...

Kaczorek wrote:
PS. if you encounter missing devices on any USB port see this post indilib.org/forum/stellarmate/7374-no-as...ct-port-mapping.html

I hope I’m not making a premature judgement, but it’s possible that the very latest RPi kernel updates installed yesterday but dated 2020-07-11 may have sorted the FTDI USB device issue. At least I have booted my equipment three times without warning messages about the Pegasus Astro PPB disconnecting. The PPB features an FTDI USB to serial chip.

Read More...

rishigarrod wrote: Jasem posted this on the first page of this thread:
sudo rpi-update e1050e94821a70b2e4c72b318d6c6c968552e9a2

Worked perfectly for me.

This was a way to return to the old Raspberry Pi kernel 4.19 for Raspberry Pi users from over three weeks ago. I don't believe you would be using this with Ubuntu. There have been a number of further tweaks to kernel 5.4 from RPi.org since then which for me have solved this problem. My ASI cameras are all operating properly now. One issue which has been reported elsewhere continues - it seems that USB serial interface adapter devices from FTDI don't work consistemtly. Typical products that suffer as a consequence are SW mount EQMOD EQDirect cables wuth FTDI chips, and my Pegasus Astro Pocket Power Box which includes an FDTI brand chip.But again this is in the RPi implementations.

Read More...

Ed Wilson replied to the topic 'HitecAstro DC Focus' in the forum. 2 months ago

Sorry to reawaken this thread! I’ve just come across it now that I’ve started to try to get Autofocus to work with my set up. I have a HitecAstro DC focuser V2 driving a Sky-Watcher (non-stepper) motor with internal gearbox. After initial problems with coupling to the focus shaft on my SW ED80 refractor, I am confident that a short pulse of drive does adjust focus.
My normal focus routine used a Bahtinov mask and the Sky-Watcher battery box, but I recently invested in the HitecAstro unit. I had a couple of what seemed like initial successes running Autofocus with all settings in default values. I also had a number of failures. I then switched to Linear which I understand helps to account for the inherent backlash by approaching from one side of the optimum focus position. However I now often find that a warning message from the Indi focuser driver saying words to the effect that the motor did not move, although I have heard the sound of gear movement.
For the moment I am using the Ekos focus measurements to help optimise manually 15 ‘steps’ at a time. If I run the Autofocus the initial steps taken by the algorithm mostly leave the image well out of focus. The manual step approach works well enough and is certainly more convenient than using a Bahtinov mask.
I just wondered if I have missed some useful information from this forum relating to recent upgrades in the focuser module? I have read the KStars handbook, but clearly a lot of improvements have been introduced since it was written.

Read More...

I must say I never operate simultaneously with the hand control and KStars! One issue could be that there may be a conflict between the hand control setting the ‘freedom find’ auxiliary encoders active, whereas Indi ignores them. So the hand control may not consider the Park position to be parked if the auxiliary encoders feedback a different position. Make sure you turn the auxiliary encoders off in the hand controller settings.

Read More...

By the way, if you would like to use the internal USB interface on the mount, it only works at 115200 baud setting!

Read More...

On your second issue, I use Astroberry with my AZ-EQ5 mount via the EQMod driver to steer the telescope around my targets. It works fine for me.

Read More...

Avocette wrote: I learned a new command (sudo lsusb) from your bug report, so I thought I would try it out. Before that I did a sudo apt update && sudo apt upgrade. I subsequently found that all my USB devices were listed both by lsusb and sudo lsusb. Has kernel 5.4 perhaps been fixed? My SSD installation seems to be working including the KStars 3.5.0 beta.

My optimism has been disappointed - my one device with a FTDI chip (the Pegasus Astro PPB) doesn’t seem to work with Ekos anymore. The command lsusb does list the device but Ekos struggles with and ultimately fails to connect.

Read More...

I learned a new command (sudo lsusb) from your bug report, so I thought I would try it out. Before that I did a sudo apt update && sudo apt upgrade. I subsequently found that all my USB devices were listed both by lsusb and sudo lsusb. Has kernel 5.4 perhaps been fixed? My SSD installation seems to be working including the KStars 3.5.0 beta.

Read More...