Hello Jasem, yep that sounds right to me!


Hello Jasem, this really applies to any dark frames using a dark filter.

To summarise: when EKOS asks us to "cover the telescope" for the dark frames, could we please have an option on that info screen to select the dark filter as a means of doing this?

The issue as it stands is the autofocus routine in the Capture module. I have my dark filter loaded in my filter wheel, and if I select it as I would for any other filter and ask for a run of "Light" frames, the autofocus kicks in, even if I have deselected that filter for autofocus in the filter wheel drop-down box at the top of the Capture module. The autofocus routine then fails of course because there's nothing for it to see, and the sequence is aborted.

Going through the Dark frames selection in Capture, there is the command from EKOS to cover the telescope, which is fine, but there is no option to select a dark filter, I have to go through INDI --> EFW --> Filter Wheel --> (select filter slot number), then run a series of Dark frames. No big drama, but it would be nice to do this a bit more conveniently - a button on the "Please cover telescope" popup would be ideal.

A Dark Flats selection in the dropdown box would be even better. We could run them as a separate command line in Capture, select cover telescope or dark filter, then and have the frames filed in a separate folder like we can do now with Bias/Light/Dark/Flats etc.

Hope that explains it smile.png


Mark Sandford replied to the topic 'EFW 8-Position Filter Wheel' in the forum. 2 years ago

Hello Jasem. Yes, the updated INDI driver works for the 8-filter EFW. I had to completely reinstall KSTARS/EKOS recently and it recognises it correctly.



I'm the proud owner of a dark filter, which I use for doing dark flats instead of Bias frames. My understanding (crash helmet on here!) is that Bias frames are more useful for CCD cameras whereas Dark Flats are a good way to go for CMOS. Irrespective of the debate as to which is best, Dark Flats are a very common and successful calibration method for me.

I have a dark filter on my EFW, and it works great for this purpose, because I have to do a run of dark flats every session to match my flats. What does not work is treating it as a normal filter, selecting it and doing a run of "Lights" in the Capture Module, because I have an autofocus setup, and the Capture Module always tries to do a focus run which fails and then aborts the sequence. This is what happens even when I deselect the "Autofocus on Filter Change" on the EFW dropdown box in Capture module.

I have to manually select the dark filter using INDI --> EFW --> Controls --> Select Filter Slot --> Set. Then I do a run of Darks in the Capture Module; when it tells me to cover the telescope I just hit Continue, and I do the capture.

Could I request and additional selection on the Light/Dark/Bias/Flat dropdown in the Capture module which gives the option of using a dark filter or manually covering the scope? It would save the files in a folder separate to everything else for clarity, but also circumvent the dead-end autofocus issue which aborts the sequence.



I have dark filter, and it works, but not in the way you might expect. The main headache is if you select the dark filter and then run a line of "Light" frames in the capture module, it will try to autofocus, it can't do it, and so the sequence aborts.

What you need to do is select the dark filter by one of two means:-
1. In the Capture module, use the dropdown box to click on your dark filter as if you were about to do a run of "lights" with the dark filter OR
2. Go to INDI --> EFW --> Controls --> (#slot you use for dark filter) --> SET

You will now have your dark filter in place on your filter wheel.

Now go back to capture module, select your time and number of exposures and then Dark from the Light/Bias/Dark/Flat dropdown box, and activate a line in the module. When you press play on the capture module, you'll get the instruction to cover your camera or scope, which you now have, hit continue and it will do its run.

I wish there was a way we could circumvent this and just do a run of "Lights" but with the dark filter, but it seems to not be a thing. Others have requested this feature in the past.


Mark Sandford replied to the topic 'Scheduler Start/Stop Times' in the forum. 2 years ago

wvreeven post=70044 wrote: Ekos does have this. For each job in the scheduler you can specify a specific start time:

And the number of images taken in the job determines the length of the job. It may not be as flexible as you want but it certainly is doable.

Thanks, I’ve used the start time feature, but using the “number of subs” method is not always useful. Sometimes autofocus runs more frequently, guiding pauses sometimes, or other delays, and that means the job can run well over the plan. 

I really just want an altitude limit which moves in to the next job in line, that would suit me perfectly. SGP, NINA and  APT all do that with no issues. 


Mark Sandford replied to the topic 'Scheduler Start/Stop Times' in the forum. 2 years ago

Thanks everyone, and Hy that sounds like some good work you’re doing. 

My request really is for something very very simple - stop imaging a target when it gets to maybe 45deg altitude, then start on the next one. Whatever is left that hasn’t been done I don’t care about, I’ll consider that at the next session. 

That’s all.

Yes I can set an altitude limit, but that aborts everything and parks the scope, surely building in an option to the altitude limit selection to “move to next target in sequence” is a possibility? That’s all I ever used in Sequence Generator Pro, and it worked an absolute treat. 


Mark Sandford created a new topic ' Scheduler Start/Stop Times' in the forum. 2 years ago

I rarely use the Scheduler, because it seems to lack a key feature I really need, and I do most of my sequences manually.

I live among a lot of trees and hills, and I have a pretty good awareness of when objects will appear and then disappear among my obstacles. I have used another astro program where it was very easy to command a sequence to start and stop at specific times and/or altitudes, then move on to the next object as it rose from behind my trees.

EKOS doesn't have this, as far as I'm aware? It only has an absolute altitude limit, which causes the end of the sequence when it is reached, right?


Mark Sandford replied to the topic 'EFW 8-Position Filter Wheel' in the forum. 2 years ago

Well, it worked! Thanks for the tip. But where are the devs here, this should be a very easy item to implement into the driver for a very common piece of equipment.


Mark Sandford replied to the topic 'EFW 8-Position Filter Wheel' in the forum. 2 years ago

Ah, thanks. I've never attempted that before, I'll see how I go.

Yes, would be very very handy if this were automatic, it's not like a ZWO EFW is a rare piece of gear.


Mark Sandford created a new topic ' EFW 8-Position Filter Wheel' in the forum. 2 years ago

Hello everyone. I know this has come up before, but I can't find a solution on the forums.

I've just got a new ZWO EFW 8-position filter wheel, and I went to the Indi Control Panel in EKOS to uptdate the filter slots, but it only shows five slots, not eight. However when I go to the Capture module and click on the filter wheel button it shows eight slots (which I can't edit, also the dialog on connection and startup shows that EKOS recognises an 8-position wheel.

I have updated all the latest indi drivers as of today (13APR21), and I have the latest EKOS 3.5.2 stable version. I'm using a NUC mini-PC running KDE Neon/Ubuntu.


So I've got my RPi4 running EKOS/KStars off my home network. I usually us WiFi (it's a bit flaky at times) and also an ethernet cable to my router (rock solid, but it means using a 30m ethernet cable). Fine.

My issue comes with going remote where there's no router. Friends of mine use an ethernet cable directly between the Pi and their laptop, but they are using Linux or Windows. I am, of course, using the hardest option possible, which is a MacBookPro. Which doesn't have an ethernet port. Now, I've got it working somewhat with an Ethernet cable and an Ethernet/Thunderbolt adapter, following some excellent instructions to get SSH access to the Pi, so I can reliably use the Terminal function on the Pi via my MBP. Great!!

Problem comes when I want to use the graphical interface, using RealVNC. This app is just excellent, really reliable and simple accessing the Pi on WiFi or ethernet/router, but it refuses to access the Pi using the direct connection. I have set Static IP addresses on the Pi for local, ethernet and WiFi...none of them work using the direct ethernet method, and RealVNC keeps throwing up a message saying "The connection was refused by the computer (ie the RPi4)".

Any ideas?


Mark Sandford replied to the topic 'StelalrMate App Video Tutorial' in the forum. 3 years ago

OK, thought so. I actually do have that, but back when I bought it, KStars was in the middle of a very unstable set of builds using the Mac interface, and I gave up on it. Used SGP for most of 2019, but giving KStars another go, directly installed on my RPi4 (not via StellarMate) and I'm very impressed. Accessing through VNC, not the Mac app (I couldn't bear to go there again!!), and life is good.

So just wondering if I could use my SM membership to try again, but using my current install on RPi4? Don't want to start from scratch after many hours of compiling.

I would be happy to pay for the SM app, I understand Jasem needs to make a living off this for all the time he puts in; my suggestion really is for him to set up the app as a paid item for exactly this reason.