Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

SOLVED!!!

So, embarrassingly, it was my fault - again!! The issue was with my client - NOT the astroberry server!

I did a complete refresh again and also built a new client Ubuntu device - and it connected straight away! So I started digging and discovered the original client had some hard-wired network config in it, probably from previous testing!

So, I am going to retry the astroberry_wireless script on the original SD card, but I am pretty confident it will!!

Many thanks for your support Radek - but it seems it was my fault!!

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

OK, lengthy note this one!
I reflashed the SD card and started from scratch...

reflashed SD Card with 1.1.0 image
Connect LAN cable
Power on
Ran apt update and apt upgrade
Reboot
Ran apt-get dist-update
Shutdown
Disconnect LAN
Power on
ifconfig and astroberry_vap status confirm VAP has started
Ubuntu 18.04 client connects to astroberry VAP
IP address given as 192.168.10.151
http://astroberry.local shows the welcome page but connection fails (suspect the welcome page is cached?)
http://192.168.10.1 fails to connect
Connect to WLAN using wlanconfig
Confirm connection working OK and IP address is valid
While WLAN connection is valid, go back to post [url=https://indilib.org/forum/astroberry/4829-vap-connection-issue.html?start=0#36660]HERE[/url] and follow instructions
Modify interfaces, rc.local and confirm wpa_supplicant has valid WLAN details
Download astroberry_wireless script, put in /u/l/b and chmod it
Reboot
ifconfig shows VAP up, but no IP address for WLAN
Attempt to redownload the astroberry_wireless - confirms that no network connection is present
Output from astroberry_wireless says that the password is incorrect - [color=orange]it is not![/color]
Ubuntu client connects to VAP, but cannot connect to http://astroberry.local or 192.168.10.1
Changed network settings in Ubuntu to manual IP with mask and DNS, no difference
Confirmed astroberry firewall is disabled on all 3 profiles
Retest connection to VAP - no difference
Output of iwconfig shows:
  lo	        no wireless connection

  vap0	IEEE 802.11  Mode:Master  Tx-Power=31 dBm
		Retry short limit:7  RTS thr: off  Fragment thr:off
		Power Management:on
		
  wlan0	IEEE 802.11  ESSID:off/any
		Mode:Managed  Access Point:Not Associated  Tx-Power=31 dBm
		Retry short limit:7  RTS thr: off  Fragment thr:off
		Encryption key:off
		Power Management:on		
	
Revert changes to /etc/network/interfaces
Hash out astroberry_wireless from rc.local
Reboot
Device now connects to WLAN again, confirmed by redownloading astroberry_wireless script
Ubuntu client cannot connect to astroberry.local or via IP address
astroberry_vap status confirms VAP is not started
astroberry_vap start to start VAP
Ubuntu client connects to astroberry, gets IP address but cannot connect to astroberry.local or IP addreess

I don't actually mind about the WLAN but I do want the VAP connection to work so I can use in the field - the primary goal. Any updates I need can be done when connected to the ethernet, but VAP is key!

So, I removed the WLAN settings from wpa_supplicant, removed the WLAN settings from /etc/network/interfaces and re-added the astroberry_wireless into rc.local
When I reboot, the VAP comes up, and again, my Ubuntu client connects to it - I assume, because I get an IP address - but I cannot connect to it.

Hope some of this helps!!

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

No worries, will let you go support some other issues :)

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

Just wondering Radek, if it would be easier/useful to do a complete refresh, run a complete update and then try the new astroberry_wireless sccript?
I have spare cards so easy to do....

Appreciate your support!

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

Password checked, double and triple checked. I even changed it, updated my phone, my laptop and tablet - all connected perfectly. Pi does not connect!

Entered that command and it just sits there - no output at all. I left it several minutes just in case, but nothing.

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

Doing some more digging to try and assist...

So, this line:

/sbin/wpa_supplicant -s -B -P /run/wpa_supplicant.wlan0.pid -i wlan0 -D nl80211,wext -c /etc/wpa_supplicant/wpa_supplicant.conf

Gives me no output when run at the command-line, however this line:
wpa_cli -i wlan0 status

Gives an error "Failed to connect to non-global ctrl_ifname (nil) error: no such file or directory"

I don't know if that helps, or is even relevant!

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

Hi Radek

Step 1 - Check. Removed all other interface lines
Step 2 - Check
Step 3 - Check
Step 4 - Check
Step 5 - Check

And rebooted.

So, the VAP starts, but I still cannot connect to it, and now the WLAN won't connect either.
To see what what was happening, I modified rc.local to:

/usr/local/bin/astroberry_wireless > boot.log 2>&1

Here is the result:
Checking if connected to AP.......... Not connected Trying to connect to known AP Wireless network available Connecting............................... Can't connect to wireless network. ^[[31mCheck your password and try again^[[0m Starting Virtual Access Point Configuration file: /etc/hostapd/hostapd.conf Failed to create interface mon.vap0: -95 (operation not supported) vap0: interface state UNINITIALIZED->COUNTRY_UPDATE vap0: Could not connect to kernel driver Using interface vap0 with hwaddr b8:27:eb:4f:53:4f and ssid "astroberry" vap0: interface state COUNTRY_UPDATE->ENABLED vap0: AP-ENABLED Virtual Access Point Ready [code] And again, I can see it listed, but cannot connect to it. Interesting that the connection to the WLAN failed - I have triple-checked the password and it is correct, as is the spelling of my WLAN ssid = 200% absolutely sure!!! Sorry to cause you so much grief![code]
Checking if connected to AP.......... Not connected
Trying to connect to known AP
Wireless network available
Connecting...............................
Can't connect to wireless network. ^[[31mCheck your password and try again^[[0m
Starting Virtual Access Point
Configuration file: /etc/hostapd/hostapd.conf
Failed to create interface mon.vap0: -95 (operation not supported)
vap0: interface state UNINITIALIZED->COUNTRY_UPDATE
vap0: Could not connect to kernel driver
Using interface vap0 with hwaddr b8:27:eb:4f:53:4f and ssid "astroberry"
vap0: interface state COUNTRY_UPDATE->ENABLED
vap0: AP-ENABLED
Virtual Access Point Ready
And again, I can see it listed, but cannot connect to it. Interesting that the connection to the WLAN failed - I have triple-checked the password and it is correct, as is the spelling of my WLAN ssid = 200% absolutely sure!!! Sorry to cause you so much grief![code]

And again, I can see it listed, but cannot connect to it.

Interesting that the connection to the WLAN failed - I have triple-checked the password and it is correct, as is the spelling of my WLAN ssid = 200% absolutely sure!!!

Sorry to cause you so much grief!

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

Thanks Radek!

Read More...

Darren Jehan replied to the topic 'VAP Connection Issue' in the forum. 2 years ago

Hi Radek

OK, ifconfig -a gives:

enxb827eb1a061a Link encap:Ethernet  HWaddr b8:27:eb:1a:06:1a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1033 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1033 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:77140 (77.1 KB)  TX bytes:77140 (77.1 KB)

vap0      Link encap:Ethernet  HWaddr b8:27:eb:4f:53:4f  
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe4f:534f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:91 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:14616 (14.6 KB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:4f:53:4f  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

And iwconfig gives:
vap0      IEEE 802.11  Mode:Master  
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          
wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

Thanks!

Read More...

Darren Jehan created a new topic ' VAP Connection Issue' in the forum. 2 years ago

Me again!

So, having fixed my previous issue of not being able to connect to my WLAN, I now have been trying to get a remote connection to the ABS via the VAP.
Here's what I did:

Backup the wpa_supplicant file
Remove my WLAN details from the wpa_supplicant file, to mimic having no WLAN available
Restart the Pi

The device restarts and eventually (it seems to take some time!) the astroberry SSID is visible, but I cannot get a connection to it at all - I just get "Activation of Network Connection Failed" on my Ubuntu 18.04 client.
ifconfig shows

Link encap: Ethernet HWaddr b8:27:eb:4f:53:4f
inet addr: 192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
inet6 addr: fe80::ba27:ebff:fe4f:534f/64  Scope/link
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:109  errors:0  dropped:4  overruns:0  frame:0
TX packets:144  errors:0  dropped:0  overruns:0  carrier:0
collisions:0 txqueuelen:1000
RX bytes:17481 (17.4 KB)  TX bytes:22485 (22.4 KB)

The pi is a model 3b, so uses the hostapd_3b.conf file, but just to be sure, I updated the 3bplus file with the Channel and Mode changes...

So, now I'm stuck again!

i don't think I've changed anything else in my previous WLAN issue, but if anyone has any insights, I'd be grateful!

Read More...

Darren Jehan replied to the topic 'Network issues!!' in the forum. 2 years ago

Hi Ron
My issues were my own too! I was ignoring the capitalisation in my SSID name! Once corrected, it was all good!
I'll stick with 'berry for now, but good luck with your Stellarmate!

Read More...

Darren Jehan replied to the topic 'Network issues!!' in the forum. 2 years ago

Hi Radek - thanks! Sorry for cross-posting!!

Read More...

Darren Jehan created a new topic ' Network issues!!' in the forum. 2 years ago

So, I WAS able to connect my astroberry server to my WLAN and remote onto it via the browser.... (note, was!!)

I decided to try and get the VAP working so I could connect in the field, and this is where it all went wrong!! I was not able to connect to the RPi at all using the 'astroberry' VAP, although my Ubuntu client 'seemed' to connect and receive an IP address. No matter what I tried (browser, VNC) I could not connect.

So, I went back to my WLAN to try and figure things out, and now the RPi won't connect to the WLAN at all... I've tried a static IP address, but that didn't work and now I get a "No DHCPOFFERS received" message when I restart the wlan0 interface! I can only access by plugging into the device with screen/keyboard/mouse, I can't remote to it at all...

The wpa_supplicant file shows the network correctly, and I have even deleted the entry and redone the wlanconf but still no joy!

Any thoughts??

I really don't want to rebuild if I can get away with it....

Thanks!

Read More...