Tim created a new topic ' EKOS Crash' in the forum. 3 weeks ago

I was running a session last night. This was my first run with 1.6.1. EKOS crashed, and the logs spit this out

[2021-11-14T00:23:08.558 CST CRIT ][           org.kde.kstars.fits] - Debayed memory allocation failure. Required Memory: "173.5 MiB" Available system memory: 1.679e+09

Full log is attached. I'm not sure what was happening at the time since I was asleep. Maybe an alignment after a meridian flip? I have been having issues with that with the pervious version of SM. Any help is appreciated. Thanks.

Tim

I was running a session last night. This was my first run with 1.6.1. EKOS crashed, and the logs spit this out

[2021-11-14T00:23:08.558 CST CRIT ][           org.kde.kstars.fits] - Debayed memory allocation failure. Required Memory: "173.5 MiB" Available system memory: 1.679e+09

Full log is attached. I had successfully captured 71 of a programed 90 up to this point. I'm not sure what was happening at the time since I was asleep. Maybe an alignment after a meridian flip? I have been having issues with that with the pervious version of SM. Any help is appreciated. Thanks.

Tim

  

File Attachment:

File Name: log_09-07-44.txt.zip
File Size: 3,805 KB


Read More...

Tim replied to the topic '1.5.9 Wifi Adapter Problem' in the forum. 2 months ago

For those who were on the edge of theirs seats wondering if this is fixed in 1.6..... it is.

Tim

Read More...

Tim replied to the topic '1.5.9 Wifi Adapter Problem' in the forum. 4 months ago

Still no luck. If nothing else, I'm learning a little more about RPi than I thought I ever would. Thanks for all of the suggestions. I got another adapter that is actually working, so not all is lost. Hopefully it will perform well compared to the old one. And maybe this header install problem will randomly fix itself in a future update.

Read More...

Tim replied to the topic '1.5.9 Wifi Adapter Problem' in the forum. 4 months ago

I uncommented that line in the sources.list. It did something because the sudo update command showed a few more things happening than normal. However, I'm still getting the "Unable to locate package raspberrypi-kernel-headers" error when I run the install headers command. And I'm still on the .17 version. Thanks for trying to help. 

Read More...

Tim replied to the topic '1.5.9 Wifi Adapter Problem' in the forum. 4 months ago

I ran package updater. There was plenty that needed updating. 

My version is also 5.10.17. 

That command you suggested returns the following error:
E: Unable to locate package raspberrypi-kernel-headers

Regardless, I still got the same header error when I tried to install the TrendTech drivers again.
 

Read More...

Tim replied to the topic '1.5.9 Wifi Adapter Problem' in the forum. 4 months ago

Thanks! Unfortunately it only solved half the problem. I'm getting this now:

stellarmate@stellarmate:~ $ sh -c 'busybox wget deb.trendtechcn.com/install -O /tmp/install && sh /tmp/install'
Connecting to deb.trendtechcn.com (185.199.108.153:80)
Connecting to deb.trendtechcn.com (185.199.110.153:443)
install              100% |********************************| 16512  0:00:00 ETA
Root access is required
Package manager is: apt-get
Installing prerequisites
Hit:1 ppa.stellarmate.com/repos/apt/stable buster InRelease
Hit:2 mirrors.ocf.berkeley.edu/debian buster InRelease                  
Hit:3 raspbian.raspberrypi.org/raspbian buster InRelease                
Reading package lists... Done
Couldn't detect the appropriate kernel headers package!

 

Read More...

Tim replied to the topic 'Re:1.5.9 Wifi Adapter Problem' in the forum. 4 months ago


I didn’t. I’ve had problems in the past and gotten really good customer service from BrosTrend/TrendTech. I’ve tried them multiple times, and haven’t had received a single response this time. I ended up getting a new adapter.


Sent from my iPhone using Tapatalk

Read More...

Tim created a new topic ' 1.5.9 Wifi Adapter Problem' in the forum. 4 months ago

I finally got around to installing 1.5.9. I'm running it an RPi 4 with an external SSD. I flashed the SSD with 1.5.9, and went through my usual post-update steps using the app. I have a TrendTech/BrosTrend AC3L wifi adapter which requires using the terminal to install drivers. I normally don't have any problems. This time I did. See below for a full copy/paste of the terminal text. Tried a sudo apt update and essentially got the same error public key error. I flashed SM 1.5.6 to a card and tried again. No problems there. So something changed between 1.5.6 and 1.5.9 updates (I did not update 1.5.7/8 by flashing the SSD) that is now giving me that public key/headers package error. Copying and pasting terminal code is the extent of my RPi skills, so this one is way beyond me. Any help is appreciated! Thanks. 

stellarmate@stellarmate:~ $ sh -c 'busybox wget deb.trendtechcn.com/install -O /tmp/install && sh /tmp/install'
Connecting to deb.trendtechcn.com (185.199.109.153:80)
Connecting to deb.trendtechcn.com (185.199.110.153:443)
install              100% |********************************| 16512  0:00:00 ETA
Root access is required
Package manager is: apt-get
Installing prerequisites
Get:1 mirrors.ocf.berkeley.edu/debian buster InRelease [122 kB]
Hit:2 raspbian.raspberrypi.org/raspbian buster InRelease               
Hit:3 ppa.stellarmate.com/repos/apt/stable buster InRelease           
Err:1 mirrors.ocf.berkeley.edu/debian buster InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY DCC9EFBF77E11517
Reading package lists... Done
W: GPG error: mirrors.ocf.berkeley.edu/debian buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY DCC9EFBF77E11517
E: The repository 'mirrors.ocf.berkeley.edu/debian buster InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Warning, command failed: apt-get update
Couldn't detect the appropriate kernel headers package!
 

Read More...

Tim replied to the topic 'Can not use Darks Library' in the forum. 11 months ago

alacant wrote:

attempts the process repeatedly



BUT are we sure we want to do that anyway? Subtracting a <em>single</em> dark frames introduces <em>more</em> noise. With SEP I think that unless we want to go phd2 style and make a master dark from several single frames, this feature is redundant.


Just to be clear, you're suggesting NOT using darks at all with SEP? I usually let me session run while I sleep if the weather looks good. I will occasionally get in incomplete session because the temp changed enough to trigger EKOS to ask for a new dark for my guide camera. I know I can change the temperature threshold from the default of 1 C to mitigate this, but it isn't a problem often enough, and I have a decent dark library. Thanks.

Read More...

Tim replied to the topic 'Ekos not guiding in dec' in the forum. 1 year ago

A lot has happened with my guiding... all good. I did mess with the gain which makes SEP multistar rock solid. Thanks for that advice. Long story short, the rest of the story involves a bad Mac OS Big Sur install which lead to a complete wipe of my laptop, a bad RPi update to my RPi4 with Stellarmate OS which also lead to a complete wipe and reinstall. So far, I'd say it was worth it. Some good seeing here in the panhandle of Florida is helping as well. Results attached.



Read More...

Tim replied to the topic 'Ekos not guiding in dec' in the forum. 1 year ago

I'm using a USB cable. I have no issues using the different functions of the mount, so a bad cable seems unlikely. I'm pretty much stuck at that "south weighted" distribution in the drift plot. I feel like my kit is pretty well balanced, and I know I have a great polar alignment. I'm on the coast in the panhandle of FL, but typically have pretty dark skies, so I don't think I'm limited by seeing. The only other "big" thing I can see is Ekos's ability to hang on to multiple stars while guiding. Without having actually measured it, I'd say I only see the SEP multistar lines and circles 25% of the time at best. I'm kind of at a loss on how to get better guiding at this point. I think I've got all the low-hanging fruit, so barring hardware issues, I have to think there is some setting I'm missing. I'm going to try again for a few hours tonight.

Read More...

Tim replied to the topic 'Ekos not guiding in dec' in the forum. 1 year ago

I got some pulses in dec tonight. No idea what was different. But I'm not convinced everything is working correctly. However, maybe it is and this thread is really just me trying to figure out how to guide better. Thanks in advance.

Tim

Read More...

Tim replied to the topic 'Re:Ekos not guiding in dec' in the forum. 1 year ago

I’m using SEP multistar. Just happens that it wasn’t getting all the stars in that screenshot I took. In fact, I’d say I only track multiple stars about 75% of the time. Guidescope is focused.


Sent from my iPhone using Tapatalk

Read More...