Alonso replied to the topic 'Weather radio don't want connect' in the forum. 3 weeks ago

do you have ngnix installed?

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 3 weeks ago

OK.... I had have the same pb with the nafabox project!
So, I had must to uninstall ngnix & apache2, then I had reinstalled apache2 and after it was ok!

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 3 weeks ago

Explication for my tinker: Apache2 is on the port 80.
if you go on the web and put RL:
http://ip_local
you must to see the apache2 webpage.
if you test from another PC what do you see?

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 3 weeks ago

Do you can to try the NAT. if Ok you will know ;)
In my tinker, same local, I had must to open port!

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 3 weeks ago

Hi G_Gagnon,

if you want to see the web page from another client, you must to open the port 80 in your router (internet router) for your server.
for exemple, my server is on a tinkerbaord and his name is nafabox. In my internet box I've open Nat rules 80 on nafabox!!

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 3 weeks ago

Looks like the Apache configuration file for weather radio hasn't been copied or is in a different place. Try first
sudo cp add-on/weatherradio/weatherradio.conf /etc/apache2/conf-available
and then try the a2enmod command again.

Hi, it's an error,
if you want to use a2enmod, you must to copy the file in mod-available.
Also, you must to use command a2enconf if you want to put in conf-available ;)

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 4 weeks ago

Hi,

This is my box:
2 holes:
- mlx90614
-tsk2591. There is a glass which protect the sensor about the rain.





Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 4 weeks ago

Thanks for you response.
I will try this.
If i don’t see pb, i will send you my file if you can to look!
I have just change the name of port (ttyUSB0 to Weather beacause I created a symlink)
And in the service I change root to nafa, this is the name of the user

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 4 weeks ago

Hello Wolfgang,

sorry for the response time, it was really nice.
Everything is functional except for one detail!
I created the service and the server starts well. However, despite this I have to go through my iNDI app on my phone.
To be more cair, this application allows you to see all the INDI servers running. Except, that of weather radio is active but not connected. So I do it manually just like I would in kstars.
Suddenly, the interest of the service becomes limited.
Is there anything else to do to make sure that when the service is started it automatically connects the arduino without having to go through the phone application?

Otherwise, apart from that everything is functional and really very good !!

Many thanks for all this work!

Olivier

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 4 weeks ago

I have a last question.
Everything is OK, Web and indi.
But, if I want to use the web server 24 hours a day, I have to let kstars run.
So, is it possible to make a script that starts after each reboot?
Thank you very much
Olivier

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 4 weeks ago

Hello,
I'm very stupid! I'm not a jedi and I should have seen that !! Arff
You are a boss!
Thank you :-)

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 4 weeks ago

So,

I'm happy to say you that all is good!! the indi driver and the web server!! ouahhhh very cool!!
It's perfect.

This is my weather radio web site:
176.135.77.1/weatherradio/

I've juste one question:
when I go to the web site, I must to click on the time range (6h - 1d - 7d or 30d) to see the values and the grpahs.
if I will go on your website the values is instantaneous printed.

So, do you have an idea of why I have this effect?? thank you very much.

Olivier

Read More...

Alonso replied to the topic 'Weather radio don't want connect' in the forum. 1 month ago

Hi,
You’re alright!
I’m very bad!! All is ok!!
Sorry for that! I’m tired!
Olivier

Read More...