In fact, I would like to know if it is possible to have a laptop PC running Windows 10 with Kstars installed on it which drives a Raspberry Pi 3B + running Ubuntu Mate 16.04 (Astroberry Server) on the telescope. (With Asi 385 MC, Touptek 2000kpa, Focuser and Eqmod mount) And especially the procedure to follow!

Thank you

Read More...

Good morning all . I have a box with a raspberry pi 3b + under ubuntu mate 16.04 with KStars and Indi installed on it. My CCD Zwo Asi 385 MC, my touptek 200kpa guide, the Zwo EAF focuser, the Eqmod mount and the GPS all work in hotspot. The problem is that the Pi crashes regularly and I have phenomenal latency!

So I installed on another micro-sd, Astroberry server. The pi is on my telescope and all my peripherals plugged into a powered usb hub. I start the pi, I go to my PC under windows 10 or I installed Kstars. I entered my peripherals under Kstars (on the pc). I open my internet browser, I connect to the Astroberry server and I click on the telescope icon. The I have ONLY THE SIMULATION MODE! and I can't put anything else. If I run the connection from kstars on my pc I also only have the simulators. I do not understand anything anymore ...

Thanks in advance because I missed something. My goal was to reduce the resources of the raspberry!

Read More...

Juhin Christophe replied to the topic 'Raspberry real time' in the forum. 11 months ago

It works so fine !

Read More...

Juhin Christophe replied to the topic 'Raspberry real time' in the forum. 11 months ago

Re: The Correct way to add a RTC

Quote
I finally found it. See the penultimate post on page 3:

www.raspberrypi.org/forums/viewtopic.php?p=842661#p842661


Thu Aug 24, 2017 5:54 pm
After searching for a long while, and after a lot of experiments, I've putted togheter all the information I've collected all around the Net about how to connect a realtime clock to the Raspberry and allow the OS use it as system clock even if no connections to a NTP server.
I've used a DS3231, but the following should work even with a DS1307. Just use ds1307 where into the following instructions is used ds3231.

The following, definitively worked for me, using Raspbian Jessie. So:
edit the file using sudo nano /boot/config.txt and add or modify a line that looks like the following:

Code: Select all

dtoverlay=i2c-rtc,ds1307
Edit the file using sudo nano /etc/init.d/hwclock.sh and comment out the content in order to be sure that the content looks like the following:

Code: Select all

#if [ -d /run/udev ] || [ -d /dev/.udev ]; then
# return 0
#fi

Then disable the fake-hwclock and enable the hwclock.sh with the following group of commands:

Code: Select all

sudo apt-get remove fake-hwclock
sudo rm /etc/cron.hourly/fake-hwclock
sudo update-rc.d -f fake-hwclock remove
sudo rm /etc/init.d/fake-hwclock
sudo update-rc.d hwclock.sh enable

Then modify the file using sudo nano /lib/udev/hwclock-set locate the following lines and be sure to comment it out:

Code: Select all

# if [ -e /run/systemd/system ] ; then
# exit 0
# fi

Now, create two system services in order to set the system's clock when the OS boot and also to write to the RTC at the shutdown. So, the first one:

Code: Select all

sudo nano /etc/systemd/system/hwclock-start.service

...and paste in it the following:

Code: Select all

[Unit]
Description=Set time from RTC on startup
After=network.target

[Service]
Type=oneshot
ExecStart=/sbin/hwclock -s
TimeoutSec=0

[Install]
WantedBy=multi-user.target

and the second one:

Code: Select all

sudo nano /etc/systemd/system/hwclock-stop.service

Paste in it the following:

Code: Select all

[Unit]
Description=Synchronise Hardware Clock to System Clock
DefaultDependencies=no
Before=shutdown.target

[Service]
Type=oneshot
ExecStart=/sbin/hwclock --systohc

[Install]
WantedBy=reboot.target halt.target poweroff.target

Finally, enable the services issuing once the following command:

Code: Select all

sudo systemctl enable hwclock-start hwclock-stop

You can also verify that the RTC module has been loaded using

Code: Select all

sudo lsmod

Read More...

Juhin Christophe is friends with gehelem

Juhin Christophe replied to the topic 'Raspberry real time' in the forum. 11 months ago

Thank you for your answers . I finally opted for an rtc card based on 1307. But if I type sudo hwclock -r the clock is on time but not the system time even after reboot. . If I type sudo hwclock -s the system is set to the correct time but after a reboot I still have the old system time and if I type sudo hwclock -r the time and date are correct. How to have the right time when starting the raspberry? I'm on Ubuntu mate 16.04. Thanks in advance friends

Read More...

Juhin Christophe replied to the topic 'Raspberry real time' in the forum. 12 months ago

Thank you for your contributions . But none of the solutions work for me. I am running Ubuntu Mate 16.04 with a Raspberry 3B +.
In hotspot, I will continue to set the time manually.

Read More...