Terry Webb created a new topic ' Astroberry Bluetooth GPS' in the forum. 2 years ago

Very happy with Astroberry - got it running on a Pi3B+ in my obsy but using it in client/servermode with Kstars/Ekos on my MacbookPro - now got a Pi4 so I can run it all standalone for outreach but having problems trying to connect an old Tom Tom GPS device to Astroberry so it can pick up date and location out in the field or at Outreach Events. Currently running Astroberry 2.0.0 - have run updates and upgrades.

Astroberry Bluetooth System Icon sees GPS device but would not connect with error 'No useable services' ...

So after lots of Googling ... on INDI site and others ...

www.raspberrypi.org/forums/viewtopic.php?t=152143 Talks about adding serial connections and rfcomm

Added --compat option to ExecStart=/usr/lib/bluetooth/bluetoothd in /etc/systemd/system/dbus-org.bluez.service because Googling says Bluez 5 needs it for old devices - raspberrypi.stackexchange.com/questions/...ch-file-or-directory

Enabled Serial Communication in raspi-config - learn.adafruit.com/adafruits-raspberry-p...bling-serial-console

Updated GPSD init script for /dev/rfcomm0 etc - As per INDI forum - See attached file.

Ran hcitool to get macaddress of TomTom BT GPS Device

Ran "rfcomm connect 0 macaddress &" and device connects to astroberry pi. Have to run it as rfcomm is no longer 'bound' (?) in some Pi OSes - bugs.launchpad.net/ubuntu/+source/linux/+bug/416056

Used cat /dev/rfcomm0 and that shows some GPS data - See attached file

However even though device now seems to be connected - Astroberry GPS does not seem to get a fix - assigned GPSD as INDI device.

Can you help?

Do I have to run this? "gpsd -b /dev/rfcomm0" - although presume INDI runs that when you set up the GPSD device using the GPSD Init file.
Do I have to 'bind' rfcomm somehow - so that it connects at boot time without having to run commands.
Maybe I am just selecting the wrong devices in Astroberry/INDI?

Thanks

Terry

Read More...