Just one more observation:

cat /dev/ttyACM0 and
cat /dev/GPS0
both show U-Blox data stream which looks the same. (Data about U-blox manufacturer and some kind of numbers and letters, some of them look like coords: N*53 or N*30 and etc).


Thanks a lot for a extremely fast reply.

I do not want to bother Radek with such a small issue, he already did more than enough, dont want to waste his time.

One thing I noticed on your print screens, -
initially before your GPSMON got fix, it had the first row "tcp://localhost:2947"
once fix got
it became "/dev/ttyACM0" - this is actually the USB slot GPS dongle is attached....

In my case, it remains on tcp://localhost:2947 for ever....
So maybe, my initial tries to direct all to ttyACM0 were correct...
Will give a try once again...


stash wrote: The device I use is refered too by Ublox (mine is a Ublox 7 - quite old but works) - plugs into USB port.

Should just plug and go LOL

However here are some pointers when using Astroberry

1. VirtualGPS needs to be disabled (think its still applies - and I just tried it - it worked - see screen prints) github.com/rkaczorek/astroberry-server/issues/47

2. I find that sometimes it does not work on boot but unplugging and pluiing in the Ublox 7 makes it work - but be patient GPS fix takes time and it doesn't work indoors - so next to a window and wait if testing.

Sorry to bother again,
Can you please check how does your gpsmon window look?
Does it show U-Blox at the top or NMEA?
I tested my GPS dongle on windows, - it catches all the data and gets the fix even indoors and within 60sec.
So checked it on the fresh Astroberry install and outside (so none of my initial adjustments were in action) and I had GPS fix, - and fast, 20sec or something.
Only once... I after reboot, - nothing... It looks like data is coming in, - but no fix.
Tried to re-plug, to stop/disable Virtual GPS, - no luck..
However, I have noticed what sometimes gpsmon service shows U-Blox, sometime NMEA on the top....
also, not sure why, - data/time is sometimes correct even without the fix and sometimes it is 2019 April...


Thanks again,

Will try all that from scratch...

And why did I changed GPSD at all?
as initially it was not working at all, gpsmon was simply empty, - now it shows something (at least!) :) and all these steps I wrote, were offered on Indi for astroberry or other sites for rPi.

On windows, I was able to get data coming via its own software, but was not able to link it to EQMOD or SGP.

Anyway, - nice to know it should work almost out of the box


El Corazon wrote: I don't use Hotspot mode at home. It makes little sense to me. Jo

Agree, - unless you want to test the system before you pack out to the fields...

And thanks a lot for the static IP suggestion, as I actually had the similar issue, my rPI did not want to connect to DeVolo (Powerline - wifi extender) which was placed quite close, - rPi connection was always declined, - will test your suggestions. Thanks a lot again.


Thanks a lot,
I have not managed to find any info about the virtual PGS initially, however, my tests sho the same results as per printscreen belo.

I do receive some kind of data stream via gpsmon... but no actual fix, and cgps -s is does not show any data movement at all (kStars also)...
Maybe my back-garden is like a bomb shelter and I need to get that usb stick somewhere higher.... not sure yet...

I had to do make steps listed below to get that, - before I had no response on gpsmon at all...
1) got USB port of the GPS device by: ls /dev (checked the list with the device and with device plugged In). result: /dev/ttyACM0
2) amended /etc/default/gpsd to: DEVICES="/dev/ttyACM0"
3) sudo systemctl stop gpsd.socket
4) sudo systemctl disable gpsd.socket
5) sudo gpsd /dev/ttyACM0 -F /var/run/gpsd.sock

once On, - some data is coming in via gpsmon.... not sure what it means at all


Thanks a lot Stash,

And yes, that Comfast is 2.4ghz only, and yes my Virgin Media router had auto-channel management switched ON initially, which I have turned some time ago, however, signal is not reliable in the back-garden anyway, - router is simply way too far...
I am even amazed I can catch a signal without a repeater at all.
Will have to think how to extend the 5ghz signal probably...

As per GPS,
I do have this one www.ebay.co.uk/itm/VK172-G-MOUSE-USB-GPS...6:g:zlMAAOSwXKNdCzgI
Which I failed to use on Win10 ....
not sure it will be any use on rPi...


Thanks Doug,

The problem was similar as you advised, but a bit more complicated... :)

I am almost certain it is due to wifi repeater "Comfast CF-WR302S V2.0" I use to make wifi signal more stable in my backgarden.
Without the extender, I still have quite strong signal from the main Router, but it is not stable, sometimes it becomes very weak for no reason.
and I guess, sometimes Laptop connects to the main router, but rPi to the repeater, - they both have the same SSID name, but for some reason are treated as different networks :(
I am not sure how to fix it....
So if I switch off the repeater, - I have no problem.

However, mostly
1) The repeater is on,
2) And if I am connected to the rPi hotspot (for my tests)
3) Later I command astroberry to turn of the Hotspot
4) I presume, it should Look for the wifi on the Connection list and connect to it if it is available
5) I guess, it connects to the repeater (or main router sometimes).
6) if my win10 is not on the same device connection, I obviously try cannot connect to rPi
And at this point Win10 adds up more confusion
7) Win10 usually as still shows Asrtoberry Hotsport on the wifi list, I obviously try to connect back and fail...
Not sure what are Win10 wifi list re-fresh timings, but I think it is around 2 minutes or so....

Solutions I see:
1) Set up the repeater to work properly... - not sure how to do it... would be nice to get advice... but this one is very simple, it has no options as I recall..
2) get another repeater.... Question: which one will do the job properly????
3) Cat6 cable???? - not and option as I went rPi way to reduce the amount of the cables.
4) Get the main router closer to the backgarden? - sadly no option for that also :(
5) Else? VNC??? - will need more tests as it was very slow/laggy initially and I am not sure why.... (p.s. I previously used VNC to control win10 laptop left outside for imaging without any lag issues and on the same network).
6) else?

Once I am logged via rPI hotspot (without any internet connection), - I do see the time and date is wrong, it shows the one from last session as rPi has no internal battery to keep clock ticking...
do you guys all use
sudo date --set='2020-05-12 20:51:03'
Or maybe there is another way?

During the initial set up, - we have to add our own location details, - why not to use that out of the box?


Hi guys,
I have only basic knowledge in IT/coding and ran into strange problem...
From last week I am testing Astroberry 2.0.1 as I want to create standalone setup..

I have few issues, which I will resolve sooner or later, but the main is Hotspot connection....
<em><strong>Sometimes</strong></em>, just out of the blue, my Win 10 laptop is not able to connect to Astroberry Hotspot... Laptop is usually in around 1-2 meters distance.
rPI is powered properly.... Smartphone connects... O_o
Any ideas what I should look for?
Windows wifi connection error simply states "unable to connect"... and automatically connects to my local wifi..
Even worse, - sometimes Win10 connects to the HotSpot without any problems... So it is even more difficult to find out the real problem... And especially with a lack of knowledge.

I have not changed any Astroberry wifi settings at all, just crated a new wifi local connection which works fine and I am able to start astroberry Hotpost properly (as I want to test how it will work in the fields), I see it in the list of wifi's available, - but cannot connect <strong>Sometimes</strong>.
The only thing I was playing around with, - was trying to get rid of Warsaw as a default location from everywhere (without a success) :) .