Hello Jasem,

I sent over the link for what I think was the command set you were looking for.

Was it the correct information or is there something else you require?

Many thanks, Richard.

Read More...

 

File Attachment:

File Name: lynx_astro_dew_controllers_serial_protocol_v1.0.0_2021-05-16.pdf
File Size: 52 KB


Hi Jasem,
I am not sure but is the serial protocol information of use, see attached.

Read More...

Hello Jasem, forgive my ignorance, how would I go about obtaining the command set?

Read More...

Hi All,

I have searched the forum regarding an Indi driver for Lynx Astro dew controller and cannot see anything available.

Is there one that can be used or does one need to be written?

I know it has software for either windows based or MacOS based systems which allow manual computer control of the dew heater so thought a driver could be used to incorporate this feature in Ekos.

Any ideas would be greatly appreciated, thanks in advance.

Richard.

Read More...

Hi Jasem, I will do that tonight, thank you.

Read More...

Hello Jasem, I am a little confused here as I’m quite sure I’m using the V4L2 drivers on the Skyris, the iGuider and the iPolar.
The iPolar is recognised and uses V4L2 by default.
The iGuider is recognised and uses V4L2 by default.
The V4L2 is set in the 2nd auxiliary slot and automatically recognises the Skyris 132c, as it displays it as such in the “image info” tab.
All these are working on the Mac via KStars with the Stellarmate Plus hotspot/WiFi, not on the Stellarmate Plus vnc viewer.

Am I reading something wrong here?

Thank you, Richard.

Read More...

Hey Rob,

Firstly thank you for the build as I needed this to get the latest Indi Lib on my Mac.

I have tested this with my devices and all do connect as with the 3.5.2 and are operational, however I still have the same issue on both the Skyris 132c and the built in iGuider of the iOptron CEM70g where the pixel sizes are defaulting to 5.60.

I was informed that the latest INDI lib release should have these corrected but from your beta testing build, seems not. Unless it does not have the latest INDI release.

In the case of the Skyris 132c, the capture size is correct @1280 x 960 but the pixel size defaults to 5.60 (manufacturers is 3.75)
In the case of the iGuider, the capture size defaults to 640 x 960 (manufacturers is 1280 x 960) and the pixel size defaults to 5.60 (manufacturers is 3.75)

iGuider logs:
2021-05-05T09:27:50: [INFO] For future autodetection of pixel size, please report the following: Reported Name: iOptron iGuider: iOptron iGuide, Common Name (Eg: NexImage 10), Pixel Size to the following thread: bit.ly/2S1Vxjq
2021-05-05T09:27:50: [INFO] Setting pixel size to default of 5.60
2021-05-05T09:27:50: [INFO] Found initial Input "Camera 1", Format "YUYV 4:2:2", Size 640x960, Frame interval 1/18s

Skyris logs:
021-05-05T09:27:50: [INFO] For future autodetection of pixel size, please report the following: Reported Name: SKYRIS 132C, Common Name (Eg: NexImage 10), Pixel Size to the following thread: bit.ly/2S1Vxjq
2021-05-05T09:27:50: [INFO] Setting pixel size to default of 5.60
2021-05-05T09:27:50: [WARNING] Manual/auto exposure control is not possible on the device!
2021-05-05T09:27:50: [INFO] Found initial Input "Camera 1", Format "8-bit Bayer GRGR/BGBG", Size 1280x960, Frame interval 1/30s

I realise these are more a driver issue to contend with. Other than that, the new build from what I can see, runs well. Have not done a real environment test, just daytime indoor. Typical British weather I'm afraid.

Equipment I'm using are;
Mount - ioptron cem70g
built in iGuider
built in iPolar
Main ccd - ZWO asi183mc pro
Secondary ccd - Skyris 132c
Stellarmate+
and running on both the Stellarmate app with iPad
and kStars on macOS via hotspot or vnc viewer

thanks, Richard.

 

Read More...

Sorry Jasem, on top of all that I cannot find what INDI version is currently being used.

Read More...

Ok, 2 strangest things have occurred.
Firstly
When I open
KStars 3.5.2 on MacOS
I get
error - unable to find INDI Drivers for directory
:/usr/local/share/Indi
Please make sure to set correct path in KStars configuration.

Why has that happened? And how do I configure it?
I use Remote hosting on Stellarmate Plus. I click ok and it goes into KStars allowing me to open Ekos and connect to all devices.

Secondly
I also use the Stellarmate Plus on MacOS, when I click on the Stellarmate noVNC icon, it now says
noVNC has encountered an error:
null is not an object (evaluating’document.getElementById(“noVNC_mouse_button0”).addEventListener’)
There is also a finer print too.

I haven’t done anything different so not sure what’s happened.

Read More...