Hi All,

A little update about this issue.

The problem is definitely gpsd that occupies dev/ttyUSB0 on the startup. I used the information on this post to modify the initial launch of the process. I opened /etc/default/gpsd and I just changed the USBAUTO option to "false", full script below:

# Start the gpsd daemon automatically at boot time

# Use USB hotplugging to add new USB devices automatically to the daemon

# Devices gpsd should collect to at boot time.
# They need to be read/writeable, either by user gpsd or the group dialout.

# Other options you want to pass to gpsd

Now when I start Ekos on my Raspberry PI 4, Sesto Senso 2 is able to connect without any problem.

Last night there was a very cloudy sky and I couldn't do any test but I run the calibration of the focuser and it worked perfectly. I will give you some extra news when I'll get a chance to take some pictures.

Clear skies.