I am already doing this procedure as i mentioned in my post. I was actually doing it successfully on the rasberry pi, but it does not work on the mac for some reason


Recently, i switched from an astroberry setup (kstars on rasberry pi) to a mac with the latest version of Kstars). Everything works exactly as before with the exception of my motorized dust cover (Flip Flat). Although the driver connects fine, and i can open and close the cover, and turn on and off the light manually from the indi device manager, the capture module seems to completely ignore the dust cover.

It will not open the cover automatically if closed while trying to capture Lights, and it will not close it, or open the light when doing calibration frames (i have selected the option in the calibration options for a Dust Cover with Built-In Flat Light). Also in the sequence module, if i select to close the cap at the end of the job, it will not close it. It is as if ekos does not even acknowledge the presence of the Flip Flat.

I tried to enable the debug logs, and i cannot find in the logs any mention or attempt to send a command to the Flip Flat, although it is connected in the indi device manager.

When i was using the rasberry pi, everything worked as it should, and i don't remember to have configured anything other than to make sure that the Flip Flat is connected in the indi device manager

Am i missing something maybe ?