Hi everyone, 

I'm reviving this old thread. I'm trying to configure my neo-6m GPS module

I've disabled virtual GPS, updated /etc/default/gpsd with devices="/dev/ttyS0"  changed the gpsd_options to =""and also changed the boot.txt to add the enable_uart=1 and force_turbo=1.

Using minicom, starts with 119000 bps when I change it to 9600 starts to receive data properly, using cgps -s does not lock anything, eventually times-out. Using gpsmon works perfectly and I can lock within a few seconds. Somebody mentioned changing the default settings of minicom, so I ran sudo minicom -s and changed the serial port settings, then I saved those values as default. If I restart the pi, for some reason goes back to 119000 bps.

Even if minicom is receiving data and gpsmon has a lock on the satellites, when I load Kstars and add aux gpsd it can never lock.

Any suggestions if most welcome!