The serial times out errors are a problem.

I found that using a high gain external wifi dongle on the stellarmate via one of its usb 2 ports is the best bet with regards to minimising the errors. The antenna has to be setup just so and I’ve posted about my setup before. I feel that there must be some interference with the aluminium body of the mount and the stellarmate despite Astrotrac saying there shouldn’t be. I briefly discussed with Colin who wrote the theskyx drivers and he noticed frequent wifi issues even and timeout issues even when using a windows laptop.

Once you get a run of serial timeout errors its more likely to keep happening in which case I suggest disconnecting mount from ekos/k stars and reconnecting it. Also whilst the mount is doing slews etc avoid lookout at the taskbar of the stellarmate. I noticed everytime I hovered and pressed over the taskbar for example to check the network connection strength etc a serial timeout error would be triggered. And if I didn’t stop doing it it kept happening and in my view it “corrupts” the session so disconnect and reconnect renews the setting. This is whilst using vnc to connect to it from my mac.

Now no one seems to know why that error happens for sure but this is what I have found. On its own the wifi broadcast from the mount seems robust it’s just a matter of the other device consistently picking it up or not.

When I spoke to Richard from astrotrac he stated that during testing the wifi connection were tested for days at a time to check data transmission and integrity and apparently was ok. But obviously the same error happens on both the skyx driver and also this indi driver.

Maybe you all might have an idea.

But short of it is if use high gain antenna as desribed above and dont play around in the stellarmate /os taskbar outside of ekos/kstars it seems not to have any errors.