Sorry for the late reply but I wasn't able to check the pc until now. The Focus Cube works out of the box with the default (and built-in) driver. I wasn't used to find something working without me having to install or tweak something so I didn't even check (or thought about checking lol)

Read More...

I can build my own drivers, but unfortunately I still cannot write them. I'm just trying to understand what pkg to build in the indi-3rdparty archive in order to have the Pegasus Focus Cube v2 working in Kstars/Ekos.

Other old topics I found mention the DMFC driver but I cannot find it in the actual indi-3rdparty repo. Same for the debian tgz or custom built pkg linked here . Is there a deb file I can download somewhere? I'd still prefer to compile from the indi-3rdparty github but any other option would work as well.

Read More...

It didn't happen on 3.6.2 nor 3.6.4. It now happens every single time as soon as I hit the actual menu entry from Tools > Devices > List My Equipment as well as when prompted by the Ekos profile window telling you that 'update your equimpment/optical train...', that one here:

jMqWq6Ml.jpg

In the logs the only possible entries I found related to the crashes are:

[2023-06-02T22:11:10.716 CEST DEBG ][ default] - ObsConditions::ObsConditions(int, double, Equipment, TelescopeType) Aperture value being used: 100
[2023-06-02T22:11:10.770 CEST WARN ][ default] - libpng warning: iCCP: known incorrect sRGB profile
[2023-06-02T22:11:10.776 CEST WARN ][ default] - libpng warning: iCCP: known incorrect sRGB profile
[2023-06-02T22:11:10.822 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.592 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.623 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.653 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.684 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.715 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.746 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.777 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.807 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.838 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.869 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.900 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.931 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.962 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:18.994 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.025 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.057 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.088 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.119 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.150 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.181 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.212 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:19.243 CEST WARN ][ default] - QFont::setPointSize: Point size <= 0 (0), must be greater than 0
[2023-06-02T22:11:57.331 CEST WARN ][ default] - "lat and LST parameters should only be used in KSPlanetBase objects."
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:11:57.332 CEST WARN ][ kf.i18n] - Trying to convert empty KLocalizedString to QString.
[2023-06-02T22:12:56.780 CEST WARN ][ org.kde.kstars] - No WishList Saved yet

Running on:
[2023-06-02T22:17:32.798 CEST INFO ][ org.kde.kstars] - Welcome to KStars 3.6.5 Stable
[2023-06-02T22:17:32.798 CEST INFO ][ org.kde.kstars] - Build: 2023-05-31T15:52:08Z
[2023-06-02T22:17:32.798 CEST INFO ][ org.kde.kstars] - OS: "garuda"
[2023-06-02T22:17:32.798 CEST INFO ][ org.kde.kstars] - API: "x86_64-little_endian-lp64"
[2023-06-02T22:17:32.798 CEST INFO ][ org.kde.kstars] - Arch: "x86_64"
[2023-06-02T22:17:32.798 CEST INFO ][ org.kde.kstars] - Kernel Type: "linux"
[2023-06-02T22:17:32.798 CEST INFO ][ org.kde.kstars] - Kernel Version: "6.3.5-zen1-1-zen"
[2023-06-02T22:17:32.799 CEST INFO ][ org.kde.kstars] - Qt Version: 5.15.9

Read More...

Talking from a fresh install of Kubuntu, things looked a lot brighter since I found official drivers and libs (libplayeronecamera2 + indi-playerone) in the repos but still...

Unable to establish:
+ PlayerOne CCD
Please ensure the device is connected and powered on.


This is all I got trying a bunch of things, auto-connect, port selection, custom drivers, filter wheel alone, camera alone, simulated camera + aux .... nope, still no luck.

Read More...

Btw, since I know close to nothing about ubuntu, did you say 22.04 instead of 23.04 because you know there may be support issues with the newer version or I may as well go for the newer one? Do I need to add any particular repository for AP stuff in general? As for packages to install, is there a 'right way' to go? Otherwise, I'd just go for eqmod + all those required by this one here

Read More...

Damn, I just literally turned the pc back on to go and download Kubuntu. But I don't know, for me using systemd was already pushing it, now I'm going to install Kubuntu. Might as well go back to win at this point lmao

But seriously, if there is any way to at least understand what's the missing bit, if it's a conflict, a missing lib, a config file to edit... that'd be much much appreciated.

Read More...

I'm a proud owner of an Artemis-M Pro (IMX 492 mono) and a 7x36mm filter wheel but so far I had no luck making them talk to INDI/Kstars.

Running on arch linux, I installed libindi via the arch repos, then the EQMOD for my mount via AUR (this one here ). The EQMOD carried over the installation of the whole libindi-3rdparty pkg, which includes the playerone drivers but this is where all the troubles begin since of course those didn't work.

With the help of a 'custom buil' pkgbuild by italic from CN (this file here ) I then managed to get the 'real indi-playerone' drivers built directly from the 3rdparty repos, but I'm not sure whether there's a conflict with the ones installed by eqmod at this point. I don't even know how to tell ekos to read a specific file. I of course tried with the 'custom driver' button pointing to a file in my local folders but that did't work either.

I then found out the eqmod installed a udev rule but I don't know how to check if that's being used or not. I'm also aware of this thread here but I guess the way kstars/ekos work is now different since I cannot find a way to activate the INDI control panel _before_ activating a profile so I don't know if I'm missing something easy here or I should start all over from scratch.

Filter wheel basically the same. Drivers should be there, udev rule is there, never been able to get it to connect.

I think I may use some help from you space nerd friends :)

Read More...

  • Basic Information

  • Gender
    Male
  • Birthdate
    11. 11. 1977
  • About me
    Not sure if Sirius