Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: iOptron SmartEQ pro-Error setting local date/UTC Offset.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 1 week ago #23926

  • lazjen
  • lazjen's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 192
  • Thank you received: 11
I agree with you. If anyone reading this is in this category, I suggest sending an email to This email address is being protected from spambots. You need JavaScript enabled to view it. to politely request INDI support for your mount. While you are likely to get a response back similar to what I received, perhaps the volume of requests might sway their thinking to helping more.
The following user(s) said Thank You: knro, dokeeffe, El Corazon

Please Log in or Create an account to join the conversation.

Last Edit: by lazjen.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 1 week ago #23931

  • cl330b
  • cl330b's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 1
I will send them a request. Hopefully they will at the very least provide the rs232 command language document for the iOptron smarteq/pro mount.

On a side note, I tested the "cem60" driver, which is actually "indi_ieq_telescope" to the best of my knowledge. And I can say with certainty that the time, date, and coordinates are being updated properly on the HC 8408. I wasn't able to locate the source code for this driver in the indi repo though.

I will be able to perform more in-depth testing this weekend and provide knro a more detailed list of what is working and what is not. To directly answer your question though, another item I observed not working properly is the UTC Offset and local time. Formats below:
:SLHHMMSS# (local time) 
:SGsMMM# (UTC Offset. i.e. -480)

Both commands should return "1".


Kindly,
cl330b

Please Log in or Create an account to join the conversation.

Last Edit: by cl330b. Reason: adding additional information

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 1 week ago #24001

So if you use indi_ieq_telescope driver with your mount, everything works? The driver is available here

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 1 week ago #24029

I posted about a similar problem with my SmartEQ Pro before. I am just using the CEM60 driver, I can control the mount fine with that one for all practical purposes, except for parking. That needs to be done manually by telling the mount to go Home, not Park. Another problem is that if you try to change the guide tracking speed to 0.5 x sidereal, the mount will set it to 0.05 and all guiding will fall apart then. Otherwise, no problem. Just use the CEM60 driver.

Please Log in or Create an account to join the conversation.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 1 week ago #24041

So is the issue with the current SmartEQ driver just the date/time settings? or there are other problems?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 6 days ago #24061

knro wrote: So is the issue with the current SmartEQ driver just the date/time settings? or there are other problems?


I can confirm the aberrant behavior re date setting under the iOptron SmartEQ driver. However, as far as I understand it, the iOptron drivers are not controlling the mount, they are programming and controlling the handset. I cannot directly connect the serial cable to the mount, only through the handset, and that is then being reprogrammed during startup by Ekos. So, the handset # is the critical piece of information which driver to use, not the mount. For the iOptron SmartEQs, at least those acquired during the last year, that seems to be #8408.
HC #8408 responds (almost) flawlessly to the iOptron CEM60 driver. No problem with date there, only two minor issues I found for which there are workarounds:
It is not possible to 'Park' the mount, i.e. it slews fine to the Home position, but remains in the Unparked state. Not a major issue as far as I am concerned.
The second concerns sidereal guiding rate. I already pointed that out a few weeks ago. See attached screenshot. The default set of the x sidereal guiding rate is 50.5, obviously way off. However, if you now set it to the proper value of 0.5 using the set button on the right, Indi Control Panel will show the rate as 0.5x, however, the handset will have been reprogrammed to 0.05x, so one power of 10 off, but in RA only, NOT in DEC.
Again, not a major problem for practical purposes, as long as one is aware of it and checks the guiding rate on the HC before starting the night session. Still, it would be nice if that could be fixed, others using iOptron mounts may not notice why their guiding is way off.
Jo
Attachments:

Please Log in or Create an account to join the conversation.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 6 days ago #24087

  • cl330b
  • cl330b's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 1

knro wrote: So is the issue with the current SmartEQ driver just the date/time settings? or there are other problems?


The only issues I have observed so far are the local time, UTC offset and date settings. I have already posted the proper format for these three changes. I am waiting for an email from iOptron to see if I can obtain the rs232 command list. The correct serial command syntax for the three issues I have observed are below. This format returns "1" for the 8408 HC on all three commands. I don't know if knro plans to work on the ioptron smarteq/pro driver, or create another link to the indi_ieq_telescope for the smartEQ/pro HC. I am willing to continue to test the former until it is functioning properly.

Correct command syntax.
:SCYYMMDD# (date)
:SLHHMMSS# (local time) 
:SGsMMM# (UTC Offset. i.e. -480)

kindly,
cl330b

Please Log in or Create an account to join the conversation.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 6 days ago #24094

Sorry there is so MUCH to follow up with I can't recall many details, so let's summarize this:
1. With iOptron SmartEQ, you can use the CEM60 driver if you connect directly to the mount bypassing the handset?
2. Parking: What remains in unparked state? The physical mount? or the INDI parked/unparked status? or both? Logs?
3. Ok the code is based on this: www.ioptron.com/v/ASCOM/RS-232_Command_Language2014_V2.0.pdf
Command: “:AG#”
Response: “nnn#”
This command returns the guiding rate n.nn * sidereal rate. The range of n.nn is [0.10, 0.90]

So if hand set guide rate was set to 0.5, then then command should return 050 which then divided by 100 = 0.5x. However, from what you describe above, it seems that was is returned is 505 / 100 = 50.5 which doesn't make sense. Even if divided by 1000 it's not right. Ok, enough speculation. Set it to 0.5 in the handset, then enable logging in INDI driver, and let's see what exactly the mount sends over. Maybe it should be 1000 instead of 100.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last Edit: by knro.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 6 days ago #24095

cl330b wrote:

knro wrote: So is the issue with the current SmartEQ driver just the date/time settings? or there are other problems?


The only issues I have observed so far are the local time, UTC offset and date settings. I have already posted the proper format for these three changes. I am waiting for an email from iOptron to see if I can obtain the rs232 command list. The correct serial command syntax for the three issues I have observed are below. This format returns "1" for the 8408 HC on all three commands. I don't know if knro plans to work on the ioptron smarteq/pro driver, or create another link to the indi_ieq_telescope for the smartEQ/pro HC. I am willing to continue to test the former until it is functioning properly.

Correct command syntax.
:SCYYMMDD# (date)
:SLHHMMSS# (local time) 
:SGsMMM# (UTC Offset. i.e. -480)

kindly,
cl330b


This is command set for this driver: www.ioptron.us/ASCOM/RS-232_Command_language2013.pdf

It is the same command set for the current driver (indi_lx200_zeq25) that covers ZEQ25, iEQ30, iEQ45, and SmartEQ. There is a space in the commands you mentioned above in the documentation.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 6 days ago #24103

  • cl330b
  • cl330b's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 10
  • Thank you received: 1
That document isn't accurate. The 8408 HC with SmartEQ pro mount returns "0011". Please see this more updated document which shows the working command syntax for the 8408 HC and SmartEQ pro mount even though it is not listed in the text. The commands in the document from 2014 (V2. 0) are 100% confirmed working properly.

Kindly
cl330b
Attachments:

Please Log in or Create an account to join the conversation.

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 5 days ago #24106

That's the document I use for the iEQ Pro drivers in INDI... Ok, this is then just a mis-labeling. I will update INDI so that when you run "SmartEQ" driver, it uses the indi_ieq_telescope driver instead of indi_lx200zeq25 driver

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

iOptron SmartEQ pro-Error setting local date/UTC Offset. 6 months 5 days ago #24116

Another issue. The documentation is very sparse.

1. IEQ Pro documentation: indilib.org/devices/telescopes/ioptron/ieq45.html
2. ZEQ25 documentation: indilib.org/devices/telescopes/ioptron/zeq25-smarteq.html

It would be great if someone can step and supply screenshots for these drivers running plus add any bit of documentation that is useful for new users.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Time to create page: 0.212 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica