×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

optimizing plate solver

  • Posts: 723
  • Thank you received: 332
Ron, @Euripides: I'm no expert on plate solving, but am willing to work with you to figure this out.

First, the message "DISABLED: FOV must be 10 arcmins or wider. 60+arcminutes is recommended." is worrysome.
I looked at the code, and that's output when, just as it says, it calculates the FOV too small. It calculates the FOV from this formula:

    fov_x = (206264.8 * ccd_width * (ccd_hor_pixel / 1000.0) / focal_length) / 60

where 
- fov_x is in arc-minutes, 
- ccd_width is the # of pixels along the width of your imager, 
- cc_hor_pixel is the width, in microns, of your pixels,
- focal_length in mm.

So, for instance, in my setup with FL=2000, px=3.8, ccd_width=4656 I get fov_x = 30 arc-minutes.

Check the Indi window for your imager to make sure the value is good.
Here's mine, for my ASI1600, correctly set at 3.8 microns and 4656 pixels
 

Next, assuming there's no issue there, we can go into testing the plate solving itself.
Ekos could definitely use an easy way to debug plate solving, offline, during the daytime, etc.
Here's one way to do it, not as easy as it should be, but a start.

- Capture an image (in the capture tab) with the same exposure/gain/etc as you're using with Align. This will be out test file for further investigation.

- Switch to the simulator

- Jasem introduced an interesting feature in the simulator a while back, where it can replay images from a directory, instead of creating images.
You can find that if you run the simulator profile, and start up Ekos. Go to the indi tab labeled 'CCD Simulator' and inside there go to the tab labelled 'Simulator Config'.
At the bottom you will find ''Use Dir". Enable that. Note the directory location on the above line, and put your test fits file in that directory (and temporarily remove any other files 
that might be in that directory--you probably won't have any there). Now, when you run the simulator, it should always "replay" that fits file as the new capture. Remember to uncheck that 'Use dir" button later, or just don't save this configuration.

- For sanity's sake, capture a few images with the simulator. You should always see your test image.

- Go to the align tab, Use 'Capture and Solve' with Action = 'Nothing'. It should try to solve your image, and now you can play with parameters to get it to solve.

Note, you probably will also need to configure the simulator to have the focal length and ccd parameters for your real system where the image was captured. 
Enter the CCD stats on that same 'Simulator Config' page as above, and the Focal Length on the mount tab.
I think you're safe that changing these things on the simulator won't affect you when you go back to your "real profile", but please double check.

If you can't get a fits file to solve, please upload it somewhere and let me (and any others) have a crack at it too.
Of course, if you do that, send the relevant image parameters (focal length, pixel size, num pixels).

Good luck,
Hy
 
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Euripides
2 months 2 days ago #75912
Attachments:

Please Log in or Create an account to join the conversation.

The FOV message is quite odd given what FOV on the left appears to be OK. I couldn't reproduce this message thus far using a variety of profile. If you delete and create a new profile, same issue?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 2 days ago #75919

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
Thank you Hy,

Done all that, no luck with the internal solver. ASTAP and online solves ok.
2 months 2 days ago #75920

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
Hello Jasem, 

I've just erased completely the profile and create a new one. Same issue with the FOV and now I can see the error message on the bottom.


PS. Those numbers are correct.


 

 
Last edit: 2 months 2 days ago by Euripides.
2 months 2 days ago #75921
Attachments:

Please Log in or Create an account to join the conversation.

The warning message is an indicator that something is wrong. Can you go to Image Info tab of the camera INDI Control Panel and check that out? also the mount module, what's the focal length listed there?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 2 days ago #75922

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
Certainly! But I can't understand why and where else to look (beside that fact that nothing changed).

All those numbers looking good to me.

Certainly! But I can't understand why and where else to look (beside that fact that nothing changed).

All those numbers looking good to me.

  
2 months 2 days ago #75923
Attachments:

Please Log in or Create an account to join the conversation.

The only thing remaining that would be possible is language and different between decimal point and comma, but that'd hardly an issue now as it was addressed long ago. But I'm running out of ideas and this is the only thing that would explains it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 2 days ago #75924

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
Tried it. Nop, nothing changed :-(
2 months 2 days ago #75925

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 2
An easy way to revert back or install from scratch the previous version? I am on a mini pc with Ubuntu mate.


Sent from my iPhone using Tapatalk
2 months 2 days ago #75940

Please Log in or Create an account to join the conversation.

  • Posts: 39
  • Thank you received: 0

Replied by Mark Copper on topic optimizing plate solver

Here is a plate solve from last night, start and finish, with Vega as target.
   drive.google.com/file/d/1srApvSVSOMpSmFh...SWZ/view?usp=sharing
   drive.google.com/file/d/1EUJQm-UtZ_oHj7X...AT-/view?usp=sharing

Solving was again on the order of 50-60 seconds per frame. These are the options I used:
   drive.google.com/file/d/1elON7vnWqCWEExg...5Ud/view?usp=sharing

Note that I trimmed the area when I captured an image but neglected to do reflect that in the scaling options. I don't know if that had a deleterious effect.

Also, I ran solve-field on the remote computer, blind, without any options at all. Although I didn't record how long it took to solve, it was quite rapid. So I wonder if running the solver remotely created some kind of bottleneck.

There also seemed to be a problem with solving to coordinates for which Ekos had no object. Thus, for example, I tried solving to a star dimmer than 8.4, but the solver solved to a near by brighter star. But I'll investigate further and post separately if it continues to be a problem.

Thanks for reading.

 
2 months 1 day ago #75955

Please Log in or Create an account to join the conversation.

  • Posts: 723
  • Thank you received: 332

Replied by Hy Murveit on topic optimizing plate solver

Mark,
I ran your fits file too, and like you got slow results with astrometry, but got virtually instant results from ASTAP (inside of EKos).
Why not install and use the ASTAP option (either permanently or until this gets worked out)?
You do need to install ASTAP to do that. www.hnsky.org/astap.htm
Hy
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Mark Copper
2 months 1 day ago #75960

Please Log in or Create an account to join the conversation.

  • Posts: 723
  • Thank you received: 332

Replied by Hy Murveit on topic optimizing plate solver

BTW, with ASTAP you would want to disable 'use position' and 'use scale'
Orion Atlas Pro, William Optics ZS105, Moonlight V2 focuser, GSO RC10 w/RSF focuser
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm guidecam.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
2 months 1 day ago #75961

Please Log in or Create an account to join the conversation.

Time to create page: 1.174 seconds