×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Saving focus images

  • Posts: 838
  • Thank you received: 108
Last night I tried to get an AF series and store the images for later inspection.
I went to Settings->Developer and checked the box 'Save Focus Images', applied the change and quite and restarted KStars.
Then I did a focus run (linear, all stars). But no images were written to disk, as far as I can tell :(
I looked in .local/share/kstars and in my default data directory ~/EKOS.
Is the option not working, or are they somewhere else?

This is recent kstars from git (self compiled) on a Pi4.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
1 month 1 week ago #83018

Please Log in or Create an account to join the conversation.

  • Posts: 821
  • Thank you received: 396

Replied by Hy Murveit on topic Saving focus images

I have done this many times.
On Linux the files should be saved in a directory named something like: ~/.local/share/kstars/autofocus/2022-05-23
Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
1 month 1 week ago #83031

Please Log in or Create an account to join the conversation.

  • Posts: 838
  • Thank you received: 108
Thanks Hy!
There's for sure no folder autofocus. Then again, there is also no folder 'logs'. Permissions are OK, and, e.g., analyze and guidelogs exist. I'll try to create the directories manually. Or is there another setting needed to activate them?

Edit: Ah, found Settings->Advanced->Logging output. That was set to 'Default'. Setting it to 'file' makes the log appear there. Will have to see if that affects the focus images, too

Edit2: No, still no files in autofocus. But it's daylight, lens covered, so the routine didn't detect stars - not sure if it would only store successful images?
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
Last edit: 1 month 1 week ago by Peter Sütterlin.
1 month 1 week ago #83032

Please Log in or Create an account to join the conversation.

  • Posts: 821
  • Thank you received: 396

Replied by Hy Murveit on topic Saving focus images

Peter,

This is easy to test with the simulator (assuming you have GSC installed so that the simulator generates star images) so you need not wait until nighttime.
I just tried with the simulator (using the latest software) and it worked fine for me.

Hy

Here are my settings:



AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
The following user(s) said Thank You: Alfred
1 month 1 week ago #83060
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 838
  • Thank you received: 108
Ah, so it only saves when verbose debug logging is active.... should have though of that, stupid me :-o Thanks for lighting me up!
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
1 month 1 week ago #83063

Please Log in or Create an account to join the conversation.

Time to create page: 0.573 seconds