×

INDI Library v1.9.9 Released (30 Nov 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

scheduler shouldn't use Kstars time.

  • Bart
  • Bart's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Professional tinkerer
  • Posts: 143
  • Thank you received: 25
The scheduler in Ekos should be indipendent from the time in Kstars. Currently, it is better use system time or make it a configurable option.

When scheduling, I use the 'x > degrees above the horizon' often. To fill in x, I advance the time in Kstars a few hours to seeif this would work, that particular night.
I left the time as it was, not knowing the scheduler actually uses that.
So the schedule was messed up.

Another 'solution' (workaround/ patch) is to set the Kstars time to 'time now' right when the scheduler is started.
Then still, the user shouldn't change the time in Kstars during the session, so not a very good option, imho.

Hope this can be fixed! :)
Cheers guys!
Latest Stellarmate on Rpi 4B, 294mm-pro, EFW-8, CEM70
1 year 5 months ago #72919

Please Log in or Create an account to join the conversation.

When an Ekos profile is started, time is synced from the system time.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 5 months ago #72931

Please Log in or Create an account to join the conversation.

  • Bart
  • Bart's Avatar Topic Author
  • Offline
  • Premium Member
  • Premium Member
  • Professional tinkerer
  • Posts: 143
  • Thank you received: 25
Hmm, thanks! I'll check then what happened, because I remember the problem I encountered did go away after I set Kstars to 'Time - Now'.
Cheers,
Latest Stellarmate on Rpi 4B, 294mm-pro, EFW-8, CEM70
1 year 5 months ago #72985

Please Log in or Create an account to join the conversation.

Time to create page: 0.175 seconds