×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Autofocus fails with log file message "Ignoring Received FITS CCD1 ..."

4 months 1 week ago
AxelM
Fresh Boarder
Fresh Boarder
Posts: 9
More
Topic Author
Autofocus fails with log file message "Ignoring Received FITS CCD1 ..." #54270
Hi,
I have been using Ekos on a Raspberry Pi 4 (running Ubuntu+Mate desktop) for about half a year. My cameras are an ASI1600MM Pro with electronic filter wheel and an ASI290 MM mini (guider). Recently I encountered a very annoying problem with the autofocus:
  • I am running the scheduler; the filters are set to "Auto Focus", i.e. autofocus runs each time the filter changes.
  • Upon a filter change, Ekos pretends to capture and download images as part of the focusing process. However, the image in the "Focuser" tab is not updated, and neither are the HFR readings. As a result, autofocusing eventually fails.
  • However, the autofocus process runs fine when started manually from the Focuser tab (by clicking the "Autofocus" button).
The log file says:
[2020-05-20T23:35:59.929 EDT INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'M108+Owl' guiding is in progress."
[2020-05-20T23:35:59.938 EDT INFO ][ org.kde.kstars.ekos.scheduler] - "Job 'M108+Owl' capture is in progress..."
[2020-05-20T23:35:59.951 EDT INFO ][   org.kde.kstars.ekos.capture] - "Job requires 60.000-second Red images, has 0/30 frames captured and will be processed."
[2020-05-20T23:35:59.964 EDT INFO ][           org.kde.kstars.indi] - ASI EFW :  "[INFO] Setting current filter to slot 2 "
[2020-05-20T23:36:01.945 EDT INFO ][     org.kde.kstars.ekos.focus] - "Capturing image..."
[2020-05-20T23:36:05.905 EDT WARN ][   org.kde.kstars.ekos.capture] - Ignoring Received FITS CCD1 as it has the wrong capture mode 1
[2020-05-20T23:36:05.906 EDT INFO ][     org.kde.kstars.ekos.focus] - "Image received."
[2020-05-20T23:36:05.915 EDT INFO ][     org.kde.kstars.ekos.focus] - "Please wait until image capture is complete..."
[2020-05-20T23:36:05.918 EDT INFO ][     org.kde.kstars.ekos.guide] - "Guiding suspended."
[2020-05-20T23:36:05.921 EDT INFO ][     org.kde.kstars.ekos.focus] - "Focusing outward by 1,000 steps..."
[2020-05-20T23:36:06.003 EDT INFO ][           org.kde.kstars.indi] - MoonLite :  "[INFO] Focuser is moving to position 23383 "
[2020-05-20T23:36:07.631 EDT INFO ][     org.kde.kstars.ekos.focus] - "Focusing inward by 500 steps..."
[2020-05-20T23:36:07.636 EDT INFO ][           org.kde.kstars.indi] - MoonLite :  "[INFO] Focuser reached requested position. "
[2020-05-20T23:36:07.676 EDT INFO ][           org.kde.kstars.indi] - MoonLite :  "[INFO] Focuser is moving to position 22883 "
[2020-05-20T23:36:08.715 EDT INFO ][           org.kde.kstars.indi] - MoonLite :  "[INFO] Focuser reached requested position. "
[2020-05-20T23:36:10.623 EDT INFO ][     org.kde.kstars.ekos.focus] - "Capturing image..."
[2020-05-20T23:36:14.409 EDT WARN ][   org.kde.kstars.ekos.capture] - Ignoring Received FITS CCD1 as it has the wrong capture mode 1
[2020-05-20T23:36:14.410 EDT INFO ][     org.kde.kstars.ekos.focus] - "Image received."
(The full log file can be seen here .)

The relevant message appears to be "Ignoring Received FITS CCD1 as it has the wrong capture mode 1". Any idea what might be causing this?

Axel

Ubuntu Mate 20.04 (arm64) on Raspberry Pi 4 (4 GB)
Vixen R200SS 8" f/4
EQ6-R Pro
ASI 1600MM Pro + EFW, Canon 6D

Please Log in or Create an account to join the conversation.

3 months 1 week ago
AxelM
Fresh Boarder
Fresh Boarder
Posts: 9
More
Topic Author
Autofocus fails with log file message "Ignoring Received FITS CCD1 ..." #55755
A quick update in case anyone experienced similar problems: Updating Kstars from 6:3.4.2+202004251749~ubuntu19.10.1 to nightly build 6:3.4.3+202006171130~ubuntu19.10.1 (from ppa:mutlaqja/indinightly) solved the problem; autofocus upon a filter change works again.

Axel

Ubuntu Mate 20.04 (arm64) on Raspberry Pi 4 (4 GB)
Vixen R200SS 8" f/4
EQ6-R Pro
ASI 1600MM Pro + EFW, Canon 6D

The following user(s) said Thank You TallFurryMan

Please Log in or Create an account to join the conversation.

Time to create page: 0.340 seconds