×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

Problems with AZ-GTI mount and PHD2

  • Posts: 226
  • Thank you received: 88
HI,
I checked the guiding pulse in the INDI logs: the DEC axis has 2073600 steps, which is roughly 24 steps per second for sidereal rate, and the 1.250 North guiding pulse at 0.5x shows a difference of 13 steps which seems correct. From the driver point of view, it can't do more.
I noticed in your first PHD2 logs some problems while calibrating. In the RA case, East/West moves seems ok (8 west moves, 4 east moves:
01:04:15.864 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:21.199 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:26.560 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:31.903 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:37.187 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:42.493 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:47.788 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:53.049 00.000 3013644336 MoveAxis(W, 1250, -)
01:04:58.320 00.001 3015503888 WEST calibration completes with steps=8 angle=-178.7 rate=2.618 parity=1
01:04:58.344 00.000 3013644336 MoveAxis(E, 2500, -)
01:05:04.945 00.000 3013644336 MoveAxis(E, 2500, -)
01:05:11.547 00.000 3013644336 MoveAxis(E, 2500, -)
01:05:18.100 00.000 3013644336 MoveAxis(E, 2500, -)
For the DEC axis, North/South moves are problematic (22 North, 6 south):
01:05:24.634 00.000 3013644336 MoveAxis(N, 1250, -)
01:05:29.857 00.000 3015503888 Backlash: Rejected small move of 0.7 px
01:05:29.858 00.000 3013644336 MoveAxis(N, 1250, -)
01:05:29.886 00.028 3015503888 Backlash: Limpiando paso de backlash   2, Last Delta = 0.72 px, CumDistance = 0.72 px
01:05:35.109 00.001 3015503888 Backlash: Rejected small move of 0.8 px
01:05:35.109 00.000 3013644336 MoveAxis(N, 1250, -)
01:05:35.136 00.027 3015503888 Backlash: Limpiando paso de backlash   3, Last Delta = 0.83 px, CumDistance = 1.53 px
01:05:40.438 00.001 3015503888 Backlash: Rejected small move of 0.8 px
01:05:40.442 00.000 3013644336 MoveAxis(N, 1250, -)
01:05:40.470 00.028 3015503888 Backlash: Limpiando paso de backlash   4, Last Delta = 0.77 px, CumDistance = 2.08 px
01:05:45.789 00.000 3015503888 Backlash: Rejected small move of 0.6 px
01:05:45.790 00.000 3013644336 MoveAxis(N, 1250, -)
01:05:45.820 00.030 3015503888 Backlash: Limpiando paso de backlash   5, Last Delta = 0.58 px, CumDistance = 2.66 px
01:05:51.144 00.001 3015503888 Backlash: Rejected small move of 0.7 px
01:05:51.144 00.000 3013644336 MoveAxis(N, 1250, -)
01:05:51.169 00.025 3015503888 Backlash: Limpiando paso de backlash   6, Last Delta = 0.74 px, CumDistance = 3.32 px
01:05:56.380 00.001 3015503888 Backlash: Rejected small move of 0.8 px
01:05:56.380 00.000 3013644336 MoveAxis(N, 1250, -)
01:05:56.407 00.027 3015503888 Backlash: Limpiando paso de backlash   7, Last Delta = 0.84 px, CumDistance = 4.08 px
01:06:01.720 00.000 3015503888 Backlash: Rejected small move of 1.4 px
01:06:01.721 00.001 3013644336 MoveAxis(N, 1250, -)
01:06:01.750 00.029 3015503888 Backlash: Limpiando paso de backlash   8, Last Delta = 1.39 px, CumDistance = 5.46 px
01:06:07.013 00.000 3015503888 Backlash: Accepted clearing move of 4.5
01:06:07.014 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:07.040 00.026 3015503888 Backlash: Limpiando paso de backlash   9, Last Delta = 4.49 px, CumDistance = 9.62 px
01:06:12.339 00.001 3015503888 Backlash: Rejected small move of 1.4 px
01:06:12.340 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:12.365 00.025 3015503888 Backlash: Limpiando paso de backlash  10, Last Delta = 1.43 px, CumDistance = 11.05 px
01:06:17.627 00.000 3015503888 Backlash: Accepted clearing move of 2.3
01:06:17.628 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:17.653 00.025 3015503888 Backlash: Limpiando paso de backlash  11, Last Delta = 2.28 px, CumDistance = 13.26 px
01:06:22.931 00.001 3015503888 Backlash: Rejected small move of 1.8 px
01:06:22.931 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:22.959 00.028 3015503888 Backlash: Limpiando paso de backlash  12, Last Delta = 1.81 px, CumDistance = 15.07 px
01:06:28.229 00.000 3015503888 Backlash: Accepted clearing move of 3.0
01:06:28.229 00.000 3015503888 Backlash: Got 3 acceptable moves, using last move as step 1 of N calibration
01:06:28.229 00.000 3015503888 Backlash: North calibration moves starting at {1986.6,1533.0}, Offset = 18.7 px
01:06:28.229 00.000 3015503888 Backlash: Total distance moved = 21.2
01:06:28.229 00.000 3015503888 Backlash: Falling Through to state GO_NORTH
01:06:28.254 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:33.642 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:38.988 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:44.318 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:49.648 00.000 3013644336 MoveAxis(N, 1250, -)
01:06:54.989 00.000 3013644336 MoveAxis(N, 1250, -)
01:07:00.329 00.000 3013644336 MoveAxis(N, 1250, -)
01:07:05.650 00.000 3013644336 MoveAxis(N, 1250, -)
01:07:10.961 00.000 3013644336 MoveAxis(N, 1250, -)
01:07:16.247 00.000 3013644336 MoveAxis(N, 1250, -)
01:07:21.530 00.001 3015503888 NORTH calibration completes with angle=87.4 rate=1.822 parity=-1
01:07:21.563 00.000 3013644336 MoveAxis(S, 2500, -)
01:07:28.130 00.000 3013644336 MoveAxis(S, 2500, -)
01:07:34.708 00.000 3013644336 MoveAxis(S, 2500, -)
01:07:41.267 00.000 3013644336 MoveAxis(S, 2500, -)
01:07:47.803 00.000 3013644336 MoveAxis(S, 2500, -)
01:07:54.360 00.000 3013644336 MoveAxis(S, 1250, -)
01:07:59.615 00.001 3015503888 Omitted calibration alert: Advisory: Calibration successful but little south movement was measured, 
so guiding may be impaired.
Afterwards, there are many North guide pulses before the DEC axis starts to diverge, that does not occur at the first North guide pulse (even if they don't seem to be very effective). I will try to look what happens when the DEC starts diverging.
At first sight, I would think of a weight balance issue, or a loosen axis clutch. Or there may be a bug in the motor controller firmware as suggested by @Gonzothegreat, which the ASCOM driver is aware of ?
Maybe a log from an Ascom/PHD2 session would be helpful here. I'm also thinking to the SideofPier property, which seems to be used by some guiding software to use the correct axis direction.
6 months 3 weeks ago #60620

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Hi again.

Thank you very much.

I attach here PHD2 logs of the photo from the first post.

Here is a capture of the Synscan app showing the firmware version. It is 3.22.A5.


I think I can downgrade it to v3.20 to test it, but... I don't have the problem in windows. Is so frustrating :S. It seems like the bug only affects in linux. Ascom driver is from Skywatcher. Perhaps they solved or ignore the bug in their driver, don't you think so?

Thank you again.
6 months 3 weeks ago #60630
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
It seems that there is a newer firmware version from Skywatcher. v3.26.



It's a shame that no changelog is included :-(.

I'll try it as soon as possible. Perhaps there is the solution.

Bye.
6 months 3 weeks ago #60631
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2013
  • Thank you received: 187
The 3.26 still has the DEC issue from reading the last update off the CN thread. Downgrade to 3.20 instead and do your testing.
Kstars Mac osx
Incoming soon:
Odroid C4 / Takahashi 130ED / CEM25p / QHY268M / and more...

old:
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
Megrez72 / HEQ5 pro / QHY5L-II-M (OAG) / Atik 314L+ / Gerd Neumann drawer
6 months 3 weeks ago #60636

Please Log in or Create an account to join the conversation.

  • Posts: 226
  • Thank you received: 88
Had a more precise look to the logs, and immediately notice an unexplained variation of the DEC axis position as reported by the motor controller firmware. For instance during the calibration:
[2020-09-23T23:25:15.234 CEST DEBG ];EQMod Mount : "[SCOPE] Current encoders RA=8153754 DE=9502321 "
[2020-09-23T23:25:15.885 CEST DEBG ];EQMod Mount : "[DEBUG] Timed guide North 1250 ms at rate 7.52053  "
[2020-09-23T23:25:15.887 CEST DEBG ];EQMod Mount : "[DEBUG] SetDERate() : rate = 0.5 "
[2020-09-23T23:25:15.887 CEST DEBG ];EQMod Mount : "[MOUNT] SetMotion() : Axis = 2 -- dir=forward mode=slew speedmode=lowspeed "
[2020-09-23T23:25:15.900 CEST DEBG ];EQMod Mount : "[MOUNT] SetSpeed() : Axis = 2 -- period=1329692 "
[2020-09-23T23:25:17.181 CEST DEBG ];EQMod Mount : "[DEBUG] End Timed guide North/South "
[2020-09-23T23:25:17.290 CEST DEBG ];EQMod Mount : "[SCOPE] Current encoders RA=8153804 DE=9502334 "
[2020-09-23T23:25:18.478 CEST DEBG ];EQMod Mount : "[SCOPE] Current encoders RA=8153832 DE=9502332 "
[2020-09-23T23:25:19.455 CEST DEBG ];EQMod Mount : "[SCOPE] Current encoders RA=8153856 DE=9502342 "
[2020-09-23T23:25:19.601 CEST DEBG ];EQMod Mount : "[DEBUG] Timed guide North 1250 ms at rate 7.52053  "
[2020-09-23T23:25:19.604 CEST DEBG ];EQMod Mount : "[DEBUG] SetDERate() : rate = 0.5 "
[2020-09-23T23:25:19.605 CEST DEBG ];EQMod Mount : "[MOUNT] SetMotion() : Axis = 2 -- dir=forward mode=slew speedmode=lowspeed "
[2020-09-23T23:25:19.611 CEST DEBG ];EQMod Mount : "[MOUNT] SetSpeed() : Axis = 2 -- period=1329692 "
[2020-09-23T23:25:20.890 CEST DEBG ];EQMod Mount : "[DEBUG] End Timed guide North/South "
[2020-09-23T23:25:21.533 CEST DEBG ];EQMod Mount : "[SCOPE] Current encoders RA=8153907 DE=9502344 "
[2020-09-23T23:25:22.602 CEST DEBG ];EQMod Mount : "[SCOPE] Current encoders RA=8153934 DE=9502343 "
At the end at the first Timed guide pulse, the DEC axis changes by itself: 9502334, 9502332 then 9502342. Starting from 9502321, the first guide pulse is correct leading to 9502334 (~12-14 steps), then it moves by itself, and the second guide pulse is only 2 steps from 9502342 to 9502344. But 9502344 is almost correct starting from the beginning. Unless another application is moving the mount, I have no explanation. I did not go further, if I understood South guiding works correctly as you reported, I don't know why the firmware makes special corrections on the North axis. I don't own a STM32 dev board to debug the firmware and I suppose their ASCOM driver is closed source. Did you try with the ASCOM eqmod driver ?
It seems they did not solve the issue (or consider this is not a normal usage of the mount) (thanks @Gonzothegreat) What do they mean with 'telescope pointing forwards' ?
An explanation of the existence of these 2 motor firmwares (altaz and eq) may be that the handcontroller is altaz only and always send commands to the motor board as if it was in altaz mode. If the mount is on an eq wedge you then have to change the Dec axis speeds in the motor firmware and that may explain this issue. But not sure.
6 months 3 weeks ago #60640

Please Log in or Create an account to join the conversation.

  • Posts: 682
  • Thank you received: 51
Hi everyone
Guys, are we sure the azgti is reporting side of pier correctly?

@OP: (pointing south for now, there maybe different issues crossing the pole to the north) slew east of meridian:
indi_getprop *.TELESCOPE_PIER_SIDE.*

now slew west of meridian:
indi_getprop *.TELESCOPE_PIER_SIDE.*

What's the output of each command?
Cheers and clear skies,
Steve
kubuntu 20.04
700d, eq6, t7m
6 months 3 weeks ago #60647

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
Hello everyone.

Last night I tested firmware v3.20 and this solved the problem. But the guiding was not as good as in Windows (I tested too).

It could be an encoders problem? I think I have read in a forum that it should be done, but I'm not sure.

I attach PHD logs from INDI and ASCOM. I can't attach KStars log because it's 48Mb long :-S.

I think that this problem is solved.

Thanks again.
6 months 3 weeks ago #60716
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2013
  • Thank you received: 187
Good to hear you got the main problem sorted out :)
Kstars Mac osx
Incoming soon:
Odroid C4 / Takahashi 130ED / CEM25p / QHY268M / and more...

old:
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
Megrez72 / HEQ5 pro / QHY5L-II-M (OAG) / Atik 314L+ / Gerd Neumann drawer
6 months 3 weeks ago #60717

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
maybe it is naive, but I just send an email to support in Sky-Watcher. According, the change log in 3.26, it looks like that they added new features and also wanted to improve something for astrophotography in 3.22, then tried to fix some bugs in 3.26, maybe even this bug. Maybe they will pay attention to this problem now... I hope! AZ GTI is a great and unique product on the market with a lot of fans meanwhile.
6 months 4 days ago #61497

Please Log in or Create an account to join the conversation.

  • Posts: 2013
  • Thank you received: 187
Sky-watcher has always advertised this mount as not being designed for astrophotography, it is a shame they are not spending more time on it.
Kstars Mac osx
Incoming soon:
Odroid C4 / Takahashi 130ED / CEM25p / QHY268M / and more...

old:
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
Megrez72 / HEQ5 pro / QHY5L-II-M (OAG) / Atik 314L+ / Gerd Neumann drawer
6 months 4 days ago #61503

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
Hey, everyone, there's already news here? Guiding over the Astroberry doesn't work for me either. I have similar problems to those described at the beginning. Thank you very much and clear sky
4 months 3 weeks ago #63216

Please Log in or Create an account to join the conversation.

  • Posts: 499
  • Thank you received: 49
I have two AZ-GTi's. Love them.
RA guiding is pretty good. DE is often quite bad. But it's still good enough for my AT72EDII.
My rig is not well balanced - need a heavier counterweight (I am using the standard 1 kg).

Using internal guiding.
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi x 2
SW HEQ5
RST-135
Last edit: 4 months 3 weeks ago by maxthebuilder.
4 months 3 weeks ago #63398

Please Log in or Create an account to join the conversation.

Time to create page: 1.218 seconds