×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

The unlucky guy and desperate that found the work around. Thanks INDI community.

  • Posts: 11
  • Thank you received: 1
Dear Patrick,
Wonderful! Welcome to spectroscopy.
This subject is "out of topics" in this thread, but tell me if you need any help somewhere.
Yesterday night I've been able to run a new observation, and everything went well.
Thank you again for your help.
Regards,
François
4 months 1 day ago #84968

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
Good evening,

I´m also trying to fix the issue with ZWO cameras. In my case I have libASICamera2.so.1.26 instead of 25. In addition, if I download the bin file from github (github.com/indilib/indi-3rdparty/blob/ma...v8/libASICamera2.bin), I rename it and I run the command
strings /usr/lib/aarch64-linux-gnu/libASICamera2.so.1.26 | grep 1
, it still returns 26 instead of 22. Did you download an old version?

Thanks and best regards.
3 months 2 days ago #85985

Please Log in or Create an account to join the conversation.

  • Posts: 870
  • Thank you received: 83
@JUAN
Hi
Are the symlinks set correctly? Here's a working install.
Under:
/usr/lib/x86_64-linux-gnu
we have:



I believe that unless 1.26 fixes the disconnect for all versions, on arm that needs to be 1.22
HTH
kubuntu 22.04
700d, eq6, 120mm. Yes, the old one.
The following user(s) said Thank You: Juan Daniel
Last edit: 3 months 2 days ago by alacant.
3 months 2 days ago #85994
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
Hi Alacant,

for me it is similar as your image. My question is about how to get the 22 version. Do you download from an old version in git? Current master version is 26.

Best regards.
3 months 2 days ago #85996

Please Log in or Create an account to join the conversation.

  • Posts: 870
  • Thank you received: 83
If 1.26 doesn't work for you, the old versions are here:
github.com/indilib/indi-3rdparty/tree/master/libasi

Hit the platform you want, e.g. x64, then hit 'History'

Renaming and installation was covered here:
www.indilib.org/forum/ccds-dslrs/12042-t....html?start=12#84916
kubuntu 22.04
700d, eq6, 120mm. Yes, the old one.
The following user(s) said Thank You: Juan Daniel
3 months 2 days ago #85997

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
Thanks for the response.

I could get the .22 version, rename and replace, but problem persists... This is crazy because I have a RP3 and I can´t compile master from git because I don´t have enough RAM. And I can´t go back to the previous version... so basically I can´t do anything.

Nightly version is created for Ubuntu as far as I know, because I can´t add the repository in my Raspbian (sudo apt-add-repository ppa:mutlaqja/indinightly). I tried to install Kstars with Ubuntu Mate in my Raspberry, but it is so slow than it is not an option.
3 months 2 days ago #86002

Please Log in or Create an account to join the conversation.

  • Posts: 964
  • Thank you received: 128
OK, a few questions:
You are running 64bit Linux, yes? What does 'uname -a' report?
Version 1.26 has fixed the issues with 64bit ARM. So it should work. If you still have issues, it might well be some other problem.
Compiling: Not 100% sure, but I think for compiling INDI there should be enough RAM. No need to fiddle with kstars.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
The following user(s) said Thank You: Juan Daniel
3 months 2 days ago #86003

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
That is my fault I think... I have 32bits ARM version...

uname -a
Linux astroberry 5.10.103-v7+ #1529 SMP Tue Mar 8 12:21:37 GMT 2022 armv7l GNU/Linux

getconf LONG_BIT
32

Is there any work around for 32 bits?? I use Astroberry and I think it install 32 bits. Or if you recomend me another distribution I can try.

Thank you very much for the help, I was desesperate.
3 months 2 days ago #86004

Please Log in or Create an account to join the conversation.

  • Posts: 964
  • Thank you received: 128
Well, the first thing would be to get the proper library, not from armv8, but from armv7, and install it at the proper place, definitely not in something like x86_64. I don't have a debian-based Pi, so I can't tell you where it is supposed to end up.

But AFAIR only 64bit ARMs were affected, so back to: Find out what the problem is. I don't think it's the broken ASI libs.

A first try could be to log in to the Pi and run indi_asi_ccd from the command line, and report the error you get.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
The following user(s) said Thank You: Juan Daniel
3 months 2 days ago #86005

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
Yes, I was using the armv7 library and I was installing in "/usr/lib/arm-linux-gnueabihf".

Anyway, as you told me it only affects to 64 bits, I restored the original files and I ran the command you told me:
indi_asi_ccd
indi_asi_ccd: symbol lookup error: indi_asi_ccd: undefined symbol: _ZN4INDI3CCD15addFITSKeywordsEPNS_7CCDChipE

For example focuser works fine:
indi_asi_focuser
Searching for HID Device VID: 0x3c3 PID: 0x1f10
1 ASI EAF attached out of 1 detected.

I enabled logs in Ekos and I see the next:

[2022-09-02T16:12:34.938 CEST DEBG ][ org.kde.kstars.indi] - Adding managed driver "ZWO Camera"
[2022-09-02T16:12:34.939 CEST DEBG ][ org.kde.kstars.indi] - Starting INDI Driver "indi_asi_single_ccd"
[2022-09-02T16:12:34.944 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "FIFO: start indi_asi_single_ccd -n \"ZWO Camera 2\""
[2022-09-02T16:12:34.945 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "With name: ZWO Camera 2"
[2022-09-02T16:12:34.945 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "FIFO: Starting driver indi_asi_single_ccd"
[2022-09-02T16:12:34.946 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "2022-09-02T14:12:34: Driver indi_asi_single_ccd: pid=2076 rfd=10 wfd=15 efd=16"
[2022-09-02T16:12:34.946 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2022-09-02T16:12:35.059 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "2022-09-02T14:12:35: Driver indi_asi_single_ccd: indi_asi_single_ccd: symbol lookup error: indi_asi_single_ccd: undefined symbol: _ZN4INDI3CCD15addFITSKeywordsEPNS_7CCDChipE"
[2022-09-02T16:12:35.059 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2022-09-02T16:12:35.062 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "2022-09-02T14:12:35: Driver indi_asi_single_ccd: stderr EOF"
[2022-09-02T16:12:35.062 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2022-09-02T16:12:35.062 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "2022-09-02T14:12:35: Driver indi_asi_single_ccd: Terminated after #0 restarts."
[2022-09-02T16:12:35.063 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "Child process 2076 died"
[2022-09-02T16:12:35.063 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2022-09-02T16:12:35.063 CEST CRIT ][ org.kde.kstars.indi] - INDI driver "indi_asi_single_ccd" crashed!
Last edit: 3 months 2 days ago by Juan Daniel.
3 months 2 days ago #86006

Please Log in or Create an account to join the conversation.

  • Posts: 964
  • Thank you received: 128
Good :)
I think that indicates that the program was compiled against a different lib and/or using headers from another version. But there I'm on very thin ice, so maybe some of the devs can give deeper info how to proceed.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
The following user(s) said Thank You: Juan Daniel
3 months 2 days ago #86008

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
Thank you for the help.

I found this thread about this issue, I added my issue.

indilib.org/forum/ccds-dslrs/12134-indi-...need-help.html#86007
3 months 2 days ago #86009

Please Log in or Create an account to join the conversation.

Time to create page: 0.827 seconds