×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Connection to QHY268M crashes kstars after update

Yes, I checked the logs and it actually detects bayer.. so something odd is going on if the bayer property is not defined.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 months 6 days ago #86745

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 2
Understood, so additional info: My version of indi-full is still at 1.9.7 and refuses to go to 1.9.8, I don't know if this is an issue.

While this is being investigated - and I'll help however I can - what can I do to my FITS header so that say SIRIL and FITSviewer detect the bayer? It appears they depend on the property. Do I just need to set the BAYERPAT property in the FITS header? I know that it is RGGB.
Last edit: 2 months 6 days ago by George L.
2 months 6 days ago #86746

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 2
This is resolved. I don't know how it happened exactly, but basically when the camera would crash I tried a bunch of things including deleting the config files.
I found a couple of debian packages to roll bakc to for indi-qhy and used those. They didn't work perfectly but they worked well enough for me to achieve what I needed (now the question is, am I missing information in my images? The images I took before all of this were 60mb, now they're 52 ... maybe I'm just overthinking it).
So, for whatever reason those drivers did not auto-detect/write the RGGB filter field into the configuration.
I deleted the configuration, rebuilt it, and now the filter was in there automatically. It should probably be called 'bayer pattern', not 'filter' under the bayer property.

My images can be fixed by running astfits from gnuastro, so I'm very happy about that.

This was a weird misadventure but I learned a lot.
It would really be good to have a repository available that makes things available for rollbacks though.
2 months 6 days ago #86752

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 2
So while I was able to image and salvage my images, this isn't completely resolved:

1) The focus module crashes if I try to take an image with the QHY268C
2) Just like the 268 was crashing before, attempting to connect to the SV905C now crashes ekos.

My indilib is still at 1.9.7 and I see in the update some of the debug symbol packages for the drivers (*-dbg) have been 'held back'. This makes me suspect that my installation is either somehow corrupt or it's in some sort of unstable situation, and I'm thinking the indilib not updating is probably part of the reason here.

Jassem, was kstars 3.6.1 built against indi 1.9.8?
2 months 5 days ago #86770

Please Log in or Create an account to join the conversation.

Time to create page: 0.460 seconds