×

INDI Library v1.9.1 Released (26 Jun 2021)

Bi-monthly INDI Library v1.9.1 is released bringing a few new drivers and improvements to existing drivers.

Nighscape 8300 driver

  • Posts: 21
  • Thank you received: 0
Dear knro,
I have a concern to get the nightly ppa, as my setup is working nice,
so if I get the it, do I have to do again wizard steps? Or Can I save the "old setup" for keeping all same configurations?
3 years 1 week ago #27738

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
Dear knro,
I have a concern to get the nightly ppa, as my setup is working nice,
so if I get it, do I have to do again wizard steps? Or Can I save the "old setup" for keeping all same configurations?
Last edit: 3 years 1 week ago by MARCELO A B DE CICCO.
3 years 1 week ago #27739

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0

Hi folks,


Last night I did my first tests using NS 8300:
CCD recognized
ekos drive operational, ..

but downloaded images came with problems, please see attached the Print Screen.

I tried Raw and Compress mode, as well changing pooling values.

Related to images LUT : histogram and auto-stretch changes didn't work out.


LOG FILE:


"
INFO 777.180653 sec : Session log file /home/decicco/.indi/logs/2018-12-10/indi_nightscape_ccd/indi_nightscape_ccd_01:02:57.log
INFO 809.166495 sec : Exposure done, starting readout...
INFO 815.348894 sec : Starting download...
INFO 816.775435 sec : download done...
DEBUG 816.775572 sec : image size 8647584 buf 0x7f5e040012c0
DEBUG 816.843001 sec : Download 1253 lines complete.
DEBUG 816.847084 sec : Uploading file. Ext: fits, Size: 4173120, sendImage? Yes, saveImage? No
DEBUG 816.855102 sec : Upload complete
INFO 848.480348 sec : Exposure done, starting readout...
INFO 855.382166 sec : Starting download...
INFO 855.932591 sec : download done...
DEBUG 855.932738 sec : image size 8647584 buf 0x7f5e0508c430
DEBUG 855.962434 sec : Download 322 lines complete.
DEBUG 855.967527 sec : Uploading file. Ext: fits, Size: 4173120, sendImage? Yes, saveImage? No
DEBUG 855.977129 sec : Upload complete
INFO 927.358918 sec : Exposure done, starting readout...
INFO 934.154667 sec : Starting download...
INFO 935.186217 sec : download done...
DEBUG 935.186373 sec : image size 8647584 buf 0x7f5e040012c0
DEBUG 935.237929 sec : Download 791 lines complete.
DEBUG 935.241030 sec : Uploading file. Ext: fits, Size: 4173120, sendImage? Yes, saveImage? No
DEBUG 936.087299 sec : Upload complete
INFO 1007.887824 sec : Exposure done, starting readout...
INFO 1014.711328 sec : Starting download...
INFO 1015.321357 sec : download done...
DEBUG 1015.321480 sec : image size 8647584 buf 0x7f5e0508c430
DEBUG 1015.358578 sec : Download 383 lines complete.
DEBUG 1015.362182 sec : Uploading file. Ext: fits, Size: 4173120, sendImage? Yes, saveImage? No
DEBUG 1015.372706 sec : Upload complete
DEBUG 1058.023970 sec : Status change 1
INFO 1062.020244 sec : Exposure done, starting readout...
INFO 1069.307849 sec : Starting download...
INFO 1069.654936 sec : download done...
DEBUG 1069.655119 sec : image size 8647584 buf 0x7f5e040012c0
DEBUG 1069.677198 sec : Download 133 lines complete.
DEBUG 1069.682697 sec : Uploading file. Ext: fits, Size: 4173120, sendImage? Yes, saveImage? No
DEBUG 1069.695532 sec : Upload complete
DEBUG 1285.744112 sec : Status change 1
INFO 1289.753585 sec : Exposure done, starting readout...
INFO 1297.764042 sec : Starting download...
INFO 1297.764193 sec : download done...
DEBUG 1297.764232 sec : image size 8647584 buf 0x7f5e0508c430
DEBUG 1297.790032 sec : Download 135 lines complete.
DEBUG 1297.798502 sec : Uploading file. Ext: fits, Size: 4173120, sendImage? Yes, saveImage? No
DEBUG 1297.812544 sec : Upload complete
"
2 years 7 months ago #32474
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 2
Hi,

You're getting truncated images- basically the driver can't download the whole framebuffer because there's a usb synchronization issue.
What system is indi-nightscape running on?
Also, please make sure you have the latest libftdi1 package installled.
Please make sure that on Linux you have the updated udev rules installed for a usb buffer size increase. You will get this kind of problem all the time unless you increase the buffer size correctly.
You can also try running indi-nightscape as root, but i can't recommend that.

Regards,

Dirk
2 years 7 months ago #32484

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
ubuntu 18, latest release

the updated udev rules > how do I set this?
2 years 7 months ago #32485

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 2
There should be a file in /lib/udev/rules.d called:

99-nightscape.rules

Containing:
ACTION=="add", ATTR{idVendor}=="19b4", RUN+="/bin/sh -c '/bin/echo 256 >/sys/module/usbcore/parameters/usbfs_memory_mb'"
# All Celestron Nightscape Cameras
SUBSYSTEMS=="usb", ATTR{idVendor}=="19b4", MODE="0666"
2 years 7 months ago #32489

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
Thanks ! Yes the files and configuration are ok. It was a cable issue, I changed it, all nice now!
2 years 7 months ago #32959

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0

Replied by Felix on topic Nighscape 8300 driver

Hi, i have read in the driver page that it can be used with the nightscape model #95555. This one is the camera that has the KAI-10100 sensor. Did someone manage to get this cammera working with the driver.

Tanks in advance
1 year 10 months ago #44107

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 2
Hi, It's never been tested with the KAI-10100 version. It may sort-of work, but probably won't work at all.

The first thing i need is lsusb output and a full debug output from the driver during startup to see what is actually happening.

Better yet, lend me a camera for a few weeks and i'll proabbly be able to get it working ;-)
1 year 10 months ago #44123

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0

Replied by Felix on topic Nighscape 8300 driver

We would like to lend you the cammera, but we are located in Uruguay and it's a bit expensive to send it, of course we will send you the debug output, can you guide us how to get it? We have already turned on the debug option in Ekos but when pressing connect it only displays "[DEBUG] open failed!".
Is there a way to debug from console?

Thank you very much.
1 year 9 months ago #44216

Please Log in or Create an account to join the conversation.

Time to create page: 0.784 seconds