×

INDI Library v1.9.1 Released (26 Jun 2021)

Bi-monthly INDI Library v1.9.1 is released bringing a few new drivers and improvements to existing drivers.

Bug with the Indi Atik CCD driver

  • Posts: 7
  • Thank you received: 0
Helllo all,
I'm still working to make my observatory work - thanks to the Indi & Kstars ecosystem - wonderful.
I'm facing a problem with the latest versions of Indi lib (1.7.6) and Kstars (3.1.1)

When starting Ekos, I've the following message - if an Atik camera is connected, or not.
KStars detected INDI driver indi_atik_ccd crashed. Please check INDI server log in the Device Manager.

Could you help me ?

Best regards,

François
2 years 4 months ago #36755

Please Log in or Create an account to join the conversation.

what OS and architecture?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 4 months ago #36758

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Dear Jasem,
You're right, I did not give a lot of informations. Sorry.
I'm working on a laptop PC, Ubuntu 16.04.
The test I did is purely local : Kstars running on my PC, and the Indi server as well.
It worked before (few weeks ago, at least), with the same PC. I'm not sure if the problem appeared when I did upgrade to Indi/Kstars new versions, or before.

You did an amazing job, really.

Thanks,
François
2 years 4 months ago #36788

Please Log in or Create an account to join the conversation.

64bit on 16.04 is problematic due to an older glibc and I think Atik built the SDK with a more recent glibc. I will see if I can get them to send me something that works in 16.04 as well, or you can upgrade to 18.04
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 4 months ago #36797

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Ok, good to know. Thanks.
I will not upgrade my PC shortly, but the Indi server can be elswhere (on an RasPi, indeed). Then, I may work around the problem (I guess the problem with 16.04 is the Indi server, not Kstars - right ?).
I'll tell you if I still have problem. And if you want me to check a change on your side, jut ask.

Many thanks.

François
2 years 4 months ago #36799

Please Log in or Create an account to join the conversation.

This issue is only on 16.04 64bit Intel version. armhf 16.04 is fine.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 4 months ago #36800

Please Log in or Create an account to join the conversation.

Time to create page: 0.499 seconds