×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

canon 450d cannot connect to indi

  • Posts: 739
  • Thank you received: 57
Ubuntu 18.04
Hi everyone
The camera seems to be recognised:
Apr 14 18:10:44 steve-5430 kernel: [ 1550.724105] usb 3-2: new high-speed USB device number 13 using xhci_hcd
Apr 14 18:10:44 steve-5430 kernel: [ 1550.876346] usb 3-2: New USB device found, idVendor=04a9, idProduct=3086
Apr 14 18:10:44 steve-5430 kernel: [ 1550.876352] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr 14 18:10:44 steve-5430 kernel: [ 1550.876355] usb 3-2: Product: DCP CONNECT
Apr 14 18:10:44 steve-5430 kernel: [ 1550.876358] usb 3-2: Manufacturer: Canon Inc.
Apr 14 18:10:44 steve-5430 mtp-probe: checking bus 3, device 13: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-2"
Apr 14 18:10:44 steve-5430 mtp-probe: bus: 3, device: 13 was not an MTP device
Apr 14 18:10:44 steve-5430 upowerd[1033]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb3/3-2

But neither gphoto nor canon dslr will connect:
019-04-14T16:23:35: [ERROR] Can not open camera: Power OK? If camera is auto-mounted as external disk storage, please unmount it and disable auto-mount.
2019-04-14T16:23:35: [ERROR] Camera open error (-105): Unknown model

My canon 700d works fine on the same computer.

Any ideas?
Cheers and clear skies,
Steve
kubuntu 20.04
700d, eq6, t7m
2 years 5 months ago #37760
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 739
  • Thank you received: 57
Hi again. OK, I changed the udev rule and now have it reckognised as a MTP device. Is that good?

Apr 15 17:48:53 steve-ubuntu kernel: [ 2292.401396] usb 3-1: new high-speed USB device number 15 using xhci_hcd
Apr 15 17:48:53 steve-ubuntu kernel: [ 2292.553375] usb 3-1: New USB device found, idVendor=04a9, idProduct=3086
Apr 15 17:48:53 steve-ubuntu kernel: [ 2292.553382] usb 3-1: New USB device strings: Mfr=1, P019-04-15T17:52:35
Apr 15 17:48:53 steve-ubuntu kernel: [ 2292.553391] usb 3-1: Manufacturer: Canon Inc.
Apr 15 17:48:53 steve-ubuntu upowerd[1002]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb3/3-1

and
lsusb
Bus 002 Device 003: ID 064e:d251 Suyin Corp.
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 015: ID 04a9:3086 Canon, Inc.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

but:
gphoto2 --list-config
*** Error ***
Could not detect any camera
*** Error (-105: 'Unknown model') ***

indi says
No cameras detected.Check power and make sure camera is not mounted by other programs and try again.
2019-04-15T17:52:35 Unable to establish:
+ Canon DSLR
Please ensure the device is connected and powered on.
2019-04-15T17:52:30 INDI services started on port 7624.
2019-04-15T17:52:30 Starting INDI services...

Can anyone help me?
Cheers
kubuntu 20.04
700d, eq6, t7m
Last edit: 2 years 5 months ago by alacant.
2 years 5 months ago #37807

Please Log in or Create an account to join the conversation.

I think it's better to open an issue on libgphoto's Github regarding this with all the information.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 5 months ago #37900

Please Log in or Create an account to join the conversation.

  • Posts: 739
  • Thank you received: 57
kubuntu 20.04
700d, eq6, t7m
2 years 5 months ago #37909

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 1
Hi,

same thing here with a Canon EOS 700D. Cabeling and power all good, I can’t get it. 
I tried with Sequence Generator Pro and it worked. Again, I have invested so much effort and I really like the concept but I’m about to resign. 

Sorry for this but I need a working system. I still believe in STELLARMATE, but give me a hint.

thanks Gunter
4 months 1 week ago #71009

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 1
Again me, strangely enough gphoto recognizes the EOS but indi not.
4 months 1 week ago #71010

Please Log in or Create an account to join the conversation.

700D should work right away, if it doesn't work, please share the logs.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
4 months 1 week ago #71011

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 1
Hi Jasem,

Yes, I will send the Logs gut this camera has Bad a Problem Top Connect. All of the sudden is will Not work anymore. ????

Talk to you later
4 months 1 week ago #71021

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 1
Hi Jasem,

here ist the logfile. In my profile are only the telescope simulator and the Canaon 700d connected via standard USB cable.

Thank you for you help.

Bye Gunter
4 months 1 week ago #71168
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.209 seconds