×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

New Pentax Driver Testing

  • Posts: 43
  • Thank you received: 6

Replied by karlrees on topic New Pentax Driver Testing

Last I remember, StellarMate was using Ubuntu Mate. Is that still the case? Also, did you install from the package, or compile it yourself? This may be the issue where the toolchain on Ubuntu Mate doesn't compile libricohcamerasdk correctly. (One of the many frustrations that could be solved if Ricoh would just open up the SDK, or even just recompile it).
7 months 2 weeks ago #59276

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6
Just before the camera takes a picture, the screen blinks a couple of times, shows the ISO set on the camera. But when you check the FITS file afterwards it shows the ISO chosen in EKOS. I can also see the stretch values in the FITS viewer changes.
I just checked ISO800, not ISO102400, so you're right Noideaforaname, we did celebrate too early.
I'm pretty sure though, that I've been able to change ISO using PkTrigger, but I might be wrong.
Anyway, setting exposure time for me is a huge step :)
Last edit: 7 months 2 weeks ago by DrawsACircle.
7 months 2 weeks ago #59277

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
@Karl

I tried to compile the drivers, pktriggercord etc while i was running Astroberry because 3rd party drivers are not included.

But 3rd Party indi drivers are included in Stellarmate. The last monthly update featured your work. Maybe something went wrong and Jasem can fix it.

PTP is working with short exposures while using the Gphoto CCD or Pentax legacy. But i think both don't use pktriggercord. So no help at all.

And both Gphoto and Pentax legacy set the pixel resolution to 3 and 8 bit instead 3.88 and 16bit.

And i stumbled another bug (on my rig). After i turned on debugging (K70) i wasn't able to turn it off again. Purge, load, deleting the files in the ./Indi folder... nothing worked. So i did a third fresh Install today :) time to use a second mirco SD Card for testing.

@DrawsACircle

I tried again to change the ISO and took a look at the values and not the histogram. They stay nearly the same (tried ISO 100 and then ISO 102400). I will try it again tomorrow, nightshift is calling.

Did you try PTP mode?
Last edit: 7 months 2 weeks ago by Noideaforaname.
7 months 2 weeks ago #59287

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6
I have not tried PTP mode, I will tomorrow.
I guess the FITS information is based on the Ekos settings and not the EXIF information, that’s why it said ISO800.

Edit: It’s tomorrow, my pc died while flying a Cessna 172 in Microsoft Flightsim 2020 last night :(
New motherboard and cpu ordered, arriving next Thursday.
Last edit: 7 months 1 week ago by DrawsACircle.
7 months 2 weeks ago #59288

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6
Just tried PTP mode with Pentax Native, ISO can be set, but not exposure time - I tried both Bulb modes - Start/Stop trigger pulse and constant pulse, no changes.
Nothing works in PTP mode with Pentax Legacy.
So, if we could have an exposure start pulse and an exposure stop pulse, that would make the day, It should be a feature you can activate/deactivate in case you use a camera like the KP or K-1 which is supposed to be working with the Pentax SDK.
7 months 1 week ago #59388

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 6

Replied by karlrees on topic New Pentax Driver Testing

Were you using a lens, or doing prime focus? For the K-70 at least, the SDK provided by Ricoh does not expose certain settings unless it detects a lens on the camera that supports those settings. I'm sure whoever decided on this limitation thought they were doing the user a favor by only exposing settings supported by the lens, but obviously they were not thinking about prime focus. Anyway, this means that PTP mode is severely handicapped if you're doing prime focus. Much to my frustration, I did not discover this until after I had already developed the PTP driver, as I probably would have started with MSC mode only had I been aware of the limitation.

The Ricoh SDK does not support bulb mode for PTP with the K-70 (or any camera, I suspect).
7 months 1 week ago #59391

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1

karlrees wrote: (Hmmm, I did just have an idea though--I wonder if I can could add an option for the driver to downsample or clip the original image before FITs conversion, to speed things up. I'll add that to my list of things to look into).


Than the polar alignment tool in ekos would maybe also be possible using the K70 and a refresh rate around 1 - 2 seconds. Am i right?.
7 months 1 week ago #59393

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6

karlrees wrote: Were you using a lens, or doing prime focus? For the K-70 at least, the SDK provided by Ricoh does not expose certain settings unless it detects a lens on the camera that supports those settings. I'm sure whoever decided on this limitation thought they were doing the user a favor by only exposing settings supported by the lens, but obviously they were not thinking about prime focus. Anyway, this means that PTP mode is severely handicapped if you're doing prime focus. Much to my frustration, I did not discover this until after I had already developed the PTP driver, as I probably would have started with MSC mode only had I been aware of the limitation.

The Ricoh SDK does not support bulb mode for PTP with the K-70 (or any camera, I suspect).


I use my M200 f4 lens, manual prime.
For me, ISO is not that important, I tend to stick to ISO800.
@Noideadoeaname, you should be able to use your K-70 for proper polar alignment, I don’t know if 1-2sec exposure time is sufficient, if not, it will be difficult to control.
7 months 1 week ago #59400

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
That was just a flash of thought ;)

I managed to get 1 arcminute error on the K70 while using my guiding cam to do the polar alignment. Think that's okay for 750mm focal length while guiding.
7 months 1 week ago #59402

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
Anything new about the driver?
6 months 5 days ago #61429

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 6

Replied by karlrees on topic New Pentax Driver Testing

No. There are not enough hours in the day, unfortunately. I did respond to the pixel size issue on GitHub. I think it's technically a KStars/Ekos issue, not a driver issue, but the driver could probably be enhanced to supply the values for the K70 so as to avoid the issue in the future.

I had done some initial profiling a while back to see how much time FITs conversion was taking on the Pi4. I was surprised to find it taking less than a second, which is a big improvement over the Pi3 and probably attributable to having more memory available. Unfortunately, this means that clipping and/or downsampling before FITs conversion is unlikely to help much--the bottleneck right now appears to be the transfer from the camera to the Pi4. I'm going to look into it one more time just to double check, though.

Were there any other loose ends?
6 months 4 days ago #61456

Please Log in or Create an account to join the conversation.

  • Posts: 74
  • Thank you received: 6
Since you are asking Karl :-)
If we could have an exposure start pulse and an exposure stop pulse, that would make the day for K-70 users. It should be a feature you can activate/deactivate in case you use a camera like the KP or K-1 which is supposed to be working with the Pentax SDK.
Last edit: 6 months 4 days ago by DrawsACircle.
6 months 4 days ago #61459

Please Log in or Create an account to join the conversation.

Time to create page: 0.412 seconds