×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Indi support for Meade LS (Autostar III) series

  • Posts: 17
  • Thank you received: 0
Hi,
I would like to control Meade LS 8-Inch ACF (f/10) Advanced Coma-Free Telescope with Indi Ekos. This telescope is based on Autostar III version.

Anyone knows about this?

Thanks in advance!
8 years 2 months ago #6996
The topic has been locked.
Should be, just use the LX200 GPS driver.
8 years 2 months ago #6998
The topic has been locked.
  • Posts: 17
  • Thank you received: 0
Ok thanks Knro for the reply. I am going to buy this telescope as soon as possible. The advantage of single switch alignment attracted me most. If all the options can be controlled by the indi it will be superb for me. Do you know anyone used this scope with Indi or do you guess any issue may raise up?

Regards
8 years 1 month ago #7012
The topic has been locked.
Well it uses LX200 command set so I don't see why wouldn't the driver work. Only actual testing can reveal any issues.
8 years 1 month ago #7013
The topic has been locked.
  • Posts: 17
  • Thank you received: 0
Hi! Finally I bought the telescope and today I tried it to run by Kstars/indi, but failed. Please see the attached pictures.
I tried LX200 GPS library.
lsusb output: ST-Ericsson is most probably the telescope. because when I plug out the telescope usb it disappears.

Please would anyone explain me why indi is showing such errors? What can I do now to control the telescope using kstars?

Thanks in advance!
7 years 11 months ago #7950
Attachments:
The topic has been locked.
First, check if you have /dev/ttyUSB0 , then as indicated in the FAQ , add your user to the dialout group and restart:
sudo adduser $USER dialout
7 years 11 months ago #7953
The topic has been locked.
  • Posts: 17
  • Thank you received: 0
Hi!
I followed the FAQ but failed to work it out. Dialout user command does work. but ls -l /dev/ttyUSB0 shows: cannot access /dev/ttyUSB0: No such file or directory.
Note that LS8 connects with pc via Print port to USB cable.
Any further suggestion?
7 years 11 months ago #7961
The topic has been locked.
I'm not sure if ST-Ericsson is a USB Serial driver. Anyway, we can see what happens if you unplug it, then plug it back, and type
dmesg | tail -n 20

Post the output here.
7 years 11 months ago #7962
The topic has been locked.
  • Posts: 17
  • Thank you received: 0
Sorry for my late reply. I could not control the telescope yet. please help! Here is the output:

bao@bao-desktop:~$ dmesg | tail -n 20
[ 11.556640] brcmfmac: brcmf_add_if: ignore IF event
[ 11.565773] brcmfmac: power management disabled
[ 11.785255] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 11.785277] Bluetooth: BNEP filters: protocol multicast
[ 11.785302] Bluetooth: BNEP socket layer initialized
[ 12.760774] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[ 12.760798] brcmfmac: brcmf_add_if: ignore IF event
[ 24.407431] fuse init (API version 7.23)
[ 30.436181] Bluetooth: RFCOMM TTY layer initialized
[ 30.436245] Bluetooth: RFCOMM socket layer initialized
[ 30.436297] Bluetooth: RFCOMM ver 1.11
[ 72.972470] usb 1-1.2: USB disconnect, device number 4
[ 74.744076] usb 1-1.2: new high-speed USB device number 7 using dwc_otg
[ 74.844944] usb 1-1.2: New USB device found, idVendor=04cc, idProduct=0000
[ 74.844965] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 74.844979] usb 1-1.2: Product: Meade eFinder Serial Emulator
[ 74.844991] usb 1-1.2: Manufacturer: Meade
[ 74.845002] usb 1-1.2: SerialNumber: 1234567890
[ 74.846371] cdc_acm 1-1.2:1.0: Zero length descriptor references
[ 74.846397] cdc_acm: probe of 1-1.2:1.0 failed with error -22
7 years 11 months ago #8310
The topic has been locked.
  • Posts: 200
  • Thank you received: 57
To me it looks like not recognized USB port. What the bluetooth stuff is doing in the log?
Do you have a serial over BT device? What do you meen by "printer port"?
7 years 11 months ago #8311
The topic has been locked.
  • Posts: 17
  • Thank you received: 0
Hi! I don't have any serial over bluetooth device. I have been using Rpi3. The telescope connects through printer usb connector cable. I have attached a picture of it. This time I have connected a TPlink wifi adapter and the Meade LS8 in USB port. See the results:

bao@bao-desktop:~$ dmesg | tail -n 20
[ 497.560367] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 497.560380] usb 1-1.4: Product: 802.11n NIC
[ 497.560392] usb 1-1.4: Manufacturer: Realtek
[ 497.560404] usb 1-1.4: SerialNumber: 00E04C0001
[ 497.564610] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_D_CUT_1T1R_RomVer(0)
[ 498.716633] r8188eu 1-1.4:1.0 wlxec086b11c324: renamed from wlan1
[ 498.781609] IPv6: ADDRCONF(NETDEV_UP): wlxec086b11c324: link is not ready
[ 499.289767] MAC Address = ec:08:6b:11:c3:24
[ 499.291374] IPv6: ADDRCONF(NETDEV_UP): wlxec086b11c324: link is not ready
[ 499.302350] R8188EU: ERROR indicate disassoc
[ 499.316207] IPv6: ADDRCONF(NETDEV_UP): wlxec086b11c324: link is not ready
[ 499.455753] IPv6: ADDRCONF(NETDEV_UP): wlxec086b11c324: link is not ready
[ 500.529539] usb 1-1.2: new high-speed USB device number 10 using dwc_otg
[ 500.630783] usb 1-1.2: New USB device found, idVendor=04cc, idProduct=0000
[ 500.630805] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 500.630818] usb 1-1.2: Product: Meade eFinder Serial Emulator
[ 500.630831] usb 1-1.2: Manufacturer: Meade
[ 500.630843] usb 1-1.2: SerialNumber: 1234567890
[ 500.632393] cdc_acm 1-1.2:1.0: Zero length descriptor references
[ 500.632426] cdc_acm: probe of 1-1.2:1.0 failed with error -22
7 years 11 months ago #8321
Attachments:
The topic has been locked.
From Meade download page they offer PL2302 driver, but then the 0x04CC vendor is ST-Ericsson and the Kernel cdc_acm driver does not recognize it. I think maybe the kernel needs to be patched to support this, but I'm not sure, I'll investigate later.
7 years 11 months ago #8324
The topic has been locked.
Time to create page: 0.639 seconds