×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Cannot save dark images in EKOS -KStars using ZWO cameras

  • Posts: 14
  • Thank you received: 2
Hi,
I have a little annoying problem with dark frames. I am running Indi Server on a remote machine in my backyard, and controlling everything using KStars with EKOS from an Ubuntu machine.
I am not able to save dark frames with my ZWO cameras (both ASI120MC-S and ASI178MC-Cool). The guide module is asking everytime to take a new dark image and images are not saved in ~/.local/share/kstars/Darks.
The dark frames are subtracted after taking them though.
I already made myself owner and full write permits in that directory, which I catched from another post.
Using the Simulator dark frames are saved and reused properly, so no problem with write permissions there, I assume.

This is the log output from the guide module:
2017-02-18T10:48:12.227 - DEBG - Guide: Capturing frame...
2017-02-18T10:48:18.343 - DEBG - Guide: received guide frame.
2017-02-18T10:48:18.356 - WARN - Audio notification requested, but sound file from notifyrc file was not found, aborting audio notification
2017-02-18T10:48:28.458 - DEBG - Guide: "Capturing dark frame..."
2017-02-18T10:48:34.587 - DEBG - Guide: "Dark frame received."
2017-02-18T10:48:34.687 - CRIT - FITS: Failed to copy "/tmp/fitsw15477" to "home/lutzbellmann/.local/share/kstars/darks/darkframe_2017-02-18T10:48:34.fits"
2017-02-18T10:48:34.687 - CRIT - DarkLibrary: Failed to save dark frame "/home/lutzbellmann/.local/share/kstars/darks/darkframe_2017-02-18T10:48:34.fits"
2017-02-18T10:48:34.887 - WARN - Audio notification requested, but sound file from notifyrc file was not found, aborting audio notification


Can anybody help? This is really annoying!
5 years 4 months ago #14604

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 2
I just noticed that in the log output there is missing a "/" slash in front of home/lutzbellm... !
When I tried to handcopy the file out of the /tmp directory I could place it in the dark folder with no issue.
Yet it is not showing up in the dark library in the EKOS module.

Can anybody confirm, that this missing slash is the root cause?
5 years 4 months ago #14605

Please Log in or Create an account to join the conversation.

  • Posts: 469
  • Thank you received: 84
That looks like the autofocus issue I was having with my 550D. Autofocus images where not saved too!!!

indilib.org/forum/focusers-filter-wheels...es-kstars.html#14084
(PT) SC@ROS Observatory
TS 6" F4 Newt / Nikon D5500 / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
5 years 4 months ago #14608

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 2
Is this solved now for you? How can I put the slash in there?
5 years 4 months ago #14609

Please Log in or Create an account to join the conversation.

  • Posts: 469
  • Thank you received: 84
Yes for me it's solved, Jasem said he would take a look, I don't really know if he saw something on the code. I recompiled indi-gphoto from the sources and it's working ok. In your case it's indi-asi. Maybe compiling it from sources will solve your issue too.
(PT) SC@ROS Observatory
TS 6" F4 Newt / Nikon D5500 / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
Orion 120ST / Explore Scientific 80APO / TSAPO102Q Sextuplet / G2-8300FW5 / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/
The following user(s) said Thank You: Lutz Bellmann
Last edit: 5 years 4 months ago by nMAC.
5 years 4 months ago #14613

Please Log in or Create an account to join the conversation.

All these issues are solved in 2.7.5, currently building in PPA.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: nMAC, Lutz Bellmann
5 years 4 months ago #14614

Please Log in or Create an account to join the conversation.

Time to create page: 0.700 seconds