×
INDI Library v1.8.7 Released (21 Nov 2020)

Nov. 2020 Release brings significant improvements to streaming and recording videos. Support for new drivers including Estatto focuser and Pegasus falcon rotator.

Time issue with Ekos/INDI and iOptron CEM-60

2 years 3 months ago
crw4096
Expert Boarder
Expert Boarder
Posts: 94
More
Topic Author
Time issue with Ekos/INDI and iOptron CEM-60 #28922
Hi,

I'm having a frustrating issue with the time setting. It seems that my mount and Ekos/INDI are fighting over what the right time is, and my mount always loses. These steps will reliably duplicate the issue:

1) Turn on mount, wait for GPS to lock. On hand controller, go to "Settings", "Set Time and Site". As I am in the US Eastern time zone with Daylight Savings time, I set the DST to "Y" and the UTC -300 minutes, because we're 5 hours behind UTC + 1 hour for DST, as instructed by the mount manual.
2) Start INDI on the Raspberry Pi; everything checks out
3) Start kstars, start Ekos, start INDI

At this point, I can verify that the mount hand controller still shows the correct time and correct offset from UTC.

4) In the INDI control panel, connect to the mount.

At this point, checking the hand controller shows that the offset from UTC is -240. The time still shows correct for local time, which is strange and bad, because now when I try to point to anything, it always points one hour further east than where it should. The only way to fix this is to disconnect INDI, change the UTC offset back to -300 and power cycle the mount.

This has been a problem for me where I had to trace down time configurations in many places - kstars (site location data), the Raspberry Pi, the mount, and I've gotten down to this. When I open the mount INDI config page and go to site management, it tells me the UTC time is an hour ahead of what it should be and the UTC offset is -4. It's impossible to set these directly it seems.

Anyway, I'm at my wit's end. I have attached a log file with my lat and long scrubbed. It's not very long. I've only started up, connected to the mount, waited a bit and then disconnected after seeing the UTC offset changed.

Other random config stuff:
I'm not using the INDI Web Manager. In the Ekos Profile Editor, I've selected "iOptron CEM60". The drivers on the Raspberry Pi are not the latest, but are not more than a month old. The telescope driver I'm using is: indi_ieq_telescope

Well that's all I can think of. Let me know if there's anything else I can provide. Thank you for any help.

Charles Wright

Ubuntu 18.04 and Raspbian Jessie; INDI 1.7.4
Mounts: CEM-60 chiefly; iEQ45
Cameras: Atik 383L+, QHY5-II-M
Focuser: Moonlite
Attachments:

Please Log in or Create an account to join the conversation.

2 years 3 months ago
knro
Administrator
Administrator
Posts: 8544
Karma: 51
Time issue with Ekos/INDI and iOptron CEM-60 #28923
The problem you're seeing is due to daylight savings. From the logs:
[2018-08-23T21:30:46.328 EDT DEBG ][                org.kde.kstars] - Next Daylight Savings Time change (Local Time):  "Sun Nov 4 02:00:00 2018 GMT"
[2018-08-23T21:30:46.328 EDT DEBG ][                org.kde.kstars] - Next Daylight Savings Time change (UTC):  "Sun Nov 4 06:00:00 2018 GMT"
[2018-08-23T21:30:46.362 EDT DEBG ][                org.kde.kstars] - Daylight Saving Time active
[2018-08-23T21:30:46.362 EDT DEBG ][                org.kde.kstars] - Next Daylight Savings Time change (Local Time):  "Sun Nov 4 02:00:00 2018 GMT"
[2018-08-23T21:30:46.362 EDT DEBG ][                org.kde.kstars] - Next Daylight Savings Time change (UTC):  "Sun Nov 4 06:00:00 2018 GMT"
[2018-08-23T21:30:46.362 EDT DEBG ][                org.kde.kstars] - Starting the timer
[2018-08-23T21:30:46.464 EDT DEBG ][                org.kde.kstars] - Date/Time is: "Fri Aug 24 01:30:46 2018 GMT"
[2018-08-23T21:30:46.464 EDT DEBG ][                org.kde.kstars] - Location: "Winchester, Massachusetts, USA"
[2018-08-23T21:30:46.464 EDT DEBG ][                org.kde.kstars] - TZ0: -5 TZ: -4

TZ0 is your UTC offset, and TZ is offset with daylight saving accounted for. 4x60 = 240 so this is what INDI uses. Probably disabling daylight savings in the controller would solve this since KStars would set the correct offset with daylight savings accounted for already. The mount probably receives -4 and then it applies its own daylight savings correction would would make this -3 or something like that.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You crw4096, radmilo

Please Log in or Create an account to join the conversation.

2 years 3 months ago
crw4096
Expert Boarder
Expert Boarder
Posts: 94
More
Topic Author
Time issue with Ekos/INDI and iOptron CEM-60 #28947
Hi Jasem,

Thanks; setting DST off and UT offset = -240 in the mount worked.

Would be nice, however, to have this work without this "hack", especially since the kstars "Set Geographic Location" config includes fields for selecting both the UT offset and DST rules for the site. Would that be possible?

Charles

Ubuntu 18.04 and Raspbian Jessie; INDI 1.7.4
Mounts: CEM-60 chiefly; iEQ45
Cameras: Atik 383L+, QHY5-II-M
Focuser: Moonlite

Please Log in or Create an account to join the conversation.

3 months 2 weeks ago
DarrenW
Fresh Boarder
Fresh Boarder
Posts: 1
More
Time issue with Ekos/INDI and iOptron CEM-60 #58051
Did you change the UT offset in the HC before or after connecting the mount? I am using a CEM25P with an ASIair and am having the same issues with DLS. I ended up here because it uses the INDI drivers.
Thanks
Darren

Please Log in or Create an account to join the conversation.

3 months 1 week ago
radmilo
Fresh Boarder
Fresh Boarder
Posts: 1
More
Time issue with Ekos/INDI and iOptron CEM-60 #58229
Darren, you have to set your DST to off in the HC of the mount, prior to connecting it to Ekos/Kstars, otherwise it would not have any effect.

I confirm the described issue also for an iOptron iEQ30 Pro mount. If the mount has DST on, after connecting it to Ekos, it will slew away from the target 1h east in RA.

Jasem's solution is correct, disabling DST in the mount will make it slew right where it is supposed to.
The following user(s) said Thank You DarrenW

Please Log in or Create an account to join the conversation.

3 months 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 978
Karma: 3
More
Time issue with Ekos/INDI and iOptron CEM-60 #58246

radmilo wrote: Darren, you have to set your DST to off in the HC of the mount, prior to connecting it to Ekos/Kstars, otherwise it would not have any effect.

I confirm the described issue also for an iOptron iEQ30 Pro mount. If the mount has DST on, after connecting it to Ekos, it will slew away from the target 1h east in RA.

Jasem's solution is correct, disabling DST in the mount will make it slew right where it is supposed to.


Same problem and solution for iOptron SmartEQPro+. Not surprising, it is using the same hand controller and driver as the CEM60.

I found this out the hard way earlier this spring.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You DarrenW

Please Log in or Create an account to join the conversation.

Time to create page: 0.193 seconds