×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

Weather radio don't want connect

  • Posts: 89
  • Thank you received: 16
My investment has arrived a nice little Wemos No NAME D1 mini EUR 5.59, for pennies.
SSD1306 OLED 0.96", EUR 6.46.

I also discovered that you can use a slightly different oled begin call to use my old SH1106, but there are some artefacts.

Works perfectly with version 1.11 development with my hardware, (MLX90614, BME280, TSL2591, Davis anenometer, OLED)
Had to figure out that the pins have a different numbering to the arduino.
Wemos	Arduino	Connected
D0	16
D1	5	Yellow	SCL
D2	4	Green	SDA
D3	0	Purple	Anenometer Wind Speed
D4	2	
D5	14
D6	12
D7	13
D8	15	Grey	Button
Tx	1
Rx	3

So this confirms problem on older hardware is not a wireing problem but most likely a short of memory problem,
I will let it run for a few days to see if there are any crashes or bugs, that I can see.

Then I will try with the RG-11.

As promised I have developed a slim version for the arduino UNO, which is free for perusal on github, the code is very simple
but will work with the sensors above (didn't try OLED) and not crash the arduino.

Feel free to look at it if you wish
github.com/procras2/OledBME

I got it to talk with indi after I figured out the firmware version number must be surrounded by ".

Now that I see how nice the wemos is, I will try to build my next station (no leaks!) with it.

Adrian
Last edit: 8 months 1 day ago by Adrian. Reason: Forgot url
8 months 1 day ago #66072

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
Hello
I still have my recurring problem that causes the station to make a mistake every 1 to 2 weeks.
******************************************************************************************************
afa@NAFABox:~$ sudo service indi-weatherradio status
[sudo] Mot de passe de nafa :
● indi-weatherradio.service - INDI server for weather radio
Loaded: loaded (/etc/systemd/system/indi-weatherradio.service; enabled; vendo
Active: failed (Result: exit-code) since Fri 2021-01-15 01:19:02 CET; 3 days
Process: 1270 ExecStart=/usr/bin/indiserver -v indi_weatherradio (code=exited,
Main PID: 1270 (code=exited, status=1/FAILURE)

Warning: Journal has been rotated since unit was started. Log output is incomple
lines 1-7/7 (END)
***********************************************************************************************
do you have an idea where the problem can come from?
Can an update fix the problem?

And above all, how to update without changing the different settings made from the beginning.
I ask because it's not me who installed it and I'm still a novice in linux.

Best regards
Christophe
8 months 16 hours ago #66097

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 246
Salut Christophe,
it looks like starting the indiserver fails or it fails with an exception during runtime. Have you tried to start it manually? Execute the following from a terminal and post here what happens:
/usr/bin/indiserver -v indi_weatherradio

Regarding the configurations: there are several configurations:
  • For the Arduino firmware, config.h holds the configuration of the firmware loaded onto the Arduino.
  • The INDI service stores the service configuration in .indi/Weather Radio_config.xml
  • For the web page scripts, wr_config.py holds the configuration for updating the web page data
HTH
Wolfgang
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
8 months 7 hours ago #66117

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
so here's what it looks like with the command line

nafa@NAFABox:~$ /usr/bin/indiserver -v indi_weatherradio
2021-01-18T22:28:22: startup: /usr/bin/indiserver -v indi_weatherradio
2021-01-18T22:28:22: Driver indi_weatherradio: pid=3666 rfd=3 wfd=6 efd=7
2021-01-18T22:28:22: listening to port 7624 on fd 4
2021-01-18T22:28:22: Driver indi_weatherradio: snooping on GPS Simulator.GEOGRAPHIC_COORD

does it help you understand my problem?

and I always launch it manually, the program and on a dedicated arduino only for the weather.

I think it lasts about 7 days. Is there a way to make it reboot automatically every hour at a certain time?


PS: And something out of the question, since you're so good, would it be possible to get a statistic of the nights?
so that we can know which nights were good during the year.
8 months 3 hours ago #66141

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 246
Not yet, since this only shows that it is working. You should log the output so that we can find the problem.
/usr/bin/indiserver -v indi_weatherradio >> /tmp/indiserver.log
I wouldn‘t recommend it, better track down the problem. I have it running for months without a problem.

I‘m not so sure what you mean. Is this more than the recording done for the weather radio web page? Take a look at my own instance here: weather.openfuture.de/
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
8 months 3 hours ago #66144

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
Hello Wolfgang

so I restarted and typed the command line you gave me to record what happens when it disconnects.

About what I meant by "a good average night's sleep."
is that if you put the 30d tab .
Because it makes a kind of average of all, so it works for temperature, humidity and pressure.
But not for clouds and SQM, it gives you values that are not very consistent (in my opinion).

So an interesting option would be to have what are the nights when there were no clouds between 2 SQM values. Like that or could know, as an example, that during "the year" there was a certain number of nights exploitable for observation.
Or we could do the same thing with how many days in the year it was sunny, keeping the days where there were less than a certain percentage of clouds in the morning and in the evening.

I don't know if you know what I mean.

See you soon.
7 months 4 weeks ago #66178

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 246
Christophe,
these are very specific questions and I'm not sure how to calculate these values.

The best way to get closer is to extract the data manually from the RRD file, import it into a spreadsheet and try to build the appropriate formulae. As soon as we have them, we can discuss how to implement them.

To extract the data, you need rrdtool installed on your machine. If it is not present, issue
sudo apt install rrdtool

For extracting the data from the RRD file, use rrdtool fetch. For example, with
rrdtool fetch weather.rrd AVERAGE -s -100d -r 1h
you extract the 1h averages of all parameters of the last 100 days.

If you need additional help, send me a PN here so that we could continue to discuss by email.

Cheers
Wolfgang
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
7 months 4 weeks ago #66192

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
Hello
so I tried this command but it gives me an error.

nafa@NAFABox:~$ rrdtool fetch weather.rrd AVERAGE -s -100d -r 1h
ERROR: opening 'weather.rrd': Aucun fichier ou dossier de ce type
nafa@NAFABox:~$


I also tried to try to decipher the data file, but I think there will be a problem, because the cloud cover depends on a calculation from the sky temperature, as the SQM depends on the Lux value.
So how to do it?
7 months 4 weeks ago #66231

Please Log in or Create an account to join the conversation.

  • Posts: 835
  • Thank you received: 246
You need to issue this command from that directory where weather.rrd is located. Should be /usr/local/share/weatherradio or /usr/share/weatherradio.
Cloud coverage is stored directly, so you can access the data directly from the rrd file.
TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
7 months 4 weeks ago #66255

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
Ok, so now I got to read the data.
So now, I would have to select a time slot for data collection.
example :from 6pm to 6am
then choose in this time frame the tolerance you want for clouds.
example: 2% of cloud during .
and then do a good day count.
Example : since January 1st there has been : "4" good night.

Do you think it's possible to do it, I realize that it's not directly useful for a night of observation, nor for the security of closing a roof.
But it would be interesting to know and remember which nights have been good during the year, and compared between years and different places.
7 months 4 weeks ago #66258

Please Log in or Create an account to join the conversation.

  • Posts: 177
  • Thank you received: 3
Hello
So I just saw that my station spat out this morning.
So how do I find out where and what the problem is?
7 months 4 weeks ago #66281

Please Log in or Create an account to join the conversation.

  • Posts: 89
  • Thank you received: 16

Replied by Adrian on topic Weather Radio - info channel

If you started your indiserver with this command
/usr/bin/indiserver -v indi_weatherradio >> /tmp/indiserver.log

You could look at /tmp/indiserver.log to see what it says. If it is not too large you could post it or a link to it.

Are you using an Arduino? or a Wemos? See problems with crashes above when using a small memory device with many
sensors.

How many sensors are you running?

My box kept on dying because of dew and wetness, the dampest sensors were getting very crusty due to
electrolysis. I could rescue some of them by cleaning with alcohol and I have tried to preserve my next batch
by covering the contacts with clear nail polish.

It would sometimes run for a week or so, then stop working and I would go out and dry it out to revive it.

Could be a hardware problem or a software problem.



Hope you get it fixed.

Adrian
7 months 4 weeks ago #66292
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.795 seconds