×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Meridian Flip not working with the Astrometry

  • Posts: 12
  • Thank you received: 0
Hi Wolfgang

I got up to do the flip myself and Lo and behold!? he did the meridian flip automatically.

Now I have clouds, so I stopped my observation.

I can still see enough stars for testing again, I selected a Star in nearby the meridian to test it is works again.
Unfortunately, it he works not a second time.

Unfortunately, before I started my observation this evening, I switched off all logs.

What I not understand is why is working without Alignment, but once I activate the Alignment the Meridian Flip is not anymore working.
I use not anymore a controller for the mount, perhaps I am wrong but is in the mount are not only a controller for the stepper motor?
I arrange my equipment and then I go to my bed is 3:30am is time to sleep.

I wish you a good night,
Matthias
2 years 2 weeks ago #59651

Please Log in or Create an account to join the conversation.

  • Posts: 981
  • Thank you received: 296
Hi Matthias,
did I get it right, it's the second meridian flip that does not work? There is indeed a bug in the most recent version of KStars that prevents a second meridian flip.

We are working on it. If you know how to compile from sources, you could try to use the sources from my KStars clone from invent.kde.org/wreissenberger/kstars.git using branch bugfix_mf_paused.

And do yourself a favor: leave the logs on. Using KStars is komplex and if you want to get help, you will need log files.

Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
Last edit: 2 years 2 weeks ago by Wolfgang Reissenberger.
2 years 2 weeks ago #59656

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
Hi Wolfgang,

Sorry my English is not so good
I will try to explain the situation in a few words.

1; The Meridian Flip always works when I only use GOTO, which I tested several times a day and night.

2; The Meridian Flip never works, when I use the Align option with the solver.

3; Except this night he did the Meridian Flip correctly, the only difference to all tests before that all logs were turned off.

Matthias
2 years 2 weeks ago #59671

Please Log in or Create an account to join the conversation.

  • Posts: 981
  • Thank you received: 296
Hi Matthias,
the only thing were I'm almost 100% sure: it's not correlated whether the logs are on and off.

For the rest: please post logs, and best with verbose mode on and at least INDI and mount selected in the logging options. This is the only chance how we could drill it down, the rest is speculation...

Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
2 years 2 weeks ago #59672

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
Hi Wolfgang,

Ok, For the next 3 nights the weather forecast is very bad maybe small chance from Sunday to Monday.

Matthias
2 years 2 weeks ago #59678

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 8
Hi, only my 2 cents: meridian flip does not happen if Kstars and mount disagree about time/location. Only difference is that when you solve for slew to target, KStars *syncs* your mount to the solved coordinates; at that time, if they disagree abount time (for instance, for different treatment of Daylight Saving, that I saw happen) mount will be confused and think meridian is not where it should be.
Double/triple check time and location settings, and time/location sync between KStars and mount (you have three different options in KStars settings about that).

Hope this helps
2 years 2 weeks ago #59684

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
Hi Wolfgang,

The tip with the delay was good with H0.3 the Meridian flip works mostly.
At the night from Saturday to Sunday the flip has works, also the new alignment and the guiding.

I have done some test, (before I started with real observation), with objects nearby the meridian line then the new alignment and guiding procedure has not started, (see picture object NGC7380)

From Sunday to Monday the Meridian Flip has not worked and the position of the telescope this morning was really strange.

The log file from Saturday to Sunday log_20-48-41.txt
The log file from Sunday to Monday log_20-22-27.txt

Perhaps the weather is that evening also good enough to try again.

Matthias

P.S. I installed a safety system, to switch off the system on collision.

File Attachment:

File Name: log_20-48-41.txt
File Size:776 KB

File Attachment:

File Name: log_20-22-27.txt
File Size:476 KB
Last edit: 2 years 1 week ago by Haase.
2 years 1 week ago #59938
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
Hi "picciux",
sorry for my late reply.
The time settings seem be correct, the problem was really the hour setting for the Meridian Flip.
Last edit: 2 years 1 week ago by Haase.
2 years 1 week ago #59939

Please Log in or Create an account to join the conversation.

  • Posts: 981
  • Thank you received: 296
Hi Matthias,
the log from Sunday to Monday is on INFO level, unfortunately. The meridian flip is initiated at 1:08, but there is no entry that the flip completes. So it remains difficult to explains what happens...

Nevertheless, even if you did it already, please check in the INDI dialog whether your mount has the same location as KStars and is working on the same time. A delay of 0.3h seems too much for me.

Just another idea: maybe your Raspberry or your mount changes time after the initial sync between KStars and the mount happened.

It would be great if you could provide a log on VERBOSE level where the MF fails.

Cheers
Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
2 years 1 week ago #59944

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
Hi Wolfgang,

Ok, I will check the time after the initial sync.

For me the log file looks also very strange, no more pictures were taken, and the mount ran in the completely wrong direction.

My log setting is
Verbosity: Verbose
Output: File
Ekos: Alignment and Mount

Maybe you think it's good to add schedulers or something else too?

Cheers,
Matthias
2 years 1 week ago #59995

Please Log in or Create an account to join the conversation.

  • Posts: 981
  • Thank you received: 296
Hi Matthias,
should be sufficient, but if you are not very limited with disk space, better tick all EKOS devices. You never know...

Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
2 years 1 week ago #60002

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
Hi Wolfgang,

Sorry for my late reply! (strange not receive an e-mail)

I checked the time between Rasp and Mount this seems to be correct, anyway with my mount I have no problems with 18 minutes over the Meridian.
I will check again everything to reduce the time.

Thank you very much for your help the Meridian flip has works several times so I think we can close this post.

I have another problem, from time to time the autofocus runs over the allowed max travel.
But I will first read more in the forum maybe someone has the same problem.

If I cannot find a solution, I will open a new post with all information.

Again, thank you very much for your great help.
Cheers Matthias
2 years 1 week ago #60186

Please Log in or Create an account to join the conversation.

Time to create page: 1.008 seconds