×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

Missing Ekos Tab in KStars 3.5.3 Linux Upgrade

Going to rebulild KStars now, should be fixed soon.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Christopher Kovacs
1 month 4 weeks ago #70545

Please Log in or Create an account to join the conversation.

  • Posts: 309
  • Thank you received: 13
I am running Kstars 3.5.3 on an Rpi4 with an Ubuntu 20.1 64 bit OS.  I have the EKOS icon in Kstars, but I seem to have a missing tab in the Indi Control Panel. In my profile I have an SX CCD and I get no errors about the driver crashing in the log, but I get no tab for the SX CCD in the Indi control Panel, so I cannot connect. The camera runs fine in PHD2 as a stand alone. As I mentioned in another thread I have tried to make sure I have all the xml files in the right locations, but that has not restored the tab in the control panel.



 
Last edit: 1 month 4 weeks ago by Ronald Scotti. Reason: corrections
1 month 4 weeks ago #70560

Please Log in or Create an account to join the conversation.

  • Posts: 309
  • Thank you received: 13
spoke too soon, I just did an upgrade (after I saw that Jasem was working on a new rebuild and now Ekos is missing from Kstars on Ubuntu 20.1 on Rpi-4.
I will reboot and try again.

Nope, no joy.  Ekos is even missing from Kstars settings.

Is there a was to recover Kstars 3.5.0 for Linux on Rpi-4?
 
Last edit: 1 month 4 weeks ago by Ronald Scotti. Reason: corrections
1 month 4 weeks ago #70566

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Same problem on RPi4 4GB running Ubuntu 20.1, decided to finally try the stable version after having a locked-in nightly version from a couple of months ago that was working fine. Looks like Jasem is sorting it out as we speak.
Interestingly I did a stable KStars upgrade on another Rpi only two days ago and that was perfect but that said it was 3.5.3 trial version (not stable) although I was accessing the stable ppa ?
I suppose we just wait or roll back to a previous version. No worries either way for me lots of cloud on the way over the next few days. :)

Mike
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 120SSD running KStars/Ekos/Indi under Ubuntu Mate 20.10, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

1 month 4 weeks ago #70569

Please Log in or Create an account to join the conversation.

  • Posts: 309
  • Thank you received: 13
How do we roll back to a previous version? Unfortunately, I did not save the SD card image (like I should have) when I was running Kstars 3.5.0.
1 month 4 weeks ago #70572

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hmm, I feel sure that there is a repository of previous versions ? github. You could try using the KStars snap package which is often an older version. Here is a link snapcraft.io/install/kstars/ubuntu
This enables a roll back if you install another later using the same method I think.
I always have a cloned SD card just for this eventuality as I have been bitten before.

Mike
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 120SSD running KStars/Ekos/Indi under Ubuntu Mate 20.10, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

1 month 4 weeks ago #70573

Please Log in or Create an account to join the conversation.

  • Posts: 309
  • Thank you received: 13
"snap" does not seem to work on ARM64 (Rpi) hardware? I burned the SD card to and SSD, but there is no way to get the OS off the SSD as it is too large for the SD card (I should have made a smaller partition). Anyway I think I am stuck until Jasem fixes the latest release.

thanks,
1 month 4 weeks ago #70574

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 1
I also have the same result of not being able to access Ekos after updating to the latest KStars.

I can't seem to find a way to roll back. It looks like the PPA package listing only contains the most recent version. The same is true for Snap.

I might be missing something with the PPA package listing though. 

Anyone else have any luck on a rollback? I suppose I could build from source.

 
1 month 4 weeks ago #70575

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 1
I have the same result. Upgrade on Ubuntu makes Ekos disappear entirely from KStars.

Can't figure out a way to roll back -- both snap and the ppa seem to have only one version, unless I am missing something. I really wish there was an obvious way to roll back. If I can help with that, let me know.

Also, apologies if this is a double post. My prior reply didn't seem to get posted. Or maybe it's in some kind of new-account limbo.
1 month 4 weeks ago #70576

Please Log in or Create an account to join the conversation.

  • Posts: 238
  • Thank you received: 15
To my knowledge there is only one version, so upgrading is a one way street. Crazy decision, if you ask me....
1 month 4 weeks ago #70579

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hi,

I had a similar problem and managed to shrink the image size by shrinking the unused portion of the drive so that it fit onto the receiving drive. I think that my problem was the other way around with a 125GB image from SD going onto a 120GB SSD. I think that I used GPARTED to shrink the unused section of the SD and reimaged just the reduced partitions and everything fitted OK.
There are a number of tutorials on You Tube how to do this. If I can find the one I used I will post it up for you.
I feel sure that I found a library of older KStars versions when I needed to roll back several months ago. I will hunt around tonite as its cloudy so nothing else to do :)

Mike
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 120SSD running KStars/Ekos/Indi under Ubuntu Mate 20.10, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

1 month 4 weeks ago #70581

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
I seem to remember using this site to access older versions of KStars in the past. pkgs.org/search/?q=KStars
Currently version 3.4.2 is available (search in your current linux flavour). Having said that I am sure that the problem will be fixed soon.

Mike
iOptron CEM40G, SharpStar CF90IIApo with Moonlight focuser, ASI294MCpro, ASI120MM-S, DIY MyFocuserPro2, RPi4 8Gb 120SSD running KStars/Ekos/Indi under Ubuntu Mate 20.10, DIY flat box
Skywatcher Flextube 12" Dob, Meade LX75 8SCT, Skywatcher NEQ6Pro

1 month 4 weeks ago #70582

Please Log in or Create an account to join the conversation.

Time to create page: 1.311 seconds