Hello Hy,

Thanks for all the great work on the multistar internal guiding!!!
I have the same set up and as long as you can access initially with a monitor I would set up NoMachine in this situation. The web site gives all the instructions. Set up V8 version for Raspberry Pi on the Pi and make a note of the IP address of the Pi. It will start NoMachine at boot up thereafter. Then set up on the computer that you want to access the Pi from. Follow instructions . Provided both are accessing the same wifi network you should be able to create a connection icon on the computer that you want to view and control the Pi wish allows easy connection. There are various options about how to view the remote desktop, choose whatever suits. I find using a static IP address on the Pi helps with this connection.

Good luck

Mike

Read More...

Michael Hamilton replied to the topic 'ttyusb0' in the forum. 2 weeks ago

Glad it is all sorted.

Read More...

Hi Henry,

Here is a final update that will hopefully get you on the right track.
This is the work flow that I would suggest for you. First go into the /.indi folder and delete the Astrophysics Experimental_congig.xml file. This allows a fresh initialisation of the mount (COLD).
Ensure that "KStars updates the mount" box is ticked.
Keep your mount unpowered for this first stage. This is very important (I forgot to say this last time - sorry). It should be connected via usb as usual though.
Start up KStars, start the ekos profile that you have created with your mount included.
Navigate to the indi mount gui tab and you will see various messages as it tries to connect. Wait until this search stops and the tell tale light next to the connect buttons goes red. This means it has stopped trying to connect.
You should now just see the connection boxes and the cold/warm buttons only in the mount gui.
Power up your mount and press the connect button.
The full mount gui will come up.
Set your "park from" and "park to" mount positions then go to the options tab and save config.
Now back to the main mount gui and press "cold"
You should see the button activate and you should now be able to see the "unpark/park" buttons become active.
Go to the ekos mount gui (or the indi gui) and select "unpark". You should now see the mount icon in the correct position on the planetarium
Now you are unparked you should go to the "Site Management" tab in the indi mount gui and you should see that there is a red light next to the parking position config. Click "write data" and this will turn green indicating this is now saved.
Now do a test slew to check it is all working.
Now click "Park" on the ekos mount gui and the mount will slew back to your chosen parking position.
You can unpark now and slew as per normal.
If you now disconnect and exit indi/ekos and KStars you should now only need to do a warm start as your parking data should be saved.

So to check this lets do a warm start.
Remember to always start with the mount unpowered.
Start Kstars and then your profile.
As before wait for the attempt at connection to finish (red light next to connection)
Then power up the mount and press connect.
Check that the "park from and to" info is correct (you will usually still have to set the "park to" information)
At this point I always save the config in the options tab. You should not need to do anything in the site management with a warm start.
Click "warm" and the park/unpark will become active.
Unpark and check that the mount icon is in the correct place.
You can use the mount normally now. If you look at the site management tab it should show the parking data with a green light (if not press "write data" and it will go green (this should not be necessary though in a warm start).

Good luck

Mike

Read More...

Hi Henry,

I can confirm that the current Astrophysics experimental driver does work well in the Southern Hemisphere (Brisbane) in the following setup.
RPi4 running Ubuntu Mate 20.1 and using the current KStars Nightly build (now locked in). The mount is Astrophysics GTO1100 with the the CP4 controller and V13 firmware. The connection to the Pi is direct USB2 with no handbox.
If you have been trying some different configs I would suggest that you open the /.indi folder and delete the Astrophysics Experimental_config.xml file in order to start afresh.
Plug the mount into the RPi and powerup the mount. Start KStars and EKOS and start the profile that you have created for the mount (just for testing keep this simple and just use the mount and a CCD simulator.) Make sure that you have set your geographical co-ordinates in KStars settings and tick the "KStars updates the mount" box.
As has been mentioned before you could disable verbose logging if this interferes with the buttons (cold and warm)
Start the driver profile and open up the Astrophysics tab in the indi gui.
Do not unpark yet!
Go to the "unpark from" and set this to whatever your mount is current set at (Park 2 or Park 3 seem to work for me) make sure the mount is at the position that you set for "Park from"
Go to "Park To" and set whatever you normally park to (usually Park 3 for me).
At this point do not worry about where the mount appears on the KStars planetarium
In the indi gui click the cold start button.
Make sure that the "park to and from" values have not changed
Now click on unpark and track in the EKOS gui (or the indi gui)
Your mount should not move at all but should start to track
Now go to the Site Management tab in the indi driver and click on write data to save the parking co-ords
Now you should be able to do a test slew by clicking on a point relatively close to the current mount position be ready to stop the mount in case it flies off in the wrong direction
The mount should slew to the desired point on the planetarium.
Now go to the options tab in the indi mount gui and click "save config".
Now try parking but just check that the indi gui shows your desired parking position.
Press "park" in either the indi or EKOS tabs and the mount should park OK.
Try disconnecting the mount, close down the program then restart and connect again.
Your information regarding parking positions should now be retained for "park from" but is unlikely to hold for "Park to" so always remember to set this before you unpark and save the config but you will have to click on cold start in order to be able to unpark and continue as before.
If for any reason the cold/warm start buttons dont work just disconnect the mount then reconnect and select cold start to allow the unpark to work
It's not perfect but it is workable once you understand the limitations.
Previously the mount would always try to park as if it was in Kiribati for me in Brisbane and this made it always 4 hr out of sync so pretty frustrating. Wildi's hard work on this driver has given us a very workable solution and we thank him for all the hours he has put in!

BTW I tried the editing of the xml file as suggested above but both cold and warm buttons stopped working so I have stayed with the situation as described above.
Hopefully this makes sense and will get you on the right track.

Mike

Read More...

Michael Hamilton replied to the topic 'ttyusb0' in the forum. 2 weeks ago

Hi,

Your mount will only connect with a baud rate of 115200 (provided you have the version that connects directly with USB) just ensure that this is set in the indi connection GUI rescan and it should pick up the connection and connect. If this still fails remove everything else that is connected and use the camera simulator with your mount in a test profile to ensure nothing confuses the connection and it should see the mount and connect. Then start adding your other gear. Other connection issues can occur if using a non powered USB3 hub. If you are still experiencing problems you will need to post some logs.

Mike

Read More...

So I did this recently after the 20.10 release. It was a bit a a game. I ended up installing all of the dependencies as per the git hub recommendations separately and ended up with about two that would not install so I went looking for the older packages in the ubuntu package directory. The Groovy Gorilla has the libcfitio9 installed but you can get the io8 version from the ubuntu packages repository ( packages.ubuntu.com/focal/libcfitsio8 ) and install it as a deb package. It will solve some of the dependency issues. I still was unable to install indi-full however. However this is not really needed.
I ended up doing sudo apt-get install kstars-bleeding on it's own. Then installing libindi1 as a separate package and indi-bin I think. Then I just chose the individual drivers that I needed for my set up (asi, myfocuserpro2 and eqmod). I had a few crashes with eqmod but then it all settled down and now appears to work. I keep seeing the gsc not found but this could now be part of kstars bleeding but I am just guessing as the KStars ekos/limited indi appears to work ok now.
I did this purely for "fun" there is no way I would trust it this early on. Clear nights are a rarity at the moment.

Cheers,

Mike

Read More...

Hi
Check out this thread that covers two ASI cameras not being recognised. It is likely that your problem is not driver related. I use the same set up and had similar problems. Editing the rules files as per this thread sorted out the problem. indilib.org/forum/stellarmate/7374-no-as...ct-port-mapping.html
I dont think that you need to bother winding back the kernel now so dont follow those instructions at the start of the thread. Look to the end of the thread and change the rules file (just missing some backslashes) then see if you can connect.

Mike

Read More...

My bad,
I thought that I had the latest nightly but that was incorrect. This issue has been fixed in nightly build.
My apologies.

Mike

Read More...

Hi,

I recently did a reworking of my raspberry pi4 using Ubuntu20.04.1 and am using the Kstars 3.5 beta version with latest nightly build. Last night I had some problems with focusing and noticed that focusing in and out were reversed. Using the "enable reverse direction" tab in the indi driver did not have any effect. I checked using the Windows based stand alone focuser application and this worked fine.
I have checked through the forum and cannot find anyone else with this problem. However I did find a reference in github from Rob Brown that this was a problem and there was a commit to change. Can anyone tell me if this fix has made it into nightly build? BTW I have the latest firmware for the myfocuserpro2 loaded.

Cheers

Mike

Read More...

Michael Hamilton replied to the topic 'Wifi Issues' in the forum. 6 months ago

Glad to hear you found a solution!

Mike

Read More...

Michael Hamilton replied to the topic 'Wifi Issues' in the forum. 6 months ago

Hi astrodd,

I have a similar situation. My observing location is right down the bottom of the garden in a fenced off pool area with metal fencing all around. I have a pretty powerful router in the house but have found the best connection has been using a Netgear EXT6200 extender. This is dual band. It has the advantage of being able to be powered by a 12 v dc supply rather than needing a power plug like many extenders on the market.
I connect to the Netgear using the 5GHz band from the Pi (Static IP). Then the Netgear connects to the house network via 2.4GHz. I have used ethernet from the Pi to the Netgear but I have not found this to be better. Less cables the better. I then connect to the Pi headless via Real VNC (I use Astroberry).
I use this extender in the field too (peer to peer) as it gives enough range to image from a club house or car using a laptop if very cold.

Hope this helps.

Mke

Read More...