×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Lakeside Focuser Firmware Version

4 weeks 2 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #44730
Hi,

ive started to to get to grips with KStars and EKOS using stellarmate OS and the only issue im having at present is with my Lakeside Focuser, this is my return to astrophotoraphy after a 7 year break and the lake side is hence about 6 years old. The firmware is version 1.03 and quite dated.

I can connect fine but, any changes to the backlash, or reverse settings give a buffer read error and then usually cause a crash. The focusser will move from within EKOS but any attempt to use presets again causes a crash.

I tried to enable debug but unfortunately this enables then imediately disables, so no joy there. Im assuming that its the firmware that is the issue as the INDI drivers were probbably for later revision, but it could of course be an issue with the controller itself, from other threads im finding that people are using the lakeside with INDI and id like to if anyone had any success with a similar level of firmware ?.

Glen

Please Log in or Create an account to join the conversation.

4 weeks 2 days ago
knro
Administrator
Administrator
Posts: 7355
Karma: 51
Lakeside Focuser Firmware Version #44754
Hello Glen and welcome to INDI Forums!

Check my signature on how to enable logs in Ekos. Is there possibility you can flash a newer firmware to the focuser?

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

4 weeks 2 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #44782
Hi i have attached some logs which capture a variety of error following the below actions:
17.43.37 = within EKOS move to an absolute position
17.45.59 = trying to enable backlash and reverse which rest back to diabled the move to a preset postion of 2000
17.56.36= 100 step moves, mostly succesfull but with some errors.

my applogies if ive posted the logs incorrectly, maybe my bad understanding of the video you reffered me to.

I have had some response regarding getting the firmware flashed to the latest supported version, which i intend to to do. Id say dont your valuable time on this as the firmware update may fix these issues and i will check and update this once i have had that done and re tested it.

thanks

Glen

File Attachment:

File Name: Archive.zip
File Size:21 KB
Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 6 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #44910
HI,

update on focuser, i have now purchased a new controller which is running firmware version 1.30 so up to date as far as i know.

im still having problems, albeit slightly different ones to before, as soon as the foucser connects the error below constantly polls

2019-10-21T14:18:40: [ERROR] DecodeBuffer: Unknown response : (TN/A#)

any value changes on backlash, reverse no longer cause and error or crash wihtin the INDI control panel, which before they were. Pretty much any value can now be changed with no issue. however goto a preset position in INDI or speciyfying an absolute position in EKOS causes a crash.

I have attached log files for both a move from within EKOS and using preset 1 in the INDI control panel.

Thanks Glen

File Attachment:

File Name: Archive201...0-21.zip
File Size:11 KB
Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 6 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #44912
Hi,

Not sure if this is usefull or not but running KStars from OSX i have the same error message, (2019-10-21T14:18:40: [ERROR] DecodeBuffer: Unknown response : (TN/A#)) but goto absolute position, preset in INDI CP or Ekos works and doesnt cause an Error.

Glen

Please Log in or Create an account to join the conversation.

3 weeks 6 days ago
knro
Administrator
Administrator
Posts: 7355
Karma: 51
Lakeside Focuser Firmware Version #44921
So the driver wasn't handling when the temperature is not available. I just updated the code to handle it, please test tomorrow in INDI nightly.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 weeks 5 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #44927
Hi,

I will give it a go in the morning and let you know how I get on.

Thanks again

Glen

Please Log in or Create an account to join the conversation.

3 weeks 4 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #44965
Hi
tried to update this morning atnd it turned into a bit of journey into the unknown for me,

Initially i couldnt run the add repository statement as this gave the message "add-apt-repository command not found", bit of digging and i ran "sudo apt-get install software-properties-common" which seemed to resolve this, maybe the wrong thing but hey.

On running the statement all was good then but it failed on the update due to a missing dependency as below :

stellarmate@stellarmate:~$ sudo apt-add-repository ppa:mutlaqja/indinightly
This PPA is for nightly UNSTABLE Ekos & INDI drivers builds. This is NOT intended for production use, it is only available for testing.
More info: launchpad.net/~mutlaqja/+archive/ubuntu/indinightly
Press [ENTER] to continue or Ctrl-c to cancel adding it.
--shortened
Fetched 137 kB in 4s (31.8 kB/s)
Reading package lists... Done

stellarmate@stellarmate:~$ sudo apt-get update
--shortened
Fetched 137 kB in 4s (31.8 kB/s)
Reading package lists... Done
stellarmate@stellarmate:~$ sudo apt-get install indi-full kstars-bleeding gsc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
indi-full : Depends: indi-aok but it is not installable
E: Unable to correct problems, you have held broken packages.


This is all very new to and ive tried to find some guidance on this hoping to be able to address this myself but having tried to install indi-aok i got the message below:

Package indi-aok is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Any sugestions on where to look for help on this or what i need to do, also after this kstars doesnt seem to be showing in plasma as an application and wont run from terminal, which im presuming is related to this but dont know


Glen

Please Log in or Create an account to join the conversation.

3 weeks 4 days ago
ajt68
Senior Boarder
Senior Boarder
Posts: 71
Karma: 1
More
Lakeside Focuser Firmware Version #44967
I had the same issue at lunch time, and started a new thread about it, no solution yet

indilib.org/forum/astroberry/5899-astrob...-fails-indi-aok.html

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #45001
Hi,

updated kstars and indi from nightly build sucessfully.

so im now running
Build: 2019-10-22T12:10:04Z
KStars version 3.3.7 on Rpi4 4gb using Stellarmate OS v1.4.4

On connectiing to the focuser same issue as previous with temperature NA from the device. from digging around and looking at when i originally purchased the focuser, at that time the steppers didnt alway come with a temperature sensor which im presuming now that it is this that is causing the issue, ive had it apart and sure enough no temp sensor, hence the NA return.

im going to try soldering up a sensor and well see what that does. Blow up probably but i have a spare controller now.
I have attached another log for what its worth but looks very similar to previous

Glen


File Attachment:

File Name: GotoPreset1.zip
File Size:4 KB
Attachments:

Please Log in or Create an account to join the conversation.

1 week 6 days ago
psjshep
Expert Boarder
Expert Boarder
Posts: 92
Karma: 2
More
Lakeside Focuser Firmware Version #45356
Hi Glen,
I originally wrote the Lakeside driver with input from the designer, Peter Chance.

I am not a C programmer per say, but learned enough to get the driver working with my setup which obvisouly included the temperature sensor - later, Peter allowed the code to be submitted to the INDI repository.

I am on holiday at the moment, but can take a look at the code when I get back if you like?

Regards,
Phil

Please Log in or Create an account to join the conversation.

1 week 6 days ago
GN2000
Fresh Boarder
Fresh Boarder
Posts: 12
More
Topic Author
Lakeside Focuser Firmware Version #45359
Hi Phil

Thanks for your kind offer, I’m hoping that the temp sensor and capacitor arrive this week so I was waiting till I get them installed to see how it responds, before I raised any more questions. Let me get that sorted first, so you don’t waste any time over something that may get cured by updating the hardware.

Glen

Please Log in or Create an account to join the conversation.

Time to create page: 1.156 seconds