×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Getting a time mismatch when using travel router

  • Posts: 92
  • Thank you received: 1
I have a need for a remote connection so I have tried out a travel router. I am connected to it's network with my MacBook Pro.

Every time I connect to Ekos the time is off. I can readjust the time in KStars but it apparently also is creating chaos with my mount. At least one evening the mount did not park at it's allotted time and the mount hit my tripod. Now when I attempt a GoTo move the mount thinks that it needs to do a Meridian flip. The last time imaging I had to disable the Meridian Flip as GoTo was hung up with the Meridian Flip confusion.

Is there a good way of making the Raspberry Pi understand what the time actually is?

I read somewhere where Jasem suggested that the Stellarmate Controller included RTC. What is the Stellarmate Controller? How would this be enabled?

Would this problem be alleviated by using the Stellarmate App?

Would it work (still using the travel router) to have the software driven on my MacBook instead of being driven by the Pi unit?

Any other ideas?
2 months 2 days ago #83546

Please Log in or Create an account to join the conversation.

  • Posts: 69
  • Thank you received: 10
Paul,

I use these docs.macetech.com/doku.php/chronopi Keeps time even when there's no power to the Pi, easy to fit and very accurate time keeping. There are other types but I'm sure they'll work just as well.

Regards

Alan
Raspberry Pi4B,ASI120MM -S Usb3, ASI385MC, Atik 428CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod, Equinox ED80, ASI533MC, RedCat 51 ASI 120MM Mini.
The following user(s) said Thank You: Paul Imm
2 months 2 days ago #83547

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 1
Alan, per your suggestion I have placed an order for this RTC chip.

I do get a little lost with linux but will give the script on the linked website a try. I am thinking that I could install this using the Pi device plugged into a monitor using keyboard and mouse.

If I get stuck I may have a question or two, but knock on wood this will help me past the issues I've been having.

Thank you,

Paul
2 months 2 days ago #83550

Please Log in or Create an account to join the conversation.

If you use SM App, it would try to sync GPS time and location every time you connect to the unit. RTC would help you by saving the time when unit is powered off. At any rate, the App should ensure both time and location are always correct. You don't need to use the App for everything, just connect to the unit to sync GPS.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Paul Imm
2 months 2 days ago #83557

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 1
I have a power outage so it is an excellent time to try things out.

I still don’t have the RTC from on order.

I did however try connecting to the StellarMate app this evening. The good thing was that I think it synced up the time. The bad thing is that every few seconds it drops the connection and says that it has a sync error.

The IP that I am connected to on the StellarMate app matches the travel router.

I believe that the travel router is set up on station mode. I have a small Ethernet cable going from the Pi unit and the travel router.

What should the network settings read on the StellarMate app?

Presently I am connected to my MacBook with no issues that I see other than the fact that my battery will run out sometime tonight.

I would like to get the StellarMate App going for times that I will be imaging remotely.
1 month 4 weeks ago #83626

Please Log in or Create an account to join the conversation.

Can you remove StellarMate on setup tab and rescan? is it detected again and is the connection stable or the same?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 month 4 weeks ago #83628

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 1
Jasem, I just tried putting the profile I had into the trash can. I am getting the same behavior as before. The connection to Ekos intermittantly flashes on and off. When I am in Ekos there is an intermittant Syncing message about every other second.

This same network over the travel router did give me an entire night of imaging over my MacBook Pro using Real VNC.

Is there an area online that I could go to that shows suggested settings for using a travel router with the Stellarmate App?

I do believe that I am at least in a state where using the iPad to connect to the Pi with Ekos gives me a good time sync with Ekos and travel router over Real VNC. That however is a lengthy process to do this every night that I am imaging.

It might be advantageous if I start another thread more specific to the Stellarmate App if there isn't a simple solution to the bad connection issue.
1 month 4 weeks ago #83639

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 1
Alan: How do you enable the mace tech real time clock?

I powered up the Pi unit and have keyboard and mouse control over a monitor.

Your link follows through the entire installation of the rtc chip.

I followed the hardware installation instructions.

I made it through the initial instructions as the Raspberry Pi OS was already installed with Stellarmate.

Steps 3 to 5 were easy as the rtc script already was installed in the boot folder. I skipped down to step 7.

7. (If using monitor, keyboard, and mouse to configure the Pi)
Eject micro-SD card from your computer and insert into Raspberry Pi
Attach Pi to monitor, keyboard, mouse, and Ethernet cable
Attach Pi to a USB power source
Wait for the Raspberry Pi to boot up
Open a command line terminal

Here is where I am stuck.

8. Enter sudo hwclock -r which should display the date and time (example below):
Fri 12 May 2017 20:28:09 UTC -0.737856 seconds

After the above entry I get the following error message:
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the —verbose option to see the details of our search for an access method.

My guess is that the Raspberry Pi OS is somewhat modified with the Stellarmate install. It is evident that there is a provision for the rtc chip because the needed script (step 4) was already in place.

Assuming that you also use the Stellarmate OS, what do you do to get the RTC chip to work properly?
1 month 2 weeks ago #83817

Please Log in or Create an account to join the conversation.

  • Posts: 69
  • Thank you received: 10
Paul,
Carefully check the line in the config.txt file "dtoverlay=i2c-rtc,ds3231" because I've had the same error message in the past when I'd made a mistake typing in that line. Copy and paste it off the website onto a new line and comment out the original line with a # and try that.

I've used the Macetech Chronopi on RasperryPi OS and Ubuntu systems for a few years now I've just tried out the new Ubuntu 64 bit system and it also works fine on that.

Alan
Raspberry Pi4B,ASI120MM -S Usb3, ASI385MC, Atik 428CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod, Equinox ED80, ASI533MC, RedCat 51 ASI 120MM Mini.
The following user(s) said Thank You: Paul Imm
1 month 2 weeks ago #83843

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 1
Alan, I went through the verification of the script in the setup directory and it once again looked good.

I went to the command prompt and entered the sudo hwclock -r verification. Once again it errored out.

With no other ideas I went to the Stellarmate update screen (which I also did prior to the last time I tried the hwclock install) and it found an update that I let run and reboot. When it came back I was surprised to see that the version and package number were exactly the same.

I went back into the command prompt and entered sudo hwclock -r once again. For whatever reason this time it displayed the time. I followed the ChronoPi install scripts and even though there were several errors it in the end apparently installed the real time clock.

I will be trying this out and see if I now have a true time lock.

To be honest I was thinking that the battery must have been dead. I was ready to go out and buy a new one.

If this works I will want to buy another RTC chip.

Thank you for directing me towards what I was looking for.

UPDATE:
Alan and Jasem: I plugged in my travel router with the updated RTC install. There was no conflict with time when I changed my network to the travel router's IP and did Real VNC.

Just wondering whether something might come up differently when using the Stellarmate app I entered this application on my iPad. As soon as I clicked refresh everything came up properly with Ekos! Perhaps the chip install helped both in telling proper time as well as communicating properly with the Stellarmate app. The only other thing that I did was update the Stellarmate OS while hooked up to monitor from 1.70 to 1.71.
Last edit: 1 month 2 weeks ago by Paul Imm. Reason: Update
1 month 2 weeks ago #83849

Please Log in or Create an account to join the conversation.

  • Posts: 69
  • Thank you received: 10
Paul,
Glad you got it working.

One tip is to hook up the Raspberry Pi to the internet regularly, just to keep the RTC time up to date, so there are no time conflicts with the other devices you are using.

Good luck with it

Alan
Raspberry Pi4B,ASI120MM -S Usb3, ASI385MC, Atik 428CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod, Equinox ED80, ASI533MC, RedCat 51 ASI 120MM Mini.
1 month 2 weeks ago #83856

Please Log in or Create an account to join the conversation.

Time to create page: 0.723 seconds