×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

After update to 3.6.0: QHY driver crash!

  • Posts: 116
  • Thank you received: 10
Hi,
after update to 3.6.0 (from SM 1.7.1) it is NOT possible to get QHY camera (in my case QHY268C) working. Always warning "QHY driver crash".

Hope this can be fixed soon. I had all updates until now.

edit: Log file attached.

File Attachment:

File Name: log_13-18-17.txt
File Size:44 KB
Last edit: 2 months 3 days ago by Juergen.
2 months 3 days ago #84829
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 3
2 months 3 days ago #84831

Please Log in or Create an account to join the conversation.

  • Posts: 116
  • Thank you received: 10
Just a short update: I tried with my 3.5.9 astroberry image: QHY camera works great. lsusb output is the same. After switching the SSD to Stellarmate 1.7.2 without disconnecting the camera: again QHY driver crash!

So there is something wrong with the new version either kstars or libindi
2 months 3 days ago #84835

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 3
Yes I back to 3.5.8 work fine and also nikon camera crash too..
2 months 3 days ago #84837

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 6
Yes, My 462 won't even appear to the list. Seems QHY drivers are left out for 3.6.0 for some reason.
2 months 3 days ago #84843

Please Log in or Create an account to join the conversation.

  • Posts: 35
  • Thank you received: 28
Hi

This part of your log file indicates you need to recompile your driver against the latest indi lib:


indi_qhy_ccd: undefined symbol: _ZN4INDI3CCD15addFITSKeywordsEP8fitsfilePNS_7CCDChipE"
2 months 3 days ago #84844

Please Log in or Create an account to join the conversation.

  • Posts: 267
  • Thank you received: 15
I confirm the crash also with the qhy183m. i would be curious to know how update are released and marked as stable. this is not the first time that occurs these kind of problem with updates
2 months 3 days ago #84847

Please Log in or Create an account to join the conversation.

  • Posts: 116
  • Thank you received: 10
I just downloaded the complete SM 1.7.2 but the 64bit version, since I wanted to change anyway and was curious if my camera works in 64bit. My former installation was 32bit. I installed it from scratch and it works. So maybe the compilation of the QHY driver for the 32bit version has been forgotten.

I think Jasem will do this soon ;-)
2 months 3 days ago #84849

Please Log in or Create an account to join the conversation.

  • Posts: 116
  • Thank you received: 10
Another point: the file system of the 64bit Image doesnt inflate after the first/second reboot. It still was on 7.9G. I had to do it via raspi-config. Just for information...
2 months 3 days ago #84850

Please Log in or Create an account to join the conversation.

  • Posts: 116
  • Thank you received: 10
Hi all,
Jasem pushed an update some minutes ago. Now it works!

Thank you for the quick fix, Jasem!

Best regards

Jürgen
2 months 3 days ago #84852

Please Log in or Create an account to join the conversation.

  • Posts: 40
  • Thank you received: 4
Would be fantastic if it could be the same for the canon driver, same error, same solution I guess.

Sky is so clear now... :-(
Mount: AZ-EQ6 GT
Scope: Skywatcher Esprit 100 super APO triplet
Guide: Tecnosky 60
Camera: Canon Ra
Camera guide: Zwo ASI 224MC
Stellarmate on RPI 4 8Gb
2 months 3 days ago #84859

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 3
after update qhy working fine but nikon still crash.
2 months 4 days ago #84874

Please Log in or Create an account to join the conversation.

Time to create page: 1.052 seconds