×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

INDI Driver for SVBONY cameras

  • Posts: 149
  • Thank you received: 31
Hi Nigel,

Your images look a bit out of focus.

When guiding with a color camera, I usually use bin 2x2, to avoid debayer artifacts.
The SV305 sensor (imx290) has a pretty small pitch (2.9um). Unless you image at very long focal length, I think you will get better results, with better SNR.

Best regards,

Thx8411
5 months 1 week ago #82365

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 5
Hi Collin

yes the camera was probably a bit out of focus as it was at a setting for a couple of weeks ago. It could also have been down to the misty clouds or the moon as usually the snr is in the hundreds.

The sv106 with its helical focuser seems rather difficult to focus. I’ve tried using astrodmx as it gives quite rapid feedback. Do you have any suggestions about what could help?

Regards

Nigel
5 months 1 week ago #82366

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 5
ok can ignore my question about the disappearing stars. Basically it appears that the sky was so bright that after 40 seconds the image was becoming over-exposed. At least that seems to be what I’m seeing in fits liberator. Next time I will check the histogram as I could see things move to the right as the exposure time increased until things basically dropped off the end.
Rookie mistake :)
The following user(s) said Thank You: R Dan Nafe
5 months 1 week ago #82405

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 5
Hi

I’ve been having problems recently with the images download by ekos from my sv305. The files appear and logging doesn’t appear to indicate any problems however while the files are the right size they seem to have null (I’m sort of assuming this as the statistics say min/max as being 0) data image.

I’ve tried shutdown/power down/boot and altering the indi driver settings but with no luck. I’ve swapped the usb connections around (all but a usb memory stick was off a powered usb hub now that is as well)

Now AstroDMx seems to be able to use the camera (yes I’ve done a shutdown etc between just in case).

Finally at my wits end late last night I was trying AstroDMx and tried auto gain rather than auto exposure (which was very noisy) and everything became clear with the stars showing nicely. Switched over to ekos and suddenly that was working fine. Even after yet another power cycle.


Anyone hit something similar?

Is Astrodmx somehow changing some state in the sv305 which survives power cycles? Or has some problem been introduced in the last few days as things were working fine previously?

Regards

Nigel
5 months 2 days ago #82574

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hello Nigel,

SVBony introduced the ability to store the settings in a recent SDK :

<< SVBCAMERA_API SVB_ERROR_CODE SVBSetAutoSaveParam(int iCameraID, SVB_BOOL enable); >>

I don't use this feature. In my mind, it's the wrong way to go. The settings should be stored in the client software, not at low level, or you may experience
the issue you just discovered.

Sadly, AstroDMX seems to use it.

Thanks for sharing your experience.

Best regards,

Thx8411
5 months 9 hours ago #82624

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hi folks,

I'm working on the temperature control on the SV405CC, and I have a question.

The SVBony SDK controls for camera cooling are somewhat different from the INDI default controls.

SVBony provides :

- Powering the cooler ON/OFF
- Setting the cooler power (0 - 100%)
- Reading the current temperature
- Setting the target temperature

INDI provides :

- Setting the target temperature
- Setting the cooling/warming ramp
- Setting the temperature hysteresis

What should I do ?

- Try to wrap all the SVBony controls onto the INDI controls, and only them ?
- Try to mix the INDI Controls and the SVBony SDK, with extra controls ?
- Provide only the SVBony controls, as a proprietary panel, without the INDI default controls ?

Please notice that I don't have the camera yet (waiting for delivery), so, I'm note able to see how the SDK controls really act.

Best regards !

Thx9411
5 months 7 hours ago #82625

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 6
First implement and release the INDI control, then implement the SVBONY control. Or vice versa. Why not implement it in whichever way can be released sooner?

I too am waiting for SV405CC to ship, and SVBONY tells me it will ship at the end of this month.
Hopefully the SV405CC will arrive in your hands soon.
5 months 7 hours ago #82626

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 5
Hi Collin

are you saying the settings are stored in the camera and retained through power cycles?

That sounds a rather pointless and error prone thing for them to decide to do. Would have thought it would be cheaper/easier and thus more profitable to leave it to a client to set.

Is there some form of reset to defaults call that could be made when the indi driver is initialised otherwise people are just going to keep hitting what seems like random errors?


Regards

Nigel
5 months 6 hours ago #82627

Please Log in or Create an account to join the conversation.

INDI has CoolerSP (Cooler ON / OFF) control. You can also add your own property for setting the cooler power. I presume there is "automatic" mode when the power is set automatically, and another where it is manual. You can also add another switch for that.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Collin
5 months 5 hours ago #82630

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hi Nigel,

I agree with you, pointless and sensitive.

<< Is there some form of reset to defaults call that could be made when the indi driver is initialised otherwise people are just going to keep hitting what seems like random errors? >>

I don't know yet. I have to explore the APIs deeper.

Best regards,

Thx8411
4 months 3 weeks ago #82735

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 31
Hi Jasem,

Thanks for your answer.

I think I will choose this option :

<< - Try to mix the INDI Controls and the SVBony SDK, with extra controls ? >>

Best regards !

Thx8411
The following user(s) said Thank You: R Dan Nafe
4 months 3 weeks ago #82736

Please Log in or Create an account to join the conversation.

  • Posts: 6
  • Thank you received: 6
Hi Collin

Did you receive your SV405CC?
I received mine last week.
I am testing it with SharpCap but have not done astrophotography yet.

If you don't mind, can you tell me when the SV405CC INDI driver will be released?
3 months 3 weeks ago #83350

Please Log in or Create an account to join the conversation.

Time to create page: 0.947 seconds