×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Alt-Az mode for EQmod

1 month 2 weeks ago
Dirk Tetzlaff
Senior Boarder
Senior Boarder
Posts: 50
More
Topic Author
Alt-Az mode for EQmod #59733
did another run now with the geehalel indi branch:
prior to the compilation I could connect to my mount via direct USB @115k. After the compilation I could not connect with either skywatcher_altaz, Altaz_simple or EQmod.
For the EQmod I received the following log message:
[2020-09-11T13:45:25.870 CEST INFO ][ org.kde.kstars.indi] - EQMod Mount : "[ERROR] Error: Communication failed -> tty write failed, check connection: Write Error: Bad file descriptor "
[2020-09-11T13:45:25.872 CEST DEBG ][ org.kde.kstars.ekos] - "EQMod Mount" is disconnected.
[2020-09-11T13:45:25.873 CEST INFO ][ org.kde.kstars.ekos] - "EQMod Mount is disconnected."

For the other two, I attach the log file. It occurs to me, that for the skywatcher_altaz the config.xml in the .indi directory is missing. I could set the connection parameters in the indi control panel, but I am unsure whether they have any effect:
Attachments:

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago 1 month 2 weeks ago by geehalel.
geehalel
Gold Boarder
Gold Boarder
Posts: 211
Karma: 16
More
Alt-Az mode for EQmod #59735
At least one of the driver has succeded in opening and writing to the mount:
<code>
[2020-09-11T13:18:05.060 CEST DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az Wedge : "[DEBUG] Connecting to /dev/ttyUSB0 @ 115200 "
[2020-09-11T13:18:05.061 CEST DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az Wedge : "[DEBUG] Port FD 3 "
[2020-09-11T13:18:05.061 CEST DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az Wedge : "[DEBUG] Connection successful, attempting handshake... "
[2020-09-11T13:18:05.061 CEST DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az Wedge : "[SCOPE] SkywatcherAltAzSimple::Handshake "
[2020-09-11T13:18:05.061 CEST DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az Wedge : "[SCOPE] InitMount "
[2020-09-11T13:18:05.062 CEST DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az Wedge : "[SCOPE] CheckIfDCMotor "
...
[2020-09-11T13:18:06.415 CEST DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az Wedge : "[DEBUG] Handshake failed. "
[2020-09-11T13:18:06.532 CEST DEBG ][ org.kde.kstars.indi] - INDI Server: "2020-09-11T11:18:06: Driver indi_skywatcherAltAzSimple: SkywatcherAltAzSimple::ISGetProperties"
</code>
`CheckifDCMotor` sends a ':' which is not a valid command for AZEQ5/6 mounts, and they return '!1'. This is what I test, exactly '!1' as this is what my AZEQ5 replies. Maybe the AZEQ6 returns another error code and the function returns false. You may test that using picocom if you have it installed: `picocom -b 115200 /dev/ttyUSB0`, hit ':' followed with ctrl-M (there is no echo), and look at the reply. You may close picocom with ctrl-A then ctrl-X. Don't send other commands if you are not sure of what you do (<strong>never</strong> send ':Q'....).
Concerning EQMod, as we change the indi core library without recompiling it, it may explain the connection issue. But usually this implies a crash when the API has changed and the dynamic loader fails and aborts. Otherwise EQMod should be able to work as usual. I wonder if you actually run the hand compiled binaries. May you try to check if they have been installed in `/usr`:
<code>
ls -l `which indiserver indi_eqmod_telescope indi_skywatcherAltAzMount`
</code>
If their date are correct, you may try to launch them by hand and connect kstars directly to that indiserver (on localhost port 7624):
<code>
indiserver indi_skywatcherAltAzMount
</code>
Actually I don't exactly know your setup.

Edit: the EQMod error (bad file descriptor) suggests as disconnection/reconnection of the USB serial dongle, changing its device file (USB1 for instance).

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
Dirk Tetzlaff
Senior Boarder
Senior Boarder
Posts: 50
More
Topic Author
Alt-Az mode for EQmod #59736
Installed picocom and sent ": +CTRL-M"

My mount returns "!0" ; so different response from your AZEQ5...

For the setup: I have astroberry installed on a pi4. Pls. let me know what other info you need.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
Dirk Tetzlaff
Senior Boarder
Senior Boarder
Posts: 50
More
Topic Author
Alt-Az mode for EQmod #59738
checked the date of the indi drivers in /usr:
indiserver and skywatcherAltAzMount are with date of today. indi_eqmod_telescope is Apr 13.
Tried to "handconnect", also. No success.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
geehalel
Gold Boarder
Gold Boarder
Posts: 211
Karma: 16
More
Alt-Az mode for EQmod #59741
I updated the driver, you can refresh your clone:
cd ~/Projects/indi
git pull
and rebuild/reinstall. And retry. Beware of USB extension cable, I also had connection issues while testing, just reconnect them and that was ok.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
Dirk Tetzlaff
Senior Boarder
Senior Boarder
Posts: 50
More
Topic Author
Alt-Az mode for EQmod #59745
did the update. AltAzSimple still handshake failing; skywatcherAltAz does not connect due to other reasons. Log attached. First attempt is with AltAzSimple (because there the connection at least was initiated), second with skywatcher_AltAZ
Attachments:

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
federicoparrasilva
Fresh Boarder
Fresh Boarder
Posts: 9
More
Alt-Az mode for EQmod #59844
Dear Jasem, sorry to be communicating about the same subject on many fronts (Stellarmate support ticket HAYB-000932, Github enhancement demand github.com/indilib/indi/issues/1232 , and now here).
As I mentioned in both other places, the version of the indi_skywatcherAltAzMount driver you are using with the alias AZ-GTI AltAz is the one that still contains the bug that doesn't allow UDP connection with Az-GTI, as explained -and then solved- in this GitHub bug github.com/indilib/indi/issues/1158 ).
So that's the first problem. The second problem for is that when using AZ-GTI in AltAz with indi_skywatcherAltAzMount driver (not your version), it does not track. The driver connects through WiFi (UDP), and then it is parked. If I unpark, it goes somewhere, but when it gets there it doesn't track. I can slew somewhere else (sometimes, sometimes it stops) but again when it gets to destination it does not track.
As the original post demanded, I also think the best would be to have an AltAz "translation layer" between Ekos and AZ-GTI eqmod-based driver, translating from AltAz to EQ and back in every interaction with said driver, would that be possible? Since that driver works seamlessly with AZ-GTI whereas the indi_skywatcherAltAzMount driver does not.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
knro
Administrator
Administrator
Posts: 8460
Karma: 51
Alt-Az mode for EQmod #59855
It's alright! Ok, let's move all the discussions here :D

I am using this driver with my AZ-GTi Alt-Az driver over UDP.



I just tested this and issued GOTO to Phecda. It slewed there and it was tracking. RA/DE are constant while AZ/AL change to keep the object centered.



I'm not sure I follow the last point though.. you want to help explicit Az/Alt input in the driver? This can be added, but it's not strictly necessary. If this is required for a very good reason, then I'll add it. Otherwise usually clients simply send the RA/DE and the driver internally converts that to Al/Az and command the mount.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Attachments:

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
federicoparrasilva
Fresh Boarder
Fresh Boarder
Posts: 9
More
Alt-Az mode for EQmod #59871
Ok, I see that you are making it work.
In my case, after switching to the beta channel, only one driver works (AZ-GTI AltAz), all other drivers (including Nikon, etc) give me the "driver xxxx was not found on the system" error (and then Kstars closes). So that's bad, I think I'll have to download the image and start all over again. It's frustrating because I had downloaded the 4+ gb plate solving data files and my connection is slow.

In any case, the AZ-GTI AltAz driver (which does work) does not connect via UDP. I don't know why. The indi-SkyWatcher-AltAzMount driver did connect fine via UDP, but did not track correctly.

My last point was about what I mentioned in github.com/indilib/indi/issues/1232 enhancement: the point is that AZ-GTI driver is a superior driver compared to indi_Skywatcher_AltAzMount in many ways, it has more features and is more stable I think. If I am correct, then my point is that it would be better to make an AltAz version of that driver, an altAz version of the Eqmod driver beneath it. I know that sounds difficult, but that way altaz users would inherit all the advantages of the AZ-GTI driver and you would have a unified driver for altaz/EQ use, I think.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
knro
Administrator
Administrator
Posts: 8460
Karma: 51
Alt-Az mode for EQmod #59877
No need to reflash again. Make sure to update_indi_core and update_indi_drivers then remove the Ekos profile and recreate it again. Hopefully that should help you run all the devices. If not, we can try Teamviewer method again.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
federicoparrasilva
Fresh Boarder
Fresh Boarder
Posts: 9
More
Alt-Az mode for EQmod #59909
Dear Jasem, yesterday night I switched back to the Stable Stellarmate channel and after the switch all works, including UDP with AZ-GTI AltAz driver you made.
Unfortunately, as I mentioned, the driver it is based on (indi_skywatcher_altazmount) has bugs.
The first one is that, when tracking, in the Mount section the tracking button is not set to ON (both ON and OFF are greyed out).
The second, more important problem is that when tracking an object, Jupiter for instance, the mount will, every few seconds, slew on its own randomly, for example slew up a little bit, or slew left a little bit, then begin tracking again, then slew again...
When using the Alignment module, plate solving will be interrupted very often with the message "slewing detected aborting solving".
I tried by disabling the SoftPEC option, but crazy slewing continued.
I'm sure this can be solved. I'm also still inclined to think having two different AZ-GTI drivers, one based on indi_skywatcher_altazmount and the other on eqmod might not be the best road, and that it might be better to modify the eqmod based driver to work with altaz instead.
"
The following user(s) said Thank You knro

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
knro
Administrator
Administrator
Posts: 8460
Karma: 51
Alt-Az mode for EQmod #59923
I hope Jean-Luc's driver would work with AZ-GTi so it's a win-win on all fronts. I just attempted to use an existing driver that was tailored to Alt-Az mounts but it wasn't tested good enough I suppose. Let's wait to see when EQMod Alt/Az modifications take place.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

Time to create page: 1.073 seconds