Guillem replied to the topic 'Kstars crashes' in the forum. 6 months ago

Hi everybody,

I had problems with RAM and FITSviewer... So I did:
a) install Zram
b) disable Fitsviewer from options ( you may disable after check the first captured image )
c) disable some programmes like TEAMVIEWER ( is running by default in Stellarmate), to achieve more free memory...

In this case, everything runs in raspberry pi 3 ( only some randomly crash) from my laptop only use VNC viewer to supervise and control all stuff...

Another option is to use kstars on my laptop ( ubuntu 18.04), so with 8 G RAM fitsviewer never crashes. But I prefer that all runs in the raspberry to prevent some communications interrupts...

good luck with this fantastic environment... (only needs some debug and improvement )

Guillem

Read More...

Guillem replied to the topic 'Is a Pi with indi/kstars good for my setup?' in the forum. 7 months ago

Hi,

After some configuration problems, now I am using the rasp pi3 with kstars/ekos standalone (ubuntu mate 16.04 for arm processors)... doing all the big job. Stellarmate is a good option if you don't want to learn linux...

As Jasem wrote, it works great as a server, with a laptop processing big work, but if you have some connectivity problems ( wifi, gigabit, PLC) be careful...

Other people are using the raspberry pi 3 as as sever+Phd2, saving pictures local and remote (good option in case of connection failure), if kstars hangs, start it again and the mount will be where you left... guiding a star...

good luck for this new challenge

Guillem

Read More...

Guillem created a new topic ' problem Re-using created sequence queue ( plans )' in the forum. 7 months ago

Hi,
when I tried re-using an old creating plan ( sequence queue ) , *.esq ( xml file),
I open it and trying to modify number of pictures, exposure, filters, etc. , after that I click as new name and save it !! so when I start the sequence, and EKOS starts with old values !! :( :( :(
The only way to re-use the old sequence is modifying the .esq file (xml) with an editor,
or directly create a new plan ( sequence).

Am I doing something wrong?

thanks

Guillem

Read More...

Guillem replied to the topic 'Kstars crashes' in the forum. 7 months ago

So, you may have some options:

1- send system logs to the MAC OS people... who knows if they can help...
2- Use you mac only for remote desktop, raspberry will do all the job ( I know it can ;-) )
3- Do more tests, and share information is this forum...
4- Once, I send some logs to KDE developpers ...
5- try to update Kstars to 3.1

good luck
Clear Skies

Guillem

Read More...

Guillem replied to the topic 'Kstars crashes' in the forum. 7 months ago

Hi,

I had similar problems ... follow this link

Tips: disable FITS viewer , and zram ..., I also update to Kstars 3.1 ... ( sudo apt-get update , sudo apt-get upgrade ...)

All the problems were on the raspberry ( doing all the hard work ). On my laptop with ubuntu 18.04 Kstars, never crashed...

This QT messages in the logs, may get confussion.

good luck and clear skies

Guillem

Read More...

Hi Everybody,

Finally, everything Kstars-Ekos is perfectly working
Thanks to Jasem for his support !!

Clear skies !!

Guillem

Read More...

Hi,

I'll do it this evening !!
There is als an upgrade to do for Kstars Ekos --> version 3.1

thanks

Guillem

Read More...

Hi,

Fortunately, with zram kstars - ekos didn't crashed...

but you can see on the video ( turn down the sound !!! ) how Ekos eats a lot of RAM while ZOOM IN on the captures...

clear skies !!

Guillem

https://indilib.org/media/kunena/attachments/5068/ekosmemoryeatswhilezoomingcaptures.mp4


Read More...

Hi Jasem,

I was taking some pictures ( Everthing was PERFECT) , but I realised that memory RAM increased up more than 800 MB, while I was doing ZOOM IN in fits viewer (main window, see attached file). I could see monitoring it with htop ...

I have FITS VIEWER disabled, but I only was observing the 'round' stars...
There is atached logs.

Now , I installed ZRAM from : github.com/novaspirit/rpi_zram

I will see whats happening...

thanks for your help,

Guillem

Read More...

Guillem is friends with Albert Codina

Hi Jasem,

I made more tests during night to real objects, and memory usage is about 80-90%.
Look the PDF with screenshots...

May I kill some services? this 'phonon' message at the end of the logs is getting me MAD...

thanks

Guillem

Read More...

Hi Jasem,
Now, I am running this test : ( During this night I can do more tests ( any more suggestions?? ))
I including this brief PDF.

thanks

Guillem

Read More...

Hi Jasem,

Yesterday memory usage was 60%-70% (RAM) and CPU 50%. I saw some SWAP usage, I don't know why... I will check it this night with the default monitor (ubuntu Mate).

With FITS Viewer disable, I only make some Zoom in and out to recent images in main Ekos tab...

I read this: www.indilib.org/forum/search.html?query=...ations&childforums=1 --> I may uninstall it !!!

Two days ago, I installed the missing packages of this 'annoying Phonon' message.
In Ubuntu Mate (not KDE) I did'nt found where to disable notifications sounds...

thanks for your help

Guillem

Read More...

Kstars/ekos was working about 3 h with no errors, but finally crashed...

the end of the logs say that: QImage: out of memory, returning null image !!!
and the FITS VIEWER was disable...

any ideas??

thanks

Guillem


p.s. logs
[2019-01-07T01:43:38.226 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:38.237 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:38.531 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:38: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:38.531 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:38: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:38.532 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:38.714 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:38: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:38.715 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:39.886 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:39: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:39.886 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:39.984 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:39: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:39.984 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:39.986 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:40.001 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:40.192 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:40: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:40.192 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:40: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:40.192 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:40.305 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:40: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:40.306 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:41.595 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.595 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:41.693 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.694 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:41.696 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:41.703 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:41.880 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.880 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:41: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:41.881 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:42.054 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:42: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:42.055 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:43.296 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:43.296 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:43.394 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:43.395 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:43.399 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:43.412 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:44.218 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:44.221 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:44.224 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:43: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:44.226 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.033 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.033 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.142 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:45.142 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:45.143 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.143 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.400 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.400 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxClearPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.401 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:45.432 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:45: Driver indi_sx_ccd: sxSetSTAR2000: libusb_control_transfer -> OK"
[2019-01-07T01:43:45.433 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:47.316 CET DEBG ][ org.kde.kstars.ekos.capture] - All capture jobs complete.
[2019-01-07T01:43:47.376 CET DEBG ][ default] - WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
[2019-01-07T01:43:47.386 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Uploading file. Ext: fits, Size: 221760, sendImage? Yes, saveImage? No "
[2019-01-07T01:43:47.387 CET DEBG ][ org.kde.kstars.indi] - SX CCD LodeStar : "[DEBUG] Upload complete "
[2019-01-07T01:43:47.411 CET DEBG ][ default] - WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
[2019-01-07T01:43:47.588 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:46: Driver indi_sx_ccd: sxLatchPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:47.589 CET DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-01-07T00:43:46: Driver indi_sx_ccd: sxReadPixels: libusb_control_transfer -> OK"
[2019-01-07T01:43:47.589 CET DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-01-07T01:43:47.605 CET DEBG ][ default] - WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
[2019-01-07T01:43:48.270 CET DEBG ][ org.kde.kstars.fits] - Started WCS Data Processing...
[2019-01-07T01:43:48.275 CET WARN ][ default] - QImage: out of memory, returning null image

Read More...