Hi everyone.
Currently I am using a raspberry pi3b as indi server(no astroberry image)
My main camera is a Nikon DSLR D3200. When I save the images to either the raspbery pi or the machine where I connect remotely to the indi server the fits images generated have a fits header with info about the target and the camera's details.

It is a bit slow doing this way and I thought I would rather save only to the SD card in the camera.
I have done the changes required in the Image settings area of the GPhotoCCD tab to only save to the camera's SD card and do not download them.
However after inspecting the images generated in Kstar's fits viewer I noticed that it does not have any data in the fits header.
Is it something expected?

It might be due the image not saving as *.fits. I have also noticed that no formatting happens at all on the filename of the images saved on the camera's SD card.
I get files names like DSC_0011.NEF instead of the nicer format I get when saving to the raspberry pi polaris_Light_1_secs_2022-07-02T13-24-11_000.fits

Is there a way to force saving images to the camera's sd card as fits instead of nef?
In my GPhotoCCD settings I have got the format=NEF(raw) and encode=FITS.

Thanks for the help.