×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

indi_asi_ccd crash on connect.

  • Posts: 10
  • Thank you received: 1
Hi all 

I just upgraded form a DSLR to a ASI camera guide scope and filter wheel.

I am on 64 bit Kubuntu  20.04

I was on a slightly older version of indi and plugged everything in and the camera and guider connect but not the filter wheel. 

I then upgraded inid ekos /kstars to the latest, sudo apt-get install indi-full kstars-bleeding

Now the filter wheel is fine but the camera driver crashes as soon as I connect.  I have tried just the camera , alone  with no guide camera and visa versa noting it just consistently crashes now. 

 

lsusb below :
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 03c3:260e ZWO ASI2600MM Pro
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 007: ID 04f2:b45d Chicony Electronics Co., Ltd Integrated Camera
Bus 002 Device 006: ID 8087:0a2a Intel Corp. 
Bus 002 Device 005: ID 138a:0017 Validity Sensors, Inc. VFS 5011 fingerprint sensor
Bus 002 Device 004: ID 04f3:012d Elan Microelectronics Corp. Touchscreen
Bus 002 Device 003: ID 03c3:1f01 ZW0 ZWO EFW
Bus 002 Device 010: ID 03c3:120c  
Bus 002 Device 009: ID 04b4:6572 Cypress Semiconductor Corp. Unprogrammed CY7C65642 hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Any help would be greatly appreciated 

Regards
Cliff
4 months 3 weeks ago #73459
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1
I just looked in the kstars log and found a potential issue,looks like the drive ris looking for a symbol that does not exist "undefined symbol: _ZN4INDI3CCD22checkTemperatureTargetEv"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: start indi_asi_ccd"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: Starting driver indi_asi_ccd"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_asi_ccd: pid=3110 rfd=5 wfd=10 efd=11"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: start indi_simulator_guide"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: Starting driver indi_simulator_guide"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_simulator_guide: pid=3111 rfd=6 wfd=13 efd=14"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: start indi_asi_wheel"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: Starting driver indi_asi_wheel"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_asi_wheel: pid=3112 rfd=9 wfd=16 efd=18"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: start indi_simulator_focus -n \"Focuser Simulator\""
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "With name: Focuser Simulator"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "FIFO: Starting driver indi_simulator_focus"
[2021-07-13T17:16:34.227 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_simulator_focus: pid=3114 rfd=12 wfd=20 efd=21"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Client 15: new arrival from 127.0.0.1:47244 - welcome!"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_asi_ccd: indi_asi_ccd: symbol lookup error: indi_asi_ccd: undefined symbol: _ZN4INDI3CCD22checkTemperatureTargetEv"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_asi_ccd: stderr EOF"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_asi_ccd: Terminated after #0 restarts."
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "Child process 3110 died"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_asi_wheel: Searching for HID Device VID: 0x3c3 PID: 0x1f01"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_simulator_telescope: HaAxis: TrackRate 1, trackingRateDegSec 15.041067 arcsec"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_simulator_telescope: snooping on GPS Simulator.GEOGRAPHIC_COORD"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_simulator_telescope: snooping on GPS Simulator.TIME_UTC"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_simulator_telescope: snooping on Dome Simulator.DOME_PARK"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_simulator_telescope: snooping on Dome Simulator.DOME_SHUTTER"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2021-07-13T15:16:34: Driver indi_asi_wheel: Searching for HID Device VID: 0x3c3 PID: 0x1f02"
[2021-07-13T17:16:34.228 SAST DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2021-07-13T17:16:34.228 SAST CRIT ][           org.kde.kstars.indi] - INDI driver  "indi_asi_ccd"  crashed!
 
4 months 3 weeks ago #73460

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1
One more piece of feedback I rolled the indi_asi_ccd driver back to the one built on the 27 of April and now it works.

So right now i have the latest filter wheel driver and an older ccd driver.

Happy to test if there is a driver update.

Cliff
4 months 3 weeks ago #73461

Please Log in or Create an account to join the conversation.

  • Posts: 92
  • Thank you received: 11

Replied by nou on topic indi_asi_ccd crash on connect.

This looks like some version mismatch between INDI core and INDI ASI driver
4 months 3 weeks ago #73477

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1
Thanks yea was wondering if the new sdk was not the issue.

Any tips on how i can check ?
4 months 3 weeks ago #73480

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 1
I pulled the indi core and indi 3rd parry from git, built and deployed them both and now everything seems to be working correctly.

thanks @nou for the pointer.

Cliff
4 months 3 weeks ago #73503

Please Log in or Create an account to join the conversation.

Time to create page: 0.628 seconds