×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

UVC / Aptina AR0130 bad performance with Raspi4B

  • Posts: 55
  • Thank you received: 1
I just have received a UVC AR0130 Mono camera. I wan't to use it as a guiding camera.

The max exposure is 500ms. I have tried several settings, but it does not perform well with Kstars 3.5.0 and latest indilib.

I have tried different settings, but the results are the same.

Current settings are
YUYV:4:2:2 @ 1280x960

Video Stream reaches 1.5fps with 500ms exposures but a single exposure with 500ms takes about 3s:

2021-01-13T14:34:57: [INFO] Started 0.500-second manual exposure.
2021-01-13T14:34:57: [INFO] Capture of one frame (0 stacked frames) took 3.030569 seconds.
2021-01-13T14:34:53: [INFO] Started 0.500-second manual exposure.
2021-01-13T14:34:53: [INFO] Capture of one frame (0 stacked frames) took 2.973841 seconds.
2021-01-13T14:34:49: [INFO] Started 0.500-second manual exposure.
2021-01-13T14:34:49: [INFO] Capture of one frame (0 stacked frames) took 2.801923 seconds.
2021-01-13T14:34:46: [INFO] Started 0.500-second manual exposure.

200ms takes about 1-1.6s:
2021-01-13T14:38:12: [WARNING] No exposure or streaming in progress
2021-01-13T14:38:12: [INFO] Capture of one frame (0 stacked frames) took 1.081661 seconds.
2021-01-13T14:38:11: [INFO] Started 0.200-second manual exposure.
2021-01-13T14:38:10: [INFO] Capture of one frame (0 stacked frames) took 1.097628 seconds.
2021-01-13T14:38:09: [INFO] Started 0.200-second manual exposure.
2021-01-13T14:38:09: [INFO] Capture of one frame (0 stacked frames) took 1.241811 seconds.
2021-01-13T14:38:07: [INFO] Started 0.200-second manual exposure.
2021-01-13T14:38:07: [INFO] Capture of one frame (0 stacked frames) took 1.163899 seconds.
2021-01-13T14:38:06: [INFO] Started 0.200-second manual exposure.
2021-01-13T14:38:05: [INFO] Capture of one frame (0 stacked frames) took 1.097333 seconds.
2021-01-13T14:38:04: [INFO] Started 0.200-second manual exposure.
2021-01-13T14:38:04: [INFO] Capture of one frame (0 stacked frames) took 1.646151 seconds.
2021-01-13T14:38:02: [INFO] Started 0.200-second manual exposure.


When trying to use stacking f.e. additive, the driver sets the exposure to maximum and this results in only one stacked frame:

2021-01-13T14:39:55: [INFO] Capture of one frame (1 stacked frames) took 3.497064 seconds.
2021-01-13T14:39:51: [INFO] Started 1.000-second manual exposure.
2021-01-13T14:39:51: [WARNING] Requested manual exposure is out of device bounds [0.000,0.500], stacking up to 1.000 seconds using Additive.
2021-01-13T14:39:51: [INFO] Capture of one frame (1 stacked frames) took 3.523913 seconds.
2021-01-13T14:39:47: [INFO] Started 1.000-second manual exposure.
2021-01-13T14:39:47: [WARNING] Requested manual exposure is out of device bounds [0.000,0.500], stacking up to 1.000 seconds using Additive.
2021-01-13T14:39:47: [INFO] Capture of one frame (1 stacked frames) took 3.535223 seconds.
2021-01-13T14:39:43: [INFO] Started 1.000-second manual exposure.
2021-01-13T14:39:43: [WARNING] Requested manual exposure is out of device bounds [0.000,0.500], stacking up to 1.000 seconds using Additive.
2021-01-13T14:39:43: [INFO] Capture of one frame (1 stacked frames) took 3.304365 seconds.
2021-01-13T14:39:40: [INFO] Started 1.000-second manual exposure.
2021-01-13T14:39:40: [WARNING] Requested manual exposure is out of device bounds [0.000,0.500], stacking up to 1.000 seconds using Additive.


I also tried the "indi-webcam" driver, but with this ekos is crashing after indi connect ....

I also tried Motion JPEG ... with the same result :(

So any suggestions here?
3 months 3 weeks ago #65885

Please Log in or Create an account to join the conversation.

Time to create page: 0.388 seconds