×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Driver OnStep (LX200 like) for INDI

  • Posts: 320
  • Thank you received: 41
Buongiorno Ettore,
here my Motion setup.
OnStep Config.h
#define AXIS1_LIMIT_MIN              -185
#define AXIS1_LIMIT_MAX              185
 
 


 
7 months 3 weeks ago #80129
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
I'm confused, autoflip should be set to off when you want Ekos to control the flip no?
7 months 3 weeks ago #80130

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 5
Thanks Alain.
Ettore
INDI/KStars on Raspberry Pi 4, 4gb
Raspberry Bull 64bit
Skywatcher 150PDS
CGE-PRO Mount
Nikon D5300 Camera
ZWO183MM
ZWO ASI120mm
Whaveshave focuser
7 months 3 weeks ago #80131

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
Ettore,

Meridian Flip e un Casino infernale :-)

There is a lot of confusion with Autoflip.
In fact there is no command to issue Autoflip.
There are only limits that define a windows (between limiot East and limit West) where Onstep executes a flip when a goto is issued in this window and only if Autoflip is set to ON.
Otherwise when you reach the meridian cross Onstep will stop track or slew.
Ekos simply issues a goto when the HA is reached.

Maybe It is still not clear see references:
onstep.groups.io/g/main/wiki/5650
docs.google.com/document/d/11NlWvWyI5RxN...ekqkZmgQoIBw91M/edit
ma in Tedesco!
www.astrotreff.de/forum/index.php?thread...ian-flip-verhindern/
7 months 3 weeks ago #80132

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 22
I updated INDI to latest from PPA (1.9.5) and OnStep to 4.24 and now getting error upon connecting to the mount:
"Error setting UTC Offset"
I have "Time & Location Updates" enabled in INDI settings tab of Kstars.
I am getting same error even if I am using INDI settings window for changing UTC offset.
Given that UTC is not set correctly, the mount is totally lost.
Any thoughts on what is causing this issue?
6 months 1 week ago #81491

Please Log in or Create an account to join the conversation.

  • Posts: 58
  • Thank you received: 2
Yes i have the same problem!
6 months 1 week ago #81498

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 44
A while ago there was an update to the lx200 driver to remove some extra space in commands sent.
The offending area may be here
lx200driver.cpp

OLD = snprintf(read_buffer, sizeof(read_buffer), ":SG %+03d#", static_cast<int>;(hours));
// Meade Telescope Serial Command Protocol Revision 2010.10
// :SGsHH.H#
// Set the number of hours added to local time to yield UTC
// Returns:
// 0 – Invalid
// 1 - Valid
NEW = snprintf(read_buffer, sizeof(read_buffer), ":SG%+04.01lf#", hours);

return (setStandardProcedure(fd, read_buffer));
}

The lx200 2010 manual has:
:SGsHH.H# Set the number of hours added to local time to yield UTC Returns: 0 – Invalid 1 - Valid

The Command.ino of OnStep shows this
github.com/hjd1964/OnStep/blob/release-4.24/Command.ino

//  :SG[sHH]# or :SG[sHH:MM]# (where MM is 30 or 45)^M
//            Set the number of hours added to local time to yield UTC^M
//            Return: 0 on failure^M
//  
The following user(s) said Thank You: Alex Varakin
6 months 1 week ago #81504

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 22
Thank you so much, Gene, for pointers!
Isue is that OnStep is not able to parse the dot as part of the number sent from INDI, e.g.  -5.0
I think the correct fix is to implement override method as part of OnStep driver, as opposed to relying on the method of the generic LX200 driver.
As a quick fix, I worked around the problem by changing Command.ino of OnStep as shown below:

//  :SG[sHH]# or :SG[sHH:MM]# (where MM is 30 or 45)
//            Set the number of hours added to local time to yield UTC
//            Return: 0 on failure
//                    1 on success
      if (command[1] == 'G')  { 
        if (strlen(parameter) < 7) {
          double f=0.0;
          char *temp=strchr(parameter,'.');
          if (temp) {
            if (temp[0] == '.' && temp[1] == '4' && temp[2] == '5') { temp[0]=0; f=0.75; } else
            if (temp[0] == '.' && temp[1] == '3' ) { temp[0]=0; f=0.5; } else 
            if (temp[0] == '.' && temp[1] == '0' ) { temp[0]=0; f=0.0; } else { i=-999; } // force error if not :00 or :30 or :45
          }

 
6 months 1 week ago #81516

Please Log in or Create an account to join the conversation.

An override is the best way to go IMO so that it works with existing firmware.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 months 1 week ago #81523

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 44
Alex, glad the info helped!

Jasem, Ok! I closed issue #1643 but did not open one against OnStep for the issue

Gene

BTW: Forum seems to be getting worse, no response yesterday in browser over periods of time and after trying to post this same response earlier today, and post did not make it.
6 months 1 week ago #81524

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
@alex, @gene,

I pushed a fix to github.com/azwing/indi master

Can somebody test before I submit a pull request?
6 months 1 week ago #81533

Please Log in or Create an account to join the conversation.

  • Posts: 205
  • Thank you received: 44
@Alain,
Just a comment

The original lx200driver did not support non whole integer offsets (%03d), this was corrected in the base driver update (%+04.01lf).

The main GIT OnStep Command.ino also supports non whole integer offsets but limits what it will accept to :00, :30 and :45
It requires the exact strings if the ':' is included, e.g. ":00", ":30" and not :0 or :3

Now Meade command set does not cover the :45 offset directly only closely

en.wikipedia.org/wiki/List_of_UTC_time_offsets

What would be chance of adding the :00/:30/:45 capability in the OnStep overrides driver?

Disclaimer: I am not an OnStep user

Observation: Until issue 1604 the indilib community did not seem to suffer from the whole integer only offsets but if you are inside OnStep code :-)

Gene
The following user(s) said Thank You: Alain Zwingelstein
6 months 1 week ago #81548

Please Log in or Create an account to join the conversation.

Time to create page: 1.129 seconds