×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Driver OnStep (LX200 like) for INDI

  • Posts: 320
  • Thank you received: 41
@gene,

it is possible and I checked in Kstars "Settings/Geographic" and effectively there are Countries having offsets of 30' or 45'
At least I learned something today! I didn't remember Nepal having +05:45 or Western Australia +08:45 ... and I visited both countries !!!
Time modifying, doing testing and then push for review!
6 months 1 week ago #81550

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
@gene,

I fixed the UTCOffset so that now hh:00, hh:30 and hh:45 are supported.
I found a strange thing, UTC offset is rouded on 1st decimal so that 0,75 is 0,8 so I had to workaround that.
Not happy with it but it works

Any Idea?

PS: changes on github.com/azwing/indi
Last edit: 6 months 1 week ago by Alain Zwingelstein.
6 months 1 week ago #81556

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 22
Thank you so much Alain for fixing this!
I will be testing tonight.
6 months 1 week ago #81557

Please Log in or Create an account to join the conversation.

  • Posts: 48
  • Thank you received: 7
Hi.
I have a problem that the internal time of OnStep cannot get by INDI.

Set the location and date and time in OnStep.
(My OnStep uses GPS so it's automatic.)
Then connect OnStep to INDI and look at the INDI Control Panel in Ekos.
UTC is not get correctly.
Is there a solution to the cause of this problem?

OnStep is version 4.24q.
INDI is 1.9.5 running on a Raspberry Pi.
Uses the LX200 OnStep driver.

6 months 1 week ago #81576
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 22
I tested it and it works for most scenarios, except negative fraction numbers , like -1.5.
Here is the fix:
utc_min=abs((offset-int(offset))*60);
The following user(s) said Thank You: Alain Zwingelstein
6 months 1 week ago #81578

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
@Alex,

I get old .... I will make the change and issue the pull request.
By the way, any idea where comes the round up of offset (When Offset of location it n,75 Indi considers offset as n,8 ?
Last edit: 6 months 1 week ago by Alain Zwingelstein.
6 months 1 week ago #81588

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
@Norikyu,

may be setting time source in Kstars solves your problem.
I cannot test, have no time source in OnStep,

Select "Mount Updates Kstars"
The following user(s) said Thank You: norikyu
6 months 1 week ago #81589
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
Pull request issued, waiting for merge in master:

Current versions:
OnStep 4.24p
INDI Library: 1.9.5
indi_lx200_OnStep 1.15
kstars Version 3.5.8 Stable
6 months 6 days ago #81590

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 22

Wonderful!

Not sure about this particular issue, but in general, floating point math is very imprecise.
You may get some really unexpected results, e.g. instead of 2x2=4 you may get 3.999999008
The whole idea of pushing floating number back and forth for this use case is totally wrong and probably requires much bigger refactoring.
6 months 6 days ago #81599

Please Log in or Create an account to join the conversation.

  • Posts: 48
  • Thank you received: 7
Thank you for the hint.
But, I couldn't solve that.

I tried setting "Time & Location Updates" in the KStars INDI option to "Mount updates KStars".

When I tried it with Celestron AVX, I can get the location information and date and time of the AVX controller settings. And KStars will display the stars where the AVX is placed.

For OnStep Driver, the time will always be "UNIX Epoch-1 second", so KStars will display the wrong stars.
It looks like it is failing to get the internal time of OnStep.
Does the INDI OnStep Driver not support getting the OnStep internal time?
6 months 6 days ago #81602

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
@Alex,

I don't think this is due to Floatint Point Math but rather to some obscure ftoa() and atof() somewere between kstars / Ekos and Indi but I am not able to track it ...
By doing tests if I enter for example 3,75 into control panel everything is ok.
If I enter the same value via Geographic settings I get 1,8 in control panel and Indi

So must be in Ekos / Kstars but I can be wrong as many times :-)
Last edit: 6 months 6 days ago by Alain Zwingelstein.
6 months 6 days ago #81607

Please Log in or Create an account to join the conversation.

  • Posts: 320
  • Thank you received: 41
@Norikyu,

It is not OnStep that manages time and location but Indi so normally this should work.

I made the following test.
1) I did run Onstep as alway just to make sure Time / Location are as usual.
2) Disconnected OnStep and closed Kstars
3) Set my system location to Panama
4) Opened Kstars and set the Geographic Location to Panama
5) You can see Time in Time1.pgn
6) Started OnStep Driver see Time2.pgn
7) Connected OnStep see Time3.png

As you can see as soon I connect OnStep time is updates with Firmware Time




6 months 6 days ago #81608
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.864 seconds