×
INDI Library v1.8.6 Released (21 Aug 2020)

August 2020 release of INDI Library v1.8.6 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Problem ZWO EAF Focuser...

8 months 6 hours ago 8 months 6 hours ago by Marc2b.
Marc2b
Expert Boarder
Expert Boarder
Posts: 119
Karma: 1
More
Topic Author
Problem ZWO EAF Focuser... #48594
I am in trouble with my EAF focuser.
It works from Ekos/INDI Panel, but refuses to work with my joystick. The joystick does its job with the mount, but the focuser only beeps when receiving a command and does not move.
Here's my joystick config:
- Buttons 1/4 : Park/unpark mount
- Buttons 2/3 : abort slewing/abort focusing
- Buttons 5/6 : Slew rate down/up
- Buttons 9/10 : Focus in/focus out

The EAF has some kind of built in "Roger Beep" that sounds at each command it receives. In my case, that's all it does

File Attachment:

File Name: Kstars.log
File Size:28 KB
:(
In attachement my log, if someone is kind enough to have a glance... Look for '//' for my comments. Thanks in advance!

- Marc
Attachments:

Please Log in or Create an account to join the conversation.

7 months 4 weeks ago
jpaana
Gold Boarder
Gold Boarder
Posts: 277
Karma: 6
More
Problem ZWO EAF Focuser... #48608
I don't have a joystick in hand to test but from the code it seems to move the focuser in and out by steps specified in "Relative position" field, which happens to be zero by default (and doesn't get saved either...). So you could try setting that to 100 for example and see if it helps.

Remote observatory running Ubuntu 20.04 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You Marc2b

Please Log in or Create an account to join the conversation.

7 months 4 weeks ago
Marc2b
Expert Boarder
Expert Boarder
Posts: 119
Karma: 1
More
Topic Author
Problem ZWO EAF Focuser... #48609

jpaana wrote: I don't have a joystick in hand to test but from the code it seems to move the focuser in and out by steps specified in "Relative position" field, which happens to be zero by default (and doesn't get saved either...). So you could try setting that to 100 for example and see if it helps.


According to the log, the joystick receives the command with no "quantity". That's why the focuser does not move and the stepper beeps. So I guess you're right.
I'll try your solution later today and let you know. Thanks for you help.

- Marc

Please Log in or Create an account to join the conversation.

7 months 4 weeks ago
Marc2b
Expert Boarder
Expert Boarder
Posts: 119
Karma: 1
More
Topic Author
Problem ZWO EAF Focuser... #48612
It works ... Thanks Again ;)

- Marc

Please Log in or Create an account to join the conversation.

Time to create page: 0.549 seconds