×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Mac 3.5.5 beta, please test.

  • Posts: 2547
  • Thank you received: 676
Hello Fellow Mac users,

I recently built a DMG for testing the Mac build before the release of 3.5.5.  I was planning on sending this out on this forum about a week ago.  After I built it though, I found what may be a very significant bug.  So I asked for a delay in the 3.5.5 release.  I am not sure that it is actually a bug, however, it may just be some configuration issue specific to my machine.  But if it is really a bug, we should try to get to the bottom of it.  I haven't yet been able to determine a cause, but if. some folks can test to see if they have the same issue, then that might really help.  So I guess there are really two points to this beta:

1. Please, as usual, test to see that everything works well for the release in the Mac build.  Let me know of any Mac specific issues such as things not working like they do on Linux, dbus not working properly (such as in the scheduler or scripting), INDI drivers not included as they should be, or other similar issues.  Keep it just to Mac issues that are specific to this DMG please since I have my hands full right now.  As far as I can tell the bug below is the only significant issue holding us back and it shouldn't affect anyone actually doing deep sky imaging with real equipment.

2. Please, if you are willing, test to confirm the bug that I found, and maybe if you can find the conditions under which it might occur on your machine.  The bug is as follows:  If KStars locally starts up an INDI server (not connecting to one already started) that includes Guide Simulator, KStars crashes on the INDI Server startup.  At least in my testing, it seems if the INDI Server is already running or if the Guide Simulator is not included in the profile, the crash does not occur.  Incidentally, this does mean that if you start up the INDI Server in the Simulators profile from KStars with Guide Simulator included and it does crash, the INDI Server will still be running, so if you start up KStars and try the same experiment again, it will look like it works fine if you connect to the already running INDI Server.  So to test a second time, when that popup comes up that says and INDIServer is already running, you would need to tell it to start up a new one, then the crash may occur again.

The beta is posted here:  www.indilib.org/jdownloads/kstars/beta/kstars-3.5.5-beta2.dmg

Thanks,

Rob
2 months 3 weeks ago #75355

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
I usually only use kstars on my raspberry pi, but to help test I put that beta on my Mac laptop with Big Sur (11.5.1). I created a new profile with nothing but simulators and nothing crashed. It didn't auto connect on first start, but hitting the connect button brought it all up. Quitting, relaunching, and starting a new one caused it to start and auto connect devices right away with no crashes.
2 months 3 weeks ago #75356

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 5

Replied by simont on topic Mac 3.5.5 beta, please test.

Apparently the bug is not present for me.
I just started kstars, then ekos, then a profilie including the Guide simulator, and no crash occurred.
2 months 3 weeks ago #75364

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 2

Replied by John on topic Mac 3.5.5 beta, please test.

Hi Rob,

I have the bug as you describe. The bug isn't there in 3.5.4 Stable.

John.
2 months 3 weeks ago #75368

Please Log in or Create an account to join the conversation.

  • Posts: 2547
  • Thank you received: 676
John, you said it was just as I described.  Did you try removing the Guide Simulator from the Simulators profile or connecting to an already running INDIServer.  Did it not crash under these conditions as I found?  Also you noted that it didn't happen in 3.5.4, I think I downloaded the old DMG for 3.5.4 and tested it in my experiments yesterday and I think it crashed for me.  I will have to go back and try that again.

I guess the next question is what is different about my computer and John's computer vs. Simon's and Ryan's computer.  And the next question is why didn't this happen in the past but seems to happen now, what changed?  It is mysterious.

Thanks,

Rob
2 months 3 weeks ago #75393

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 2

Replied by John on topic Mac 3.5.5 beta, please test.

Hi Rob,

I did the series of actions you mentioned in your original post and the behaviour was as you described for each step, and left it there.

I just had another play, probably starting Kstars about 25 times. What I would say now is that (at least for me) the crash is less deterministic than your original post implies. So I've had crashes when
- the Guide Simulator is not defined in the profile
- several crashes in a row (where Indi Server should still be running)
- and not had crashes when Guide Simulator is defined and I've stopped Indi Server.
- I had a run of several starts when no crashes happened (Guide Simulator defined, disconnecting from Indi).

So it seems a bit more random, but generally more crashes when Guide Simulator is included.

I've tried playing with 3.5.4 Stable again, probably starting it a dozen times with and without the Guide Simulator - no crashes.

Hope this helps.

John.
2 months 2 weeks ago #75397

Please Log in or Create an account to join the conversation.

  • Posts: 2547
  • Thank you received: 676
Well if you got a crash on disconnecting INDI server, that is a cross platform bug and is already under investigation.  I’m specifically focused on this INDI startup bug since that seems to be a Mac issue and is new as far as I know.
2 months 2 weeks ago #75399

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 2

Replied by John on topic Mac 3.5.5 beta, please test.

To be clear... in the 2 sessions when I played with 3.5.5 beta to test for the crash on connect bug... all the crashes I experienced were on connect.
2 months 2 weeks ago #75405

Please Log in or Create an account to join the conversation.

  • Posts: 2547
  • Thank you received: 676
Thanks for the info.  I hope to get to the bottom of it.  It’s difficult though because it’s an issue with INDI and KStars communication of data not a clear issue with one or the other.  And it’s intermittent, only occurring under certain circumstances and we still don’t know exactly what the circumstances are.
2 months 2 weeks ago #75423

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 2

Replied by John on topic Mac 3.5.5 beta, please test.

Hi Rob,

It was clear last night so I used 3.5.5. beta outside for the first time. My setup is Astroberry (current version) on Rpi running Indilib and connected to devices and Kstars / Ekos 3.5.5. beta on my Mac. Here's my feedback.
1. Polar Align. The East / West and Angle are greyed out so I was forced to use West / 30 as I couldn't change these fields. It worked fine but less convenient.
2. Setup screen. Graphs (focus / guide) fit their frames now so much improved.
3. Plate solving - worked as expected, all good.
4. Focus. Worked as expected, all good.
5. Guiding, Much better numbers (in fact almost a 100% improvement in RMS). Not sure I believe this, seems too good to be true. Was dithering and using GPG. When I process the subs I'll see if the improvement is real. Had some dew / fog problems so guiding did get a bit lost at several points and needed being restarted several times. I suspect this was conditions nothing to do with the software and I don't think the previous version would have done any better,
7. Analysis screen - worked as expected.
8. Kstars crashes. There were none all night!!!! This is the first time in ages Kstars has run all night without crashing.

Cheers!

John.
 
2 months 2 weeks ago #75543

Please Log in or Create an account to join the conversation.

Time to create page: 0.955 seconds