×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Dome and mount greyed out in Scheduler?

  • Posts: 94
  • Thank you received: 3
I am using nightly build and the dome/mount option is greyed out in scheduler tab. As a result, the scheduler does not run.
I am using Aldi roof and can control the roof/mount normaly in ekos. Am I doing something wrong?
It worked fine before (3.6.0 stable) I went nightly build.
Last edit: 2 months 1 week ago by Nguyễn Trọng Minh.
2 months 1 week ago #86443
Attachments:

Please Log in or Create an account to join the conversation.

When was the nightly? I think I fixed this yesterday.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Nguyễn Trọng Minh
2 months 1 week ago #86444

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
Oh okay. Let me update and try again. Thanks
2 months 1 week ago #86451

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
Okay. So I updated the nightly to latest. And the mount is fixed immediately.
But the dome is still greyed out. I noticed that the dome status is Unknown (though it closed/parked, indi report this correctly before I go nightly). I disconnect the aldiroof driver and connect it again and the dome option is no longer greyed out and the dome status shown as parked closed as it should be.
2 months 1 week ago #86452

Please Log in or Create an account to join the conversation.

  • Posts: 434
  • Thank you received: 156
I have similar problem with current git version that Ekos doesn't seem to reliably register devices that are already connected in the INDI server when Ekos connects to the server. This causes boxes in scheduler to be grayed out, but also causes other issues like crash in align where the code tries to access mount device via a null pointer. Disconnecting and reconnecting devices after connecting with Ekos partially works around the issue, but for some reason capture tab doesn't seem to notice the filter wheel and doesn't show filters which prevents me from actually capturing anything as my sequences have filters set and capture just shows -- and doesn't proceed. Filters are correctly shown in align and focus tabs though. I have quite full set of devices from Ekos point of view (mount/cooled camera/focuser/filter wheel/dome/dustcap/lightbox) and they seem to be a bit randomly registered or not, usually not. Might be a timing issue due to all devices getting "connected" at once when Ekos connects to the already running INDI server?
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
2 months 1 week ago #86505

Please Log in or Create an account to join the conversation.

is this with latest GIT? I cannot reproduce the issue, all devices show up fine and Ekos scheduler checkboxes are OK.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Nguyễn Trọng Minh
2 months 1 week ago #86509

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
I use the latest nightly build. The dome still greyed out the first time I connect everything. But disconnect and reconnect it again individually solves the problem.
2 months 1 week ago #86511

Please Log in or Create an account to join the conversation.

  • Posts: 434
  • Thank you received: 156
Just cleaned and recompiled everything from current GIT, couldn't reproduce the alignment crash anymore, but "Warm CCD" remains grayed out even though the camera has cooling and capture tab correctly shows the temperature control. What also happens is that most tabs are totally grayed out until I switch optical train to another one and back.

Also noticed that Ekos -> PHD2 connection has some recent issue that it tries to send DEC guide mode setting to PHD2 before it has connected, doesn't receive response obviously, and starts deferring all further requests so that connection doesn't progress at all. It stays waiting for equipment connection to complete, but PHD2 hasn't received the request in the first place. Commenting out sending the DEC guide mode setting works around this issue and Ekos connects to PHD2 normally.

I'm not sure when these issues have appeared as I have had my equipment offline for maintenance for the summer and only recently started preparing for the season.
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
2 months 1 week ago #86526

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
So the issues is as following:
1. When I first connect all devices, the dome status says "Unknown" in INDI and I can control everything in ekos dome tab. This is a bug with the aldi roof ror. The roof does not check the status of the dome on connection and show it as unknown regardless of the status of the dome. The dome check box in scheduler box is greyed out.
2. When I press "close" in INDI, the dome report the status as Closed. The dome check box in scheduler is still greyed out.
3. If I then disconnect the dome and connect it again, the status shown as "parked closed" and the scheduler check box now works normaly. But the dome control in Dome tab in ekos is greyed out this time. I have to control the open/close of the dome via INDI device tabs.
Conclusion: it seems the dome check box of scheduler tab is greyed out on connection on every dome status except for "parked closed"
I have the work around of disconnecting the dome and then connect it again. But a fix would be nice.
1 month 1 week ago #87254

Please Log in or Create an account to join the conversation.

  • Posts: 94
  • Thank you received: 3
anyone working on this?
1 month 2 days ago #87572

Please Log in or Create an account to join the conversation.

Time to create page: 0.793 seconds